Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Unable to use SWV with Win7 SP1

Created: 29 Jan 2012 • Updated: 02 Feb 2012 | 1 comment
This issue has been solved. See solution.

I used to work with Win7 pro 32bit german and SWV 6.1 SP6 MP1 6.3.2059.

Because my Windows failed to update to SP1 for some reasons I could not identify, I did a clean install of Win7 pro SP1 32bit german on a newly bought SSD.

I then installed SWV 6.1 SP6 MP1 6.3.2059 there. Using F:\fslrdr_ as the redirect path to prevent interference with the redirect of the previous installation F:\fslrdr.

Note: I add global excludes for all drive letters except C:, which is the system drive. F:\fslrdr_ is now a different physical drive. Both drives use NTFS.

1st observation: While I could import layers, activating them did not make their contents visible in the file system. It just made no difference.

2nd observation: Any try to record a new application layer just made the installers of the applications hang, or quit with some error messages, in the moment they tried to create a file or dir on C:. No chance to re-create my layers either.

Next I cleaned up the old F:\fslrdr (booted into the old installation & deleted all layers), deleted the empty dir, re-installed SWV under the new Win7 installation now with the ever working F:\fslrdr. Alas, without success.

Then I took ownership and gave Administrators & my user full access to all files in the redirect area. This recipe helped with some other problems in the past, but not this time.

I found out there is a new SWV version: 6.1 SP7 MP2 6.4.1550. So I uninstalled the old SWV version (several times back and forward during the tries to make it work as described above), then installed the new version. Btw: all installs use the command line switches for serial number and redirect path.

3rd observation: After installing, 8 subdirectories under F:\fslrdr and registry entries are already there, although in the admin console I cannot see any layer.

4th observation: I imported a saved .vsa layer that I had exported with 6.3.2059, and got an error 1042 when I tried to activate it.

5th. observation: The original problems persist: I am unable to record any application. Because of (4), I can now not test if imported layers show up in the file system, but I doubt it, because everything else behaves the same as before.

==> Could you please give me any support how I can continue using SWV with Win7 SP1?

Martin

EDIT: I normally want the redirect area to be on a drive different to the system drive, for a small system partition and for lean system backups. But just to give it a try, I installed 6.4.1550 with the default redirect c:\fslrdr with the same problems 2 & 4.

EDIT2: Even 6.3.2059 reinstalled with the original redirect C:\fslrdr has problems 1 & 2.

Comments 1 CommentJump to latest comment

martin's picture

The described problem is an incompatibiliy between SWV (of both versions mentioned above) and AVG free antivirus software. After I had uninstalled AVG free, I was able to use SWV SWV 6.1 SP6 MP1 6.3.2059 with the fresh system. Sorry I did not mention AVG free with my problem report. Since Windows alerts so urgently to install an antivirus tool, that was already under the radar of my mind. On the old system, SWV had been installed first, and AVG came later to replace MSE.

I did not research any further (e.g. layer archive compatibility between 6.3.2059 and 6.4.1550, compatibility of AVG free, if it is installed second on this system, neccessary tampering of AVG free (it would cost me time again to research SWV exes/drivers to make them AVG exceptions)):

Since, in comparison to its undoubted advantages, SWV had confronted me with several issues, I come to the conclusion that having SWV on the machine is a headache poser. So I will try to live without SWV at the moment, and evaluate other products for pure portablization on one hand and for reliable sandboxing on the other.

These are examples of issues I experienced.

- Sudden 100% CPU load in the mid of work due to some file access rights inside of layers in the pre-6.3.2059, but without any useful hints of the cause (it cost me many hours to install Windows debug tools and search unsuccessfully after these problems).

- Inability to install Win7 SP1, again without any message or hint. This time I only read about it in the forum, but led me to the conclusion, that with any Windows problem, the first check should be to uninstall SWV, and then, it's maybe too time consuming to use it at all. See my original post. I read Jordan's post that Symantec had Microsoft disable earlier SWV versions with Win7-SP1. Why not my version if it prevented the update? Why for heaven's sake does Jordan say, only 6.3.something (above 2059) is SP1 fit, but that one is not offered to the home users?

- Several application (setup) issues resulting from incompatible file access rights inside the redirect area due to the Win7 UAC user/admin account "switch"(?) scheme

- Potential layer incompatibility of the Win7 SP1-fit SWV version 6.4.1550 with my last one, see original post.

- SWV does not claim to be a security solution, because processes inside layers can easily start processes outside of the layers through several windows mechanisms and thus "jailbreak".

- I usually still had to reinstall archived apps when moving to a fresh windows, because SID and User-ID were different, or some underlying things missing, and so the apps would not work as before anyway. Same reason prevented layer recording "to go" on a virtual machine.

- The system still tended to get somewhat corrupt, e.g. firefox would eternally repeat to re-install addons. After some months, I could not tell whether addon components were inside or outside of the layer, and why outside at all, sometines there was a write-protected version in the R and a deletion entry in the RW layer, but another instance outside of the layers. And it is sooo hard to keep layer pairs neat with the admin console!

- I never understood the marketing concept. I use it at home and free, but I would be willing to spend money for a capable software, and I am annoyed about the way important updates are hidden from home users, and how difficult it is to find download URLs.

- Usability has degraded because the altiris juice with its useful tools and addons around SVS is history, while the neccessity to have such addons is as strong as ever

- It will be only a matter of time until I experience the next job stopper with SWV. I am tired of it.

martin

SOLUTION