Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

UNC disabled, codebase still shows

Created: 20 Mar 2014 • Updated: 24 Mar 2014 | 5 comments
This issue has been solved. See solution.

Hi all,

Objective: To disable UNC and only publish the HTTP codebase under the "Download History" in " Package & Task Properties" in SM Agent(Target clients).

Scenario: Under Site-Server settings, I have disabled the "Publish UNC codebase" setting. With the NS Configurator, the "GenerateNSUNCPackageCodebases" has been unchecked. IIS services has been restarted as well.

However, with the changes, I did a "Managed task deployment", successfully pushing down a simple .vbs script. However, looking back at the SMA, the UNC codebase was still being published along with the HTTP. I've attempted restarting the notification server and running another deployment but to no avail.

Question: Is there something that I am missing out? I'm very sure I restarted both the IIS service first before launching the NS again.

Many thanks in advance for any assistance given.

Operating Systems:

Comments 5 CommentsJump to latest comment

Igor Perevozchikov's picture

Hi,

did you run "NS.Package Refresh" scheduled task on SMP Server, after receiveing these changed settings on Package Servers?

Also you can check this information ⇒

http://www.symantec.com/business/support/index?page=content&id=HOWTO2068

http://www.symantec.com/business/support/index?page=content&id=HOWTO7106

Thanks,

IP.

  1. Don't forget that, first you can find an answer for your question in Knowledge base
  2. If answer solves your question, then please mark as solution to close a thread
bryantan101's picture

Greetings,

Many thanks for the response.

I've accessed the task scheduler on the SMP server, I am however, unable to find the "NS.Package Refresh".

The closest I can see is "NS.Package Distribution".

Igor Perevozchikov's picture

What version of SMP Server you're using?

  1. Don't forget that, first you can find an answer for your question in Knowledge base
  2. If answer solves your question, then please mark as solution to close a thread
bryantan101's picture

My sincere apologies for the late response.

I am running on 7.1 but I have resolved the issue with the help of one of the community members.

  • Deploying the same software/script before disabling the publishing of UNC code-base will not  allow the SMA to inherit the changes after it is disabled on site server settings in NS.
  • There is a chance that the existing GUID data on SMA(CLIENT) side might have been corrupted.

I was advised to delete the GUID folders parked under:

X:\Program Files\Altiris\Altiris Agent\Agents\SoftwareManagement\Software Delivery

on SMA(Client) side, and rerun a test deployment on the machine and it worked.

As for NS.Package Refresh in task scheduler, I was also informed that it is only existant on the NS and not on Site-Servers.

I hope this helps anyone else who has encountered this issue.

SOLUTION
Igor Perevozchikov's picture

Of course if SMA already has received package which has codebase UNC+HTTP, he will doesn't update codebases on such package, in case if after some time admin will change codebase publishing on SMP Server.

Only if codebases publishing is changed on SMP Server and after that admin will sent a policy with package (which wasn't previouslly delivered to SMA) to SMA, then this package will be downloaded, using changed codebases.
 

If you've found how to fix your problem, then set your solution as solution.

  1. Don't forget that, first you can find an answer for your question in Knowledge base
  2. If answer solves your question, then please mark as solution to close a thread