Video Screencast Help

Unexpected exception during UpdatePersonalizationDB

Created: 03 Oct 2012 | 5 comments
mmathews's picture

Receiving the following even after the user has logged off and went home for the day.  Trying to find the source so I can resolve it.  Any ideas.  Geting anywhere between 3-5 per minute.  In the last 3 minutes I've received 15 of these messages in my logs. 

 

 

"10/3/2012 5:02:49 PM","Unexpected exception during UpdatePersonalizationDB.
**CEDUrlStart** :http://entced.symantec.com/entt?product=SMP&version=7.1.8280.0&language=en&module=dpSuxS+hYNX8MdfH0MGhR/mWd+j/0PN9McSngSS9PuOgB3gtBMm326KKKuJ3OUK1&error=237772514&build=**CEDUrlEnd**

( Exception Details: Altiris.NS.Exceptions.AeXException: Unable to lookup the SID associated with the specified account ---> System.Security.SecurityException: The caller ('PPLSI\net_adamjp') does not have the specified privilege ('View Security').

 

   at Altiris.NS.Security.SecurityMonitor.Demand(PrivilegeCollection privileges)
   at Altiris.NS.Security.PrivilegePermission.Demand()
   at Altiris.NS.Security.AccountManagement.TrusteeManager.GetByName[T](String name, ItemLoadFlags flags)
   at Altiris.NS.Security.SecurityTrusteeProvider.LookupSidFromName(String scope, String name)
The Zone of the assembly that failed was:
MyComputer
   --- End of inner exception stack trace ---
   at Altiris.NS.Security.SecurityTrusteeProvider.LookupSidFromName(String scope, String name)
   at Altiris.NS.UI.Controls.UserSettings.UserNameToSID(String user)
   at Altiris.NS.UI.Controls.UserSettings.SaveSettings(String user, String id, Object settings)
   at Altiris.NS.UI.CoreWebService.UpdatePersonalizationDB() )
( Exception logged from:
   at Altiris.Diagnostics.Logging.EventLog.ReportException(Int32 severity, String strMessage, String category, Exception exception)
   at Altiris.NS.Logging.EventLog.ReportException(Int32 severity, String strMessage, String category, Exception exception)
   at Altiris.NS.UI.CoreWebService.UpdatePersonalizationDB()
   at System.Threading.ExecutionContext.runTryCode(Object userData)
   at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Threading.ThreadHelper.ThreadStart()
 )
( Extra Details:  Type=Altiris.NS.Exceptions.AeXException Src=Altiris.NS

  Inner Extra Details:  Type=System.Security.SecurityException Src=Altiris.NS )","Altiris.NS.UI.CoreWebService.UpdatePersonalizationDB","w3wp","219"

Comments 5 CommentsJump to latest comment

Shaqzz's picture

I've got the same problem - Client+Server Management Suite 7.1 SP1. 9K nodes. Every 5-10 minutes I take about 10 such log entries.

Could it be linked with heavy SQL server load?

If you're interested in time management, visit: http://nicetm.com (it's in Russian, so if your language is different, use Google translate)

carlsson's picture

Do you have Ad import running for SMP roles?

We have this issue and i think......it is when a user changes their password before the AD import has run and changed the account/role in the SMP.

It's the only thing i can see that is consistent with the error appearing in the log.

 

C

Hojiblanca

Drew_Miller's picture

We've started seeing this lately as well. From what I can see so far, it doesn't have anything to do with the user changing their password or with AD import for SMP. The only AD import we utilize is for machines. It appeared for a user today who isn't due to change their password for another 35 days. 

I certainly hope it's not SQL load, we've got only got 4300+ nodes right now, and will wind up with about 10K nodes after our migration from 6.x to 7.1

mmathews's picture

I have since resolved this by giving the users access to view (read only) security permissions for that group which was giving the error.  Since I have not seen this error again.

 

TeleFragger's picture

I too am now seeing this issue and will look at the view security option. However I have to get approval to change that so not sure when I will be able to try...

 

Did we help you? Please Mark As Solution those posts which resolve your problem,