Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Unexpected Server Error a Few times per minute

Created: 09 May 2013 | 7 comments
compumech's picture

Hi,

I created a remote site using SEP 12 RU2 MP1, and performed a disaster recovery to get the server running, due to replication issues. The new site has an embedded database, and the primary site uses SQL. The primary site has two redundant front-ends. I've replicated content between the two, including packages and Liveupdate content, because the remote site does not have internet access.

The remote site did not update initially, so I dropped a JDB and was finally able to get the SEPM updated but the clients have not. Since I stood up this server, I have been getting an Unexpected Server Error every few minutes in the server node. I checked the scm-server-0.log and correlated it to this:

 

2013-05-09 14:59:39.823 THREAD 23 WARNING: No status. Recompile all groups.
2013-05-09 15:00:01.355 THREAD 23 SEVERE:  in: com.sygate.scm.server.task.PackageTask
com.sygate.scm.server.util.ScmServerError: com.sygate.scm.common.configobject.ValidationException: XML document structures must start and end within the same entity.
 at com.sygate.scm.server.configmanager.ConfigManagerCache.prepareTopLevelObject(ConfigManagerCache.java:383)
 at com.sygate.scm.server.configmanager.ConfigManagerCache.getTopLevelObject(ConfigManagerCache.java:275)
 at com.sygate.scm.server.configmanager.ReadonlyConfigManager.getTopLevelObject(ReadonlyConfigManager.java:24)
 at com.sygate.scm.server.configmanager.ConfigManager.getAvPolicyObject(ConfigManager.java:2567)
 at com.sygate.scm.server.publisher.compiler.Spa50ProfileCompiler.buildAVPolicy(Spa50ProfileCompiler.java:1294)
 at com.sygate.scm.server.publisher.compiler.Spa50ProfileCompiler.compile(Spa50ProfileCompiler.java:1023)
 at com.sygate.scm.server.task.PackageTask.updateProfile(PackageTask.java:1779)
 at com.sygate.scm.server.task.PackageTask.updateGroups(PackageTask.java:1414)
 at com.sygate.scm.server.task.PackageTask.checkGroupDirectory(PackageTask.java:1335)
 at com.sygate.scm.server.task.PackageTask.run(PackageTask.java:517)
 at java.util.TimerThread.mainLoop(Timer.java:555)
 at java.util.TimerThread.run(Timer.java:505)
Caused by: com.sygate.scm.common.configobject.ValidationException: XML document structures must start and end within the same entity.
 at com.sygate.scm.common.configobject.XMLHelper.parseSAX(XMLHelper.java:398)
 at com.sygate.scm.common.configobject.AbstractSchema.readXML(AbstractSchema.java:156)
 at com.sygate.scm.common.configobject.AbstractSchema.readXML(AbstractSchema.java:167)
 at com.sygate.scm.server.configmanager.ConfigManagerCache.prepareTopLevelObject(ConfigManagerCache.java:373)

 

I've never seen this error before, nor have I found any symantec article that refers to this issue.

 

I've reconfigured, ran a repair, removed replication and readded, made sure the certificate and server properties were ok, and many other things. I'm finally out of ideas, thus why I'm here. Help appreciated.

 

Thanks!

Operating Systems:

Comments 7 CommentsJump to latest comment

compumech's picture

That thread has no resolution. And I've checked everything listed, including the Catalina logs, which are inconclusive. Further the issue is not the same as the one I'm experiencing. I can log into the SEPM, there is database connectivity, and replication works. I'm just getting the Unexpected server error flooding the logs, for the reasons stated above.

 

Thanks.

W007's picture

hello,

Can you provide error screen shot ?

Also check this discussion

https://www-secure.symantec.com/connect/forums/error-sepm-log#comment-8659471

 

Don't forget to mark your thread as 'SOLVED' with the answer that best helped you.

compumech's picture

Hi,

 

Swing and a miss on both counts, and finally led to a black hole. Thanks.

 

My primary server site is the same version and I'm not getting any errors. I backed up the database, did a DR into this new environment and set it up as a replication partner, and now I am.

 

I turned logging to FINEST and dug through the logs to no avail. I'm not getting an error logging in, just the standard "Unexpected server error [Site] [Server]" in the admin node logs, and the log output I provided above is the only error that correlates to this event.

So far I'm seeing that replication is functional, clients are updating fine, and I'm not seeing other issues as a result of this thus far, but there are very few clients on this node and I don't want to bring on more until this is resolved, just in case.

Suggestions welcome.

 

Thanks.

SMLatCST's picture

 

Just to clarify, this remote site has been setup up anew, as a replication partner, but was done so using the a DB backup and Server Private keys of the original SEPM, it that correct?  Or was it setup with a DR of a dummy replication partner as per the below article?

http://www.symantec.com/docs/TECH95122

Also, as the errors relate to Package Tasks, have you tried unchecking the content and log replication options as a test?  I'm wondering if this error is a indicator of why the SEPM is failing to update (and why you had to JDB it).

I'll be honest, with the apparent lack of precedence on this issue, you may be better off logging  a case with Symantec for further investigation, or just reinstalling the SEPM again (but without any DR messing, and just allowing full replication to do its thing).

compumech's picture

Hi,

 

The approach in the article you stated was the exact approach taken. It was done because setting it up normally was impossible, due to bandwidth limitations and server disconnection issues that would occur randomly between a four hour period. Long story and I actually figured out why. Regarless, standard setup and replication is impossible.

I had initally done a straight replication without anything checked, and it ran well. The errors actually began before I even set up the replication partner, so I know it's not related to that.

For now, replication is running fine and the clients are updating. Like I stated before, everything seems to be working fine other than the error that ticks a few times a minute in the Admin-- Server node. Just wanted to see if anyone was having any similar issues out here before going to support, which at this point I'm not going to do. I'll just leave it be in the interim, and call this one unresolved.

Thanks for your help.