Video Screencast Help

Unistall Sophos

Created: 29 Nov 2012 • Updated: 30 Nov 2012 | 7 comments
donk2000cl's picture
This issue has been solved. See solution.

Hello all,

I deploying the new SEP ver 12.1.2 over a network, but the system has Sophos ver 10.0 installed, I marked the option on the client install to uninstall security software, but the setup, left both antivirus in the clients.

Do you know another method to uninstall this version of sophos?

This must be install in 500 clients many of this are out of the central office, then I need a centralized uninstall.

Carlos Espinoza

Comments 7 CommentsJump to latest comment

ᗺrian's picture

Try SEPPrep, should be on the install DVD under Tools/NoSupport

I've tried removing Sophos in the past with SEPPrep and it was not as easy as I expected.

Please click the "Mark as solution" link at bottom left on the post that best answers your question. This will benefit admins looking for a solution to the same problem.

sandra.g's picture

Unfortunately, that version of the Sophos program is not on the list of what the Security Software Removal feature can uninstall. See the PDF on the following page:

I saw a script for removing 9.5/10 in the Spiceworks Script center when I did a quick search via Google. Obviously a solution like this is not endorsed or supported by Symantec--so if you're not comfortable with using scripting then this may not be the way to go for you.


Symantec, Senior Information Developer
Enterprise Security, Mobility, and Management - Endpoint Protection

Don't forget to mark your thread as 'solved' with the answer that best helps you!

Mithun Sanghavi's picture


Symantec Endpoint Protection 12.1 RU2 includes third-party security software removal feature which uninstalls Sophos Anti-Virus 9.x and Sophos Anti-Virus 7.x only and so would I suggest 

SEPprep competitive product uninstall tool

Also, I would suggest a look at this Article:

How to uninstall Sophos Endpoint Security & Control from the command line or with a batch file.

Feel free to ask if it is not clear.

Hope that helps!!

Mithun Sanghavi
Associate Security Architect


Don't forget to mark your thread as 'SOLVED' with the answer that best helped you.

donk2000cl's picture

Ok. guys

Thank you for your sugestions I will review all. I will inform you my results.

Carlos Espinoza

donk2000cl's picture

Ok, Finally I use a script to unisntall the sophos 10. I used the following secuence:

@Echo Off
net stop "Sophos AutoUpdate Service"
net stop "Sophos Agent"
net stop "Sophos Client Firewall"
net stop "Sophos Client Firewall Manager"
net stop "SAVService"
net stop "SAVAdminService"
net stop "Sophos Message Router"
net stop "Sophos Web Control Service"
net stop "swi_service"
net stop "swi_update"
MsiExec.exe /X{12C00299-B8B4-40D3-9663-66ABEA3198AB} /qn REBOOT=SUPPRESS /PASSIVE
MsiExec.exe /X{15C418EB-7675-42be-B2B3-281952DA014D} /qn REBOOT=SUPPRESS /PASSIVE
MsiExec.exe /X{2C7A82DB-69BC-4198-AC26-BB862F1BE4D0} /qn REBOOT=SUPPRESS /PASSIVE
MsiExec.exe /X{FED1005D-CBC8-45D5-A288-FFC7BB304121} /qn REBOOT=SUPPRESS /PASSIVE
MsiExec.exe /X{9ACB414D-9347-40B6-A453-5EFB2DB59DFA} /qn REBOOT=SUPPRESS /PASSIVE

I using a batch to exe file converter (must be special not all bat2exe that exist helped me, I used one of f2ko) I created a setup.exe. After this, I created a setup from the export not creating single exe. So, I renamed the setup.exe that the system created by export operation to SEPsetup.exe and I copied the setup script in format of exe file. Then I launch the install using a existing package.

 Thank you for your suggestions.