Video Screencast Help
Scheduled Maintenance: Symantec Connect is scheduled to be down Saturday, April 19 from 10am to 2pm Pacific Standard Time (GMT: 5pm to 9pm) for server migration and upgrade.
Please accept our apologies in advance for any inconvenience this might cause.

Universal Server Postfix trying to send to root@localhost

Created: 20 Mar 2013 • Updated: 21 Mar 2013 | 7 comments
AMyers6671's picture
This issue has been solved. See solution.

Hi all. I'm on 3.3.0 MP1 (Build 9060) and getting the following in the Postfix logs:

-- sender non-delivery notification: CC98FD0370
-- message-id=<20130320060001.CC98FD0370@keys.FQDN>
-- to=<root@FQDN>, orig_to=<root>, relay=none, delay=0.06, delays=0.05/0.01/0/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=linemail.FQDN type=A: Host not found)
-- warning: no MX host for FQDN has a valid address record
-- from=<root@FQDN>, size=647, nrcpt=1 (queue active)
-- message-id=<20130320060001.C1410D036F@keys.FQDN>
-- uid=0 from=<root>

 

It almost seems like it is the default CentOS LogWatch feature trying to send to the default root account. It keeps trying to send this email (whatever it is) every 5 to 15 minutes.

Thanks,
Aaron

Operating Systems:

Comments 7 CommentsJump to latest comment

Alex_CST's picture

Yea looks like it.  I assume you didnt set your domain as "FQDN"?  Because that is what it looks like from that log snippet.  You have keys.FQDN and root@FQDN which points to the UN being setup with the domain "FQDN"

Please mark posts as solutions if they solve your problem!

http://www.cstl.com

AMyers6671's picture

No, I didn't set it to FQDN. I just modified the logs here for posting.

If this post has helped you, please vote up or mark as solution to help others looking for the same data.

 

sven_frank's picture

You might want to call support but the Issue is usually

nano /etc/crontab

You will see that footer:

SHELL=/bin/bash
PATH=/sbin:/bin:/usr/sbin:/usr/bin
MAILTO=root
HOME=/

Change it to too:

SHELL=/bin/bash
PATH=/sbin:/bin:/usr/sbin:/usr/bin
MAILTO=
HOME=/

The messages should be gone.

The problem is that postfix get's a mail for every cron execution and on some systems this setting is set up that way causing this strange mails being routed when you have a * route under mail.

If/when you consider your issue resolved, please click Mark As Solution on the most helpful response.

SOLUTION
AMyers6671's picture

Yep, I think that was it. When I looked before I only checked a few entries in the crontab and saw they redirected to /dev/null. There are at least 7 that do not and those, I believe, are trying to send statuses from when they run. Removing the mail section or adding >& /dev/null to the end should fix it.

Thanks again,
Aaron

If this post has helped you, please vote up or mark as solution to help others looking for the same data.

 

AMyers6671's picture

I actually checked the cron and found they are all being routed to /dev/null. I did have the exact issue you're indicating when upgrading past versions (3.2.x) and the crons would get rewritten. I'll give the crontab a check and see if that's part of the issue too.

Thanks for the pointers.

Aaron

If this post has helped you, please vote up or mark as solution to help others looking for the same data.

 

kavinclent's picture

Hello Aaron, 

How you modify the cron. I have same problem but don know where to start

AMyers6671's picture

You can modify it from the CLI by issuing

vi /etc/crontab

Then you'll want to add

>& /dev/null

To any line that doesn't have it. This will send the output there instead of emailing root. Another option is changing the mailto address at the top to a real, routeable address.

If you don't know how to get into the CLI or what those commands do, I'd recommend opening a support case and have SYMC support help you out. You don't want to make mistakes in there.

Aaron

If this post has helped you, please vote up or mark as solution to help others looking for the same data.