Video Screencast Help

"Unspecified error" deleting new, empty Partition

Created: 10 Jul 2013 • Updated: 11 Jul 2013 | 10 comments
This issue has been solved. See solution.

Hi all,

I'm testing out doing some mount points to move forward with EV 10.0.3. I believe mount points will be more flexible for us.

With that in mind, I got my new mount point drive, got a fresh disk from the SAN and mounted that disk at "D:\ICEV01MailStore Ptn4". The new partition created successfully. On another server, I followed the same steps, but there the partition did NOT create (error about the folder not being empty. That's not too important at the moment).

So, I thought I'd delete the partition I created first, but when I try EV seems to hang a bit and eventually gives me a dialog saying "Unable to delete the partition <ICEV01MailStore Ptn4>. Reason: Unspecified error".

The following events are also logged: 7114, 6916, 6916

Failed to delete a Partition.
Partition Entry Id : 121F4921A50519F4E84ED2BD55332FF1A1q10000icev1
Vault Store Entry Id: 1899458A8E285FE4DAE79D9BE08A71E4D1210000icev1
Internal references:
Error : Unspecified error (0x80004005)
Reference : {CDeletePartition::DeleteEmptyClosedPartition} [.\DeletePartition.cpp, lines (17){...,68,69,70,71,72,73,74,75,82,86,107,116}, built Dec 11 16:21:01 2012]

An error was encountered attempting to delete a Partition.

Reason: Unspecified error (0x80004005).
Method: CEVCollectorPublic::DeletePartition

An error was encountered attempting to delete a Partition.

Reason: SHFileOperation failed. D:\ICEV01MailStore Ptn4
Method: CEVCollectorPublic::DeletePartitionThread

I cannot find any guidance on the correct procedure to follow to delete a partition (e.g. whether it should be Closed, Open or Ready, do it while services are stopped, etc) but I assume Right click > Delete is correct.

So what's going on? The only file in the partition path is EnterpriseVaultPartitionRoot.xml. Is this because of the mount point? That's something to test while anyone reads this :)

Thanks

Richard

Operating Systems:

Comments 10 CommentsJump to latest comment

JesusWept3's picture

Any chance of a dtrace of StorageDelete and recreate the issue?

rasobey's picture

I can't see that particular dtrace option listed (through the console). The closest is Vault Store Partition Rollover issues, or maybe Collection issues?

Is this a CLI only dtrace?

Thanks :)

PS - I played with the mount point, for whatever reason the mount point info had been lost when I looked at the disk and viewed "Change driver letters and paths". Added it again but getting the same errors.

JesusWept3's picture

Yeah, just open a command prompt, CD to your EV Install directory
type "Dtrace" and press enter
type "set StorageDelete v" and press Enter
type "log C:\DeletionFail.txt" and press Enter
attempt a couple of times to delete the partition and recreate the error
and post the log

Also dtrace whatever is throwing the event in the event viewer
so if it says Storage Management as the source, dtrace storagemanagement
if it says Directory Service, then dtrace directoryservice as well etc

EV_Ajay's picture

Hi,

Try to restart the Enterprise Vault Storage Service and check whether it deleting the partition or not.

Thanks,

Ajay

rasobey's picture

Thanks jesuswept3. Got the drace now I'm at home, it's attached.

Ajay - thanks. I thought it might be useful to leave the error as is in case any more debugging is needed. I'll restart it if no sense is made of the dtrace log.

AttachmentSize
DeletionFail.txt 110.55 KB
JesusWept3's picture

OK so the dtrace is the same as the events unfortunately,
So lets concentrate on this

Reason: SHFileOperation failed. D:\ICEV01MailStore Ptn4

SHFileOperation is basically using windows shell to do file operations, such as Delete
So in this instance its Windows coming back and saying the folder could not be deleted

your best bet is to run a ProcMon and have it watch on that particular folder and see what errors you're getting back, no chance its acting as a WORM device or something like that?

SOLUTION
rasobey's picture

Interesting. Technically, it isn't a folder.

D:\>dir
Volume in drive D is Vault Store Database
Volume Serial Number is B4D9-2286

Directory of D:\

10/07/2013 16:29 <JUNCTION> ICEV01MailStore Ptn4 [\??\Volume{084c6043-e2f4-11e2-9b21-0022642
a7920}\]
0 File(s) 0 bytes
1 Dir(s) 1,039,253,504 bytes free

I can probably get round this by deleting the disk where this mount point goes to (hmm, wrong terminology), creating an actual folder on the D: disk called ICEV01MailStore Ptn4 and then trying the remove operation again. Let's try that..

rasobey's picture

Never mind. Can't delete the folder within Windows either after removing the mount point - "Folder is in use by another application". I guess that would be EV. Possibly the OS doing something silly..

I'll carry on working with this when I'm back in the office tomorrow morning and I'll update you with my findings.

Actually, just out of interest, does the EnterpriseVaultPartitionRoot.xml file need to exist for this to work properly? What is the purpose of the file?

JesusWept3's picture

Its there to identify what vault store the partition belongs to etc for integrity purposes
for instance you might accidentally restore PTN4 to the PTN3 location etc, its more a placeholder than anything else

Its also good if you're setting up vault stores for the first time and you dont try and point multiple partitions to the same location etc

As for the folder being in use, you can use wholockme or other utilities to find what has the lock on the particular folder, its doubtful that its EV, but that being said its always a good idea to disable Opportunistic locking etc

rasobey's picture

Ah. Tried it again this morning, don't think I did anything different but it's worked now. Who knows :)

Edit: marked one of JW3 posts as the solution - that led me to find cmd.exe had the folder open. I swear it wasn't last night anyway!