Video Screencast Help

Update to catalog index (Catalog index database) failed

Created: 14 Apr 2014 | 4 comments

Dear all,

I got trouble with Backup Exec 14.0 SP4 as the title.

We can backup successfully to tap, but come with error message "ODBC access error. Possible lost connection to database or unsuccessful access to catalog index in the database."

and when we tried to do Restore, there is nothing

In window event, we have:

Event Type:    Error
Event Source:    Backup Exec CatErrorHandler Server
Event Category:    None
Event ID:    34327
Date:        4/15/2014
Time:        11:30:32 AM
User:        N/A
Computer:    MASTER
Update to catalog index (Catalog index database) failed.
Reason:  [Microsoft][ODBC SQL Server Driver][SQL Server]Must declare the scalar variable "@PluginType". cat_RecordSet::ExecuteBulkInsert()
sp_sproc_columns CatImageInfoProc 

 For more information, click the following link:

I googled for same issue and tried to fix, but it didn't work.

Here is detail of my server

Windows: Windows Server 2003 32bit

Backup Exec: Version 14.0 Rev 1798 (32bit) - still in trial version.

Storage: HP LTO 5

Operating Systems:

Comments 4 CommentsJump to latest comment

pkh's picture

I think your BEDB is corrupt. Go the BE installation and use BEUtility to install a new BEDB.

SA_Techie's picture


Are you getting this error after an upgrade ?

Rename existing catalog folder. Run catrebulidindex -r command in cmd prompt

Restart backup exec services and run inventory and catalog on the tape.

Make sure you uncheck "storage media based catalog" option before cataloguing the tapes

Check if that works...

suyenpham's picture


I tried, but it didn't work

Here is repond after issue catrebuildindex -r 

dbutil RunSQLScript: E:\Program Files\Symantec\Backup Exec\betopcat.sql SQLServer:MASTER SQLInstanc
:BkupExec DatabaseName:BEDB
OpenFromInitializationString Connection String = Provider=SQLOLEDB.1;Integrated Security=SSPI;Persi
t Security Info=False;Initial Catalog=BEDB;Data Source=master\BkupExec;Locale Identifier=1033;Appli
ation Name=BEWS DBUTIL hr=0x0

        dbutil RunSQLScript: execute sql cmd failed.  sql statement:

CREATE PROCEDURE [dbo].[CatImageInfoProc] (
        @StringBufferSize int  ,
        @ImageId bigint,
        @ImageVersion int ,
        @PlugInType int ,
        @ImageNumber int ,
        @ResourceID bigint ,
        @BackupType int ,
        @BackupDate int  ,
        @BackupTime int ,
        @Status int ,
        @ExtStatus int ,
        @NumDirs int ,
        @NumFiles bigint  ,
        @NumCorruptFiles int  ,
        @NumFilesInUse int  ,
        @NumBytes bigint  ,
        @PswdEncryptAlgo int  ,
        @FDDSeqNum int  ,
        @FDDPBA int  ,
        @FDDVersion int  ,
        dbutil RunSQLScript:Stop execution sql script
dbutil RunSQLScript: failed: 0x80040e14
OS ERROR: 0x80040e14 (-2147217900)

CleanupDBForReIndexing: SchemaUpgrade failed.

SA_Techie's picture


Is this issue started after an upgrade or migration? If this started after migration then you must run bemig command for the schema change

if that doesnt work then you may have to raise a support ticket with symantec to work on this issue