Video Screencast Help

Update (MSWU-650) Problem

Created: 11 Oct 2012 | 11 comments
Ray OConnor's picture


It seems that update (MSWU-650) is applicable to my computer. Afterall, Microsoft says, "An instance of the JScript scripting engine leaks memory when Internet Explorer 8 or Internet Explorer 9 is installed on a computer that is running Windows 7 or Windows Server 2008 R2."

I have Windows 7 and IE9 installed. In screenshots, here is what I am experiencing:

Here is what happens when I run this update manually.

I've looked at the log and here is what I see:

Any ideas as to why the logic in checking the applicability of the patch seems bad?


Comments 11 CommentsJump to latest comment

Ray OConnor's picture

Here is the information from the log file in a better viewing format.

10/11/2012 10:06 SoftwareUpdateAgent PatchMgmtAgents.dll Failed to apply software update [MSWU-650]:Windows6.1-KB2707082-x86.msu
10/11/2012 10:06 SoftwareUpdateAgent PatchMgmtAgents.dll Advertisement {5C91D943-6C1D-4446-B7A6-127FC69BCAF9} completed status (5) exitcode (-2145124329)
10/11/2012 10:06 ProgramExec smfagent.dll Program 'Windows6.1-KB2707082-x86.msu for 09-2012 Microsoft Updates 2' completed. Exit code=-2145124329
10/11/2012 10:06 ProgramExec smfagent.dll Starting SWD task: 'Windows6.1-KB2707082-x86.msu for 09-2012 Microsoft Updates 2' command line='wusa.exe Windows6.1-KB2707082-x86.msu /quiet /norestart'
10/11/2012 10:06 SWDAgent smfagent.dll Add SWD task Windows6.1-KB2707082-x86.msu for 09-2012 Microsoft Updates 2 {5C91D943-6C1D-4446-B7A6-127FC69BCAF9} to run queue
10/11/2012 10:06 SoftwareUpdateAgent PatchMgmtAgents.dll Installed Rule evaluated FALSE for Windows6.1-KB2707082-x86.msu.
10/11/2012 10:06 SoftwareUpdateAgent PatchMgmtAgents.dll Applicability check evaluated TRUE for Windows6.1-KB2707082-x86.msu
10/11/2012 10:06 SoftwareUpdateAgent PatchMgmtAgents.dll Custom applicability check called for Windows6.1-KB2707082-x86.msu
10/11/2012 10:06 SoftwareUpdateAgent PatchMgmtAgents.dll Installed Rule evaluated FALSE for Windows6.1-KB2707082-x86.msu.
10/11/2012 10:06 SoftwareUpdateAgent PatchMgmtAgents.dll Applicability check evaluated TRUE for Windows6.1-KB2707082-x86.msu
10/11/2012 10:06 CAuxilliaryPackage PatchMgmtAgents.dll execute AeXPatchAssessment.exe -out Shavlik_applicability.xml succeeded (0x0)
dsmith1954's picture

The same error with a different application can be found here:

The patch probably is missing something that Patch Management is looking for, but the OS thinks the patch is already installed.

The fix in this kb is that the patch should be uninstalled and then re-installed. I'd give that a try.

Ray OConnor's picture

I'd uninstall it as you suggest, but it is not installed in the first place. The error shown above originally specifies nothing about the update being installed already, but that it isn't applicable.


dsmith1954's picture

The exit code in the initial post - 2149842967 - also indicates the patch is not applicable. A Google search revealed several posts that indicated the patch may already be installed, just not fully, so that's why the suggestion to see if the system thinks it's installed and to remove it. Shavlik does a more thorough check, so there may be something in the registry making the OS think it's installed and therefore not applicable.

This post has other suggestions as well:

One solution was to run WindowsUpdate and then check the Windows Update log for any errors.

Another solution was to check and see if the Windows Update service was running. I'm sure is/was, otherwise the patch would have failed with a different error.

Another suggestion is to reset Windows Update components -

If all that passes, then run the System Readiness Tool from MS -

Ray OConnor's picture

Thank you for the suggestion, but I hardly see how it helps. That article alludes that you would have to run the Import Patch Data for Microsoft task to resolve an issue for patches in March. I'm trying to troubleshoot an issue with an update from September. I've been running the Import Patch Data task every day since March....


dsmith1954's picture

Don't discount the need to update patch data because the TechNote was in March and this is October. It wouldn't be the first time an error was made in a patch assessment.

As indicated above, exit code (-2145124329) means that the patch does not apply to your computer.

The last line in the log file indicates that Patch Management is using a Shavlik which usually does a more detailed assessment than a typical MS assessment. If there is something wrong in that Shavlik file, then it could indicate the patch was needed when it may not be. So there could be a need to download a new file from Symantec.

If your file from Symantec is the latest, I'd open a ticket with Support to have it checked out.

While waiting on Support, I'd download the file directly from MS and try to install that one. Could be the file on your computer is corrupt.

One other thing comes to mind, are you running 32 bit or 64 bit Windows 7? If 64 bit, that is why the patch doesn't apply to your computer.

Ray OConnor's picture

Just to make sure I'm on the same page and doing things correctly, where would I go to "update patch data?"


Roman Vassiljev's picture

Hi Ray,
It is said at that "If you have security update 2706045 installed, you do not have to install this update."
Could you please check - Is KB2706045 installed on affected machine or not?

Also please provide us with the following files from machine where issue is observed.
- Go to directory "C:\Program Files\Altiris\Altiris Agent\Agents\SoftwareManagement\Software Delivery\{6D417916-467C-46A7-A870-6D86D9345B61}\cache\" and attach 2 files: STPatchAssessment.log & STPatchAssessment.xml
- Go to directory "C:\Program Files\Altiris\/Altiris Agent\Agents\PatchMgmtAgent\" and attach file InstallLog.csv

Thank you,

Ray OConnor's picture

It looks like the MSWU-650 update is no longer in the list of software updates on my reference computer. As DSmith pointed, I wonder if the Import Patch Data task ran last night (like it usually does every night) and something was updated. No. My reference computer does not have KB2706045 installed.

AttachmentSize 3.02 KB
STPatchAssessment.xml 61.26 KB 50.39 KB
Ray OConnor's picture

Oh by the way..Thanks for all the suggestions and help.