Video Screencast Help

Upgrade of customer DB fails when installing 10.0.4 CHF1

Created: 16 Oct 2013 • Updated: 16 Oct 2013 | 6 comments
This issue has been solved. See solution.

I just upgraded my Enterprise Vault environment to 10.0.4 CHF1 and have run into an issue when upgrading the DA customer DB's. The DA database is hosted on a SQL 2005 standard edition server. When attempting to upgrade the cusomter DB's I get the following error: "Online index operations can only be performed in Enterprise edition of SQL server." The State then says "UpgradeFailed" and I cant get past it. Any ideas? I will open a case with support but thought I'd post here too. I tried putting the DB in single-user mode and restarting the EVAM service, but the same thing happens.

Operating Systems:

Comments 6 CommentsJump to latest comment

BigPhil's picture

Ok, I figured it out. The following two sql update scripts need to be modified (I'm sure Symantec will release a v2 update to fix this issue once I update the case with my findings). So, once you install CHF1 on the Discovery Accelerator server and if your SQL server is NOT Enterprise Edition, you need to change the following two files before upgrading the Cusotmer DB's.

C:\Program Files (x86)\Enterprise Vault Business Accelerator\

AcceleratorDatabase.sql, line 76098, ONLINE = OFF
AcceleratorDatabaseSchemaUpdateV10SP4.sql, line 289, ONLINE = OFF

After modifying the files, you can successfully upgrade the DA cusomter databases.

Philip Nunn EV 10.0.3 on Windows 2008 R2 SP1, Exchange 2007 SP3 RU 10 CCR on Win2008 x64, ESXi 5.1, Mircosoft TMG, NetApp/EqualLogic storage

If this response answers your question, please mark it as solution

SOLUTION
Rob.Wilcox's picture

Well done for figuring it out - not so good that it was released with the problem in the first place :(

Kenneth Adams's picture

Thank you for notifying us of this issue, BigPhil.  We'll be opening an Engineering Track (Etrack) with Engineering about this issue to either get a fix or (maybe and) get their blessing to publicly provide customers with replacement files having the fix that you found.

Ken Adams

Backline Support for CA, DA, ACE, UCE, PSTD, ARMS, EVDC
US Support Region

GertjanA's picture

Saved my day BigPhil.

Thanks for sharing!

Thank you, Gertjan, MCSE, MCITP,MCTS, SCS, STS
Company: www.t2.nl

www.quadrotech-it.com

www.symantec.com/vision

Chris Harrison's picture

Thanks for the spot...we'll re-release with this fixed in the next couple of days. In the meantime, you're fine to modify "ONLINE = OFF" or indeed remove the line

"WITH (ONLINE = ON, ALLOW_ROW_LOCKS = ON, ALLOW_PAGE_LOCKS = ON, FILLFACTOR = 90) ON [PRIMARY] "

from both the AcceleratorDatabaseSchemaUpdateV10SP4.sql and AcceleratorDatabase.sql for the tblHashToDiscoveredItem index being created.

Chris

Symantec Enterprise Vault Engineering

Customer Focus Team

Chris Harrison's picture

Just to finish off, we've re-released the cumulative hotfix so that it no longer has this issue. For those stuck in limbo (if you haven't manually resolved the situation already) please refer to the following technote for further information:

http://www.symantec.com/business/support/index?page=content&id=TECH211817

Chris

Symantec Enterprise Vault Engineering

Customer Focus Team