Video Screencast Help
Scheduled Maintenance: Symantec Connect is scheduled to be down Saturday, April 19 from 10am to 2pm Pacific Standard Time (GMT: 5pm to 9pm) for server migration and upgrades.
Please accept our apologies in advance for any inconvenience this might cause.

Upgrade Redhat Oracle Server Agent

Created: 17 Jun 2013 • Updated: 16 Aug 2013 | 11 comments
AndrewPilgrim's picture
This issue has been solved. See solution.

Hi,

We have to upgrade 4 Redhat Linux servers from their current client version of 7.0.1 to 7.1.0.4 to match the Master/Media server in an attempt to see if this helps fix a problem we have with them failing with Status 24 errors. Its been suggested to us that we do this by Symantec Support.And once again i am stumped by what should be a simple piece of work.

I realise we have to go to the major release first (7.1) and from there apply the upgrade to take us to 7.1.0.4. My question is around the procedure. Can we just run the install for 7.1 and it will upgrade to that and then do the same for the 7.1.0.4 upgrade or do we have to remove the existing client software first, then re-install from scratch?  If we do have to remove the current version apart from bp.conf is there anything else you would recommend we take a copy of before hand to use as reference after the upgrade?

I've done some digging around and find nothing to give me a definative answer on this.

And with these being Oracle servers do we need to worry about this as part of the upgrade? I assume we don't, and that as part of the Redhat client install it will do whatever is required?

Thanks

Operating Systems:

Comments 11 CommentsJump to latest comment

captain jack sparrow's picture

Hope admin install guides were friends of yours :-)

Inline upgrade is good. Let's say upgrade 7.0.1 to 7.1, subsequently with 7.1.0.4.. You are done with 

Make sure you refer release notes for any limitations as such.

 Cheers !!!

CJS

 

Yogesh9881's picture

oohh  Status code 23/24  crying

not sure upgrade will resolve your issue !! let us know if resolved ...

but if you have any database backup scripts on client then copy those to safe place b'coz netbackup client upgrade will overwrite your scripts with sample scripts.

If this post has helped you, please vote or mark as solution.

Before break-up, make sure you have a good backup.....  ;-)

Dyneshia's picture

For clients, the quickest way would be to uninstall 7.0 and install 7.1 then apply the 7.1.0.4 patch.

Marianne's picture

Which OS is your master server?

Unix/Linux Clients can be upgraded from master server with no need to first go to 7.1 and then patch to 7.1.0.4.

update_clients script on master will push latest client binaries to clients. 

If master is some other Unix version, you can install and patch client binaries for Linux on master server, and then push updated binaries to clients, which includes all agents and options.
Instruction in NBU Installation Guide for Unix/Linux.

 

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

AndrewPilgrim's picture

@Marianne - Our Master server is running on a Windows 2008 R2 server so guess we need to do it all manually since dont imagine there is a way of pushing out the update to Redhat from there.

@Dyneshia - If these are Oracle servers to uninstall the agent do we need to worry about doing anything like having the D/bases shut down etc? Or can we remove it as described in the "Netbckup Installation Guide for Linux and Unix"

@Yogesh9881 - I agree, i doubt this will solve the Error 24. We have a long running case open trying to identify what is going on and just trying to eliminate possible causes because its a real pain now. And this is one of those steps. if it works i will for sure post something on this thread.

Marianne's picture

Right. You need to upgrade manually.

There is no need to uninstall first - just run the 7.1 installation followed by the patch.

Please verify link library after upgrade - see http://www.symantec.com/docs/TECH158276

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

AndrewPilgrim's picture

We have tried this upgrade twice now to bring the client up to 7.1 without removing the current client, but both times it seems to run the install but nothing actually changes. Will try removing the old client first and see what happens but something is not happy.

Will post and update and close thread once we have got this sorted.

Yogesh9881's picture

below command will tell you what existing NBU version (run on client system)

usr/openv/netbackup/bin/goodies/support/versioninfo –f /usr/openv/netbackup/bin/libobk.so

 
 

If this post has helped you, please vote or mark as solution.

Before break-up, make sure you have a good backup.....  ;-)

AndrewPilgrim's picture

I am marking this thread as solved. I cannot tell you exactly what happened as it was solved when i was away on holiday. Not sure how they removed and installed the 7.1 client but by doing this it instantly solved our Error 24s we were seeing. Why? No idea but it did.

SOLUTION