Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Upgraded SEP Clients (12.1.4) Requires a Restart

Created: 11 Aug 2014 • Updated: 11 Aug 2014 | 7 comments


I recently upgraded our SEPM to 12.1.4 and been pushing out the new client version to all servers. I noticed that the servers that got the updated client are prompting for a reboot (Symantec Endpoint Protection requires a restart. Please reboot your computer). These servers are running critical applications and can't be restarted. Is there a way to remove the prompt or manually restarting the SEP process without rebooting the servers? I tried the recommendation from here but the services start and stop options are grayed out.

FYI, I pushed the client update (silent install) by → Clients → Select the Client Group → Install Packages → Add both the 32 and 64bit clients. Also, the client install settings is set to "No restart". Any suggestions? Thanks



Operating Systems:

Comments 7 CommentsJump to latest comment

.Brian's picture

This needs to be set at the client group level as well. On the Clients page >> Policies tab >> General Settings >> Restart tab, you need to edit the Restart settings options here.

A description of the Symantec Endpoint Protection 12.1 client Restart Settings

Please click the "Mark as solution" link at bottom left on the post that best answers your question. This will benefit admins looking for a solution to the same problem.

Gentry_38's picture

Thanks for the prompt reply Brian. I check the settings and it's also set to "No restart". 


SMLatCST's picture

Just to clarify, are these servers actually performing a restart, or just prompting for one?

The thing is, without the restart, the clients don't upgrade but instead stay on their original versions.  This is due to the new method of client upgrades in SEP whereby the new client is silo'd into a separate folder and only swapped in during the reboot.

This method helps to maintain a fully operational client (and therefore fully protected endpoint) throughout the process.


You might also find this helpful:

Gentry_38's picture


The servers are not performing a restart but just prompting. And you're correct about the other part that client don't get upgraded if a server is not restarted ( I just tried restarting 1 non-critical server and the client is now showing 12.1.4) but is there any way to prevent the restart to get the new client version? Thanks

SMLatCST's picture

Nopes, not that I know of.

As the second (forum) link I posted from a Symantec employee states, there's no way to avoid the reboot in an upgrade I'm afraid.

Chetan Savade's picture


Attached screenshots are not visible however if you have selected ' No restart' then SEPM will not initiate the reboot forcefully. Warning message will be there as a reminder.

Here is the more description about restart settings:

  • Forced restart: Forces the computer to restart at the time you specify. The computer user does not receive an option to delay the restart.
  • Delayed restart: Set the maximum time delay to restart the computer. The user will have the option to temporarily delay the restart, but only up to the maximum time you allow. When the allowed time is elapsed, the user is prompted that a restart is imminent, and has 60 seconds to save data and close applications.
  • No restart: User's computer will not be restarted. When a restart on the user's computer is required, indication of a pending restart appears on the SEPM.
  • Custom restart: This option allows customization of the computer's restart behavior.

But it's necessary to restart the computer in order to complete the installation or migration.

I would suggest to go through this article:A description of the Symantec Endpoint Protection 12.1 client Restart Settings 



Chetan Savade
Sr.Technical Support Engineer, Endpoint Security
Enterprise Technical Support

Don't forget to mark your thread as 'SOLVED' with the answer that best helps you.<