Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Upgrading Discovery Accelerator not happening

Created: 09 Jul 2012 • Updated: 13 Jul 2012 | 7 comments
This issue has been solved. See solution.

Hi,

We upgraded EV from 7.5 SP5 to 8.0 SP5. During this, found Discovery Accelerator is not supported for 7.5 SP5 to 8.0 SP5. Hence tried reinstalling DA but of no use. Getting "The instance 'EVBADiscovery' is currently unavailable; an administrator must upgrade it before clients can connect" while trying to connect from Discovery Accelerator client.

How can we over come this? Please help.

Rgds, Guru.

Comments 7 CommentsJump to latest comment

RahulG's picture

You have proably upgraded the Da database but the customer databases are not Upgraded>

refer http://www.symantec.com/business/support/index?page=content&id=TECH165459

SOLUTION
GuruPrasadNS's picture

It is as it is since long time, say many months;

Version: 7.5 revision 80
State: Upgrade
Customer's tasks: Stopped

Upgradation happened some 6 months back. Since then we havent used DA.

Rgds, Guru.

Regards,

Guruprasad.

GuruPrasadNS's picture

Tony Sterling says here http://www.symantec.com/connect/forums/discovery-accelerator-web-page-not-opening to my same problem which was reported then that to

Delete the DA Databases from SQL

But I am seeing EVConfiguration DB as well as EVDiscovery DB for my Discovery Accelerator installation.

Since I am not sure what exactly EVConfiguration DB is used apart from my Discovery Accelerator, how can I make sure of this? Is whether EVConfiguration DB is only and exclusively used by Discovery Accelerator and also since I have CA also exist along with DA in my environment, is there any possibility EVConfiguration is holding things of other EV components?

Rgds,Guru.

Regards,

Guruprasad.

GuruPrasadNS's picture

I made a wrong comment.

CA is not colocated with DA. CA was in other physical server, which is currently crashed and not online.

We had UCE in the same box where DA was installed, which we uninstalled since we were not using.

Now we only only DA installed and no other EV components in the box.

-Rgds, Guru.

Regards,

Guruprasad.

TonySterling's picture

You need to actually run the upgrade process on the databases.  Thes steps are for 9 but will work for 8 I believe.

  1. When the installation process has completed, open the Accelerator Manager Web site (typically, http://server_name/EVBAAdmin).
  2. Click Update to update the configuration database.
  3. Follow the on-screen instructions to restart the Enterprise Vault Accelerator Manager service. You can use the Services snap-in to Microsoft Management Console to do this.
  4. In the Accelerator Manager Web site, click OK.
  5. Click Upload License to import your license key file for Discovery Accelerator
  6. Follow the steps below to upgrade each customer database:

    1. In the left pane of the Accelerator Manager Web site, right-click the name of the customer database and then click Properties.
    2. If you are upgrading to Discovery Accelerator 9.0 from Discovery Accelerator 2007 SP6, specify at least one database location for the analytics table file groups and indexes. You can use the default database location if you do not intend to use the analytics feature with this customer.

      The database locations must reside on the SQL server, and you must use local paths to refer to them. For example, do not use UNC paths to refer to database locations. The Accelerator Manager Web site does not verify that the specified locations exist. You must ensure that the paths are valid.

    3. In the Customer dialog box, click Upgrade.
    4. Monitor the upgrade progress until it has completed and the customer status is Running.
GuruPrasadNS's picture

Had followed all the steps you mentioned above, except adding Database Locations for Analytics. After adding so upgrade started and completed successfully. Found particular this thing is missing everywhere.

Anyways, Symantec connect and knowledge base is great enough to handle its applications and run the show.

Thank you all for the kind replies and guidance.

Rgds, Guru.

Regards,

Guruprasad.

GuruPrasadNS's picture

Thank you, both.

If in the article http://www.symantec.com/docs/TECH165459 it is mentioned about database locations for analytics should be present for upgrading the database would make it complete, as far as my condition is concerned.

Rahul, marking your reply as solution as you mentioned it first.

Regards,

Guruprasad.