Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

USB 3.0 Controller & Hub Drivers Use With Boot Wizard

Created: 18 Nov 2012 | 14 comments
MKH's picture

Hello:

Can USB 3.0 storage devices be used with Ghost Boot Wizard when WinPE is used as the preOS?

I tried to import some Asmedia USB XHCI 1042 controller hub drivers into the Deploy Anywhere driver database but was not successful in doing so. I also tried drivers from several other manufactures but I was not able to get them to work either. I have successfully imported SATA III and DOS RAID drivers.

I recently purchased an ASRock motherboard with an Asmedia USB 3.0 XHCI 1042 Controller Hub and when I was not able to see any devices plugged into it in the BIOS I called ASRock and they said USB 3.0 devices are only available in Windows when the drivers are installed that they cannot be seen in the BIOS and are not available to boot from.

Is it possible to get the boot wizard to work with USB 3.0 under the circumstances and if so how?

Sincerely,

Mark

Discussion Filed Under:

Comments 14 CommentsJump to latest comment

EdT's picture

Yes, it should be possible to get USB3 working under WinPE - I know as I have done it.

Please do not confuse the Deploy Anywhere database of drivers with the WinPE driver list as maintained by Ghost Boot Wizard. DA drivers are specifically for the TARGET operating system and not for WinPE.

The version of WinPE used in Ghost is based around the Vista kernel, so you need to add Vista 32 bit drivers for your USB3 chipset into Ghost Boot Wizard, and make sure the added drivers are selected. WinPE is "windows", but cut down to remove most of the GUI components, so basically an updated DOS. However, it still uses Windows drivers and does support USB and plug and play, so no issues there.

Depending on the USB3 device you are attaching, you may also need to add any USB3 drivers that come with the device.  (A Hitachi 2Tb external USB-3 drive I own, comes with USB-3 drivers which need to be loaded as well, but I think that is the exception rather than the rule).

You can also mount drivers into WinPE from the command line using DRVLOAD - this is useful for testing candidate drivers before adding them permanently using GBW.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

MKH's picture

Thanks for responding to my inquire. Below are some steps I have taken in an attempted to import USB 3.0 controller hub drivers but have yet to succussfully do so.

(1) Opened Symantec Ghost Boot Wizard - PreOS Version
(2) Selected Windows PE
(3) Clicked on the Edit Button
(4) Selected WinPE-512
(5) Clicked on the Copy Button
(6) Typed a name for a new database
(7) Selected the Storage Drives Tab
(8) Obtained the Vista drivers for my Asmedia XHCI 1042 USB 3 Controller HUB and saved all the files into a folder. The driver files are:

Inside the driver folder:

amd64 - Folder
 asmthub3.sys - file
 asmtxhci.sys - file

i386 - Folder
 asmthub3.sys - file
 asmtxhci.sys - file

ia64 - Folder
 asmthub3.sys - file
 asmtxhci.sys - file

Files not in seprete folders

asmthub3.cat - file
asmthub3.inf - file
asmtxhci.cat - file
asmtxhci.inf - file

I completely uninstalled my drivers in Windows and reinstalled them using the above information.

(9) Clicked the Add New Driver Button
(10) Clicked the Browse Button and navigated to the folder with the drivers in it and ensured the path to the drivers is in the location feild.
(11) Typed a friendly name in the Friendly name feild.
(12) Selected Vista as the OS
(13) Clicked the Ok Button

I received a message "Failed to import driver"
Failed to find any drivers to add.

When I experience this I tried other drivers.

I succussfully imported several DOS RAID drivers.

I sucessfully imported a Windows SATA III Controller driver.

I tried other USB 3.0 Controller drivers from Etron, Fresco and Renesas but I was not able to get them to import either. I noticed the manufactures have developed one driver for all Windows versions but when given the choice to select Vista drivers I selected it. I noticed all the USB 3.0 drivers do not have OEM text files in them like the other drivers I successfully imported. I am not sure where an OEM text file is required to work with Ghost and WinPE.

I have not found any instructions on how to use the DRVLOAD command.

Sincerely,

Mark

 

 

EdT's picture

Here is a link to a technote on DRVLOAD: https://www-secure.symantec.com/connect/articles/do-i-have-correct-driver-winpe

You need to gather the 32 bit Vista driver files for your hardware, consisting of a .INF, .CAT and .SYS file as a minimum. TXT files are for information and are not used by the drivers. If any DLL files are present then include them as well.

If you have a working operating system with USB-3 drivers loaded, then go into device manager via Control panel and find the hardware ID for the USB-3 chipset.  Open the candidate INF file in a text editor and check whether the hardware ID is represented in the INF. If it is not, then the driver will not load.

Once you have identified a set of working drivers via the DRVLOAD technique, then you can add these drivers with Ghost Boot wizard.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

MKH's picture

Thanks for your help!

I was able to manually load the drivers in WinPE using the DRV LOAD command and create a backup to a device plugged into one of the USB 3.0 ports on my motherboard. I still am not able to import the drivers from the WinPE drivers page under the storage drivers tab. I looked at the structure of the WinPE, WinPE 512 templates and it looks like if I wanted to manually add the drivers to a template I would have to add the driver information to the drivermanifest.txt files which exist in several places and add the drivers in several locations within the template for the drivers to load correctly, I believe this is beyond my scope at this point because of the type of information the drivermanifest files calls for and I do not understand their relationship  with the drivers. I am wondering if there might be a way to add drivers from the DRV LOAD command line after WinPE is loaded from a Ghost boot package?

Sincerely,

Mark

Did I buy a cheap motherboard with a BIOS that cannot see devices plugged into the USB 3.0 ports or is that the standard for all on motherboard USB 3.0 controllers?

EdT's picture

Adding drivers is accomplished by the Ghost Boot Wizard. Once the drivers are added, they then need to be selected and a new bootable image created.  You could of course have the drivers on a USB stick and just run a batch file to DRVLOAD them after WinPE has booted, but that is a lot more hassle long term than just updating your boot image.  Do not get confused with Deploy Anywhere, as this is an entirely separate driver database.

I cannot comment on whether you have bought a cheap motherboard, as you have not mentioned price or model. What I can tell you, however, is that my high quality and quite expensive ASUS motherboard has some dedicated USB-3 ports which need the appropriate drivers loaded by the operating system before they will function. It does, however, provide a plethora of USB-2 ports which will happily detect a USB-3 drive albeit they will only talk to the drive at USB-2 speeds.

There are also some USB-3 flash drives around now, but you will not get USB-3 speeds out of them as flash memory technology is just not fast enough to run at the full USB-3 speed. However, our tests have shown that you get pretty much the full USB-2 performance on a USB-3 port, which is a significant improvement over the previous generations of (cheap) sticks.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

MKH's picture

Thanks for your response and information.

Every time I try to add the USB drivers to the WinPE or WinPE-512 preOS options I continue to get a import fail message that says no driver information found. I have verified the driver information that I am trying to import is valid. I have successfully loaded the drivers by closing the boot wizard that loaded via WinPE and using the DRVLOAD command then using the command prompt to restart the Ghost32.exe located in the Ghost directory.

Over the holidays I downloaded the Automated Installation Kit for Vista from the Microsoft website and created a new WinPE_x86 boot package and successfully added the drivers. I then replaced the boot.win in the sources directory of a boot package I have on a USB stick I use in the USB 2.0 ports on my motherboard because the BIOS cannot see the USB 3.0 ports. When WinPE loaded the boot wizard never did. Come to find out WinPE load on X: and the Ghost package was on the last available drive letter on my system J;. So using the WinPE command prompt I changed the drive letter to J: and loaded the boot wizard. When I selected local drive to image in boot wizard there was my 32 GB Patriot Rage USB 3.0 flash drive plugged in the USB 3.0 port  that is rated at writing up to 50 MB/s and reading at up to 180 MB/s. Ghost successfully created an image of a drive with 10.6 GBs of information on it. The compressed image was a little over 5 GBs and did it in less than 3 minutes.

In an attempt to get a boot package that would load the boot wizard as it is designed to do I thought I would replace the boot.win file I had created with the one in the WinPE template files that are located under C:\Users\All Users\Application Data\Symantec\Ghost\Template\common\winpe\sources and create a new boot package using the boot wizard but the boot wizard says the boot.wim is not valid and it cannot create a boot package under the circumstances. This is where I am on this at this point in the process.

My motherboard is an ASRock 970DE3/U3S3 AMD AM3+ socket board that I bought new for $75.00. I bought this board because I already had a CPU and memory that will work with the board and I thought it might be a cheap way to get a preview of USB 3.0 and SATA III technology before buying an Intel i7 CPU and several hundred motherboard as a replacement to a top of the line ASUS motherboard I purchased in early 2004 that went out in late 2010..

It appears the USB 3.0 controller is separate from the USB 2.0 controller and ASRock did not design the BIOS to work with the USB 3.0 controller other than to have an enable / disable USB 3.0 switch because the manufactures of  USB 3.0 controllers do not provide non Windows drivers that can easily be incorporated into the BIOS enabling the BIOS to see any devices plugged into the USB 3.0 ports making them available outside Windows to boot from like you can with the USB 2.0 devices. I am wondering if this setup is exclusive to AMD motherboards or if I bought an Intel socket 2011 or 1156 motherboard  would I find the same setup.

Sincerely,

Mark

 

EdT's picture

I have a recently modern ASUS motherboard with an i7 1155 pin quad core processor and 16 Gb ram. This has four USB-3 ports using the Renesas chipset if I recall correctly, and in order to use these ports in WinPE, I have to load the appropriate drivers for them. I imagine that sooner or later the inclusion of USB-3 support into BIOSes may come about, but when you consider how long the firewire interface has been around, I've not seen any bios support for booting from that either.

You may well find that booting from a USB-3 key on a USB-2 port is the way to go, and then switch the key to a mounted USB-3 port for the actual imaging.  It's trivial to locate the drive letter of the key with a bit of batch script.

Looking back over this thread, it would appear that no mention has been made of precisely which version of Ghost you are using. I assume it's 11.5 due to the WinPE support, but check that you have 11.5.1.2266 as this is the latest available build on LiveUpdate.

Your issues with adding drivers via Ghost boot wizard when they load successfully via DRVLOAD may suggest that a reinstall of Ghost on a clean O/S might be worth a try.  I would repeat my earlier comment in that the drivers must be Vista 32 bit (not Vista 64 bit) regardless of what operating system you are imaging.

Finally, if you still have issues with the drivers, you could of course put the driver files into a folder on your USB key, and have the main batch file that loads Ghost, divert instead to a secondary batch file outside the WIM image, which you can edit at anytime without rebuilding the WIM. Then you can just add a sequence of DRVLOAD commands to get the necessary drivers loaded without any rebuild hassle.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

MKH's picture

Thanks for the information regarding USB 3 on an 1155 board. I may wait to do my upgrade.

I have made some progress with Ghost. I am using version 11.5.1.2266 and I tried version 11.5.1.2113 and got the same result. My work around at this point is to do a clean install of Ghost and create bootable media on USB flash drive using the default settings with WinPE and I select add CD/DVD support.

Next I downloaded the Automated Installation Kit for Windows Vista at http://www.microsoft.com/en-us/download/details.as... and install it. If you are using Windows XP it will call for the installation of MSXML 6.0 Parser before it will let you install AIK. MSXML 6.0 Parser is included in AIK. Once I got the AIK installed I ran the follow commands from the AIK command prompt which is called Windows PE Tools Command Prompt. You can find this under Programs on the start menu once AIK is installed. I put my drivers in a folder on C:\ in an effort to simply the commands I would have to type and keep what I am doing as close to the examples in the instructions as possible.

1) copype.cmd x86 c:\winpe_x86

This creates fresh WinPE fies as follows:

\winpe_x86
\winpe_x86\ISO
\winpe_x86\mount

2) imagex /mountrw c:\winpe_x86\winpe.wim 1 c:\winpe_x86\mount

This unpacks the contents of WinPE.wim and moves them to the mount folder.

3) peimg /inf=<path> c:\winpe_x86\mount\Windows

I run this command for each device driver that needs to be loaded.

In the case of my USB 3.0 two drivers are required a controller and hub driver.

4) Next I copy the ghost32.exe file to the Windows\System32 file which you will find under Windows in the mount folder which is in the winpe_x86 folder.

5) Locate the startnet.cmd file in the system32 file which is under Windows in the mount folder which is in the winpe_x86 folder. Once you locate the startnet.cmd file right click on it and open it with notepad and delete wpeinit and replace it with ghost32.

6) peimg /prep c:\winpe_x86\mount\Windows

This reduces the image size.

7) imagex /unmount c:\winpe_x86\mount /commit

This repackages the changes made in the mount folder to WinPE.wim.

8) copy c:\winpe_x86\winpe.wim c:\winpe_x86\ISO\sources\boot.wim

This updates the boot.win file in the sources folder.

9) Replace the boot.win file in sources folder on the flash drive that contains the boot package created by ghost with the boot.win file in the sources folder in the WinPE_x86 folder.

When you boot from the flash drive it will take WinPE a minute or two to load but the second the command prompt loads Ghost Boot Wizard  loads. There is no delay like with the boot package ghost creates. I am able to plug and unplug items in the USB 3.0 ports and as long as I go back to the main menu in the Boot Wizard then return to the screens where the drives are displayed I am able to see any devices that are plugged in the USB 3.0 ports.

I am able to backup 10.6 GBs in less than 3 minutes doing drive to drive or drive to image to a Patriot USB 3.0 flash drive that is rated at 50 MB/s write and 180 MB/s read. This Rage XT is not their top of the line flash drive the have bigger and faster.. If I select disk to image the image size is a little over 5 GBs. 

The scope limitation in this method of backup is you cannot boot from the image on the USB 3.0 flash drive because USB 3.0 cannot be seen or available to boot in the BIOS of most motherboards made today with USB 3.0 controllers on them. In order to recover from the image on the USB 3.0 flash drive you have to boot from another Ghost boot package and select the image on the USB 3.0 flash drive to recover from.

Sincerely,

Mark

EdT's picture

You will find a lot of this covered in this article: https://www-secure.symantec.com/connect/articles/readyadventures-winpe

There is also a link to another article which covers the creation of a WinPE 3 boot environment, which is somewhat different to create to the WinPE 2 environment.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

MKH's picture

Thanks again for your help.

I just got a respone to an email I sent MSI regarding USB 3.0 technology and I am going to quote what I was told.

"Any native Z77 Ivy Bridge board using a Intel 3rd generation Ivy Bridge CPU will have native USB 3.0 support which will allow you to boot from the USB port."

This would suggest AMD may be less than compared to Intel. When I first bought my AMD board I did a backip with Ghost 2003 in DOS mode and it consistantly took 48 minutes to backup compared to 18 minutes with my old P4 that was manufactured 10 years earlier. All the hardware and media was the same execpt the mothernoard, CPU and memory which is at least double on every point spec wise. The only thing I can come up with that might explain that is the 16 bit Ghost.exe was only using 1 of 4 cores on the AMD CPU which only has 1 none hyper threaded process per core compared with 2 hyper threaded processes per core on the Intel CPU.

Mark

 

EdT's picture

I wonder if that blacket statement is actually valid in all cases as they would like you to believe. The first (WD) USB-3 device I purchased actually included USB-3 drivers that had to be installed in the operating system to get the best out of the WD drive. I also have an older WD drive that came with specific drivers for XP as the detect new hardware wizard would pop up the first time the USB-2 drive was plugged in.  However, for any USB-3 storage device that is natively able to work on a USB-3 port without needing additional driver loading, should be capable of booting on the hardware combination you describe, as long as there is also support for this in the BIOS.  I suspect MSI use a specific bios supplier for which this is true, but there is more than one bios supplier, and I would never presume to suggest they are all equal.

As to your backup timings, are they for identical drive sizes?  The capability to access more than one core is a function of the operating system and not Ghost, and DOS has never been aware of more than a single core, and equally, Ghost 2003 is not going to be CPU aware even if run on a multicore processor.

DOS also has many limitations when it comes to working with modern hardware - no USB support, no SATA support, no NTFS support, no support for large disk partitions. Even way back then, the Ghost program had to implement a number of "workarounds" to allow imaging under DOS but there is only so far you can take this.  I could go on to bore you with technical details such as disk interleave factors and how using SMARTDRV in your DOS boot may speed things up, but using WinPE for imaging is so much better than DOS that it's really not worth spending time on DOS issues.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

MKH's picture

I am not sure if it is a blanket statement or not but if I spend 5 or 6 hundred dollars a CPU and motherboard and I determine all of the hardware connected to the motherboard is not available in the BIOS it will be going back to the store.

As you can tell from reading my post I really know very little about computers, my efforts are an attempt to get this new technology to function in a way the simple solutions do that were originally sold to me when I bought my first computer and software. The good news is I believe I am not only meeting that objective I am making quantum leaps in my efforts. I am glad to have the WinPE opinion with Ghost.

Mark

EdT's picture

I'm guessing that consumer laws are different in your territory than in the UK. Ultimately, it is a case of Caveat Emptor, so if you are buying computer components, there is an assumption that you know what to do with them, unless you have specifically produced a document of requirements which the vendor has failed to meet or has misled you about.

It is technically impossible to guarantee that all hardware connected to a motherboard will be available in the BIOS. For example, a hardware dongle, a SCSI card without a bios, or an integrated webcam are three examples of hardware that are not supported by the native BIOS. After all, BIOS is just an acronym for "Basic Input/Output System", and historically did little more than start the boot process from whatever boot device was available - initially floppy disk, then hard disk and so on.

I applaud your determination to get more experience on the hardware and software available today, but don't fall into the trap of making assumptions about what level of support you should get from any system service as this can get embarrassing when you encounter some of the geeks with limited social graces working in computer stores. ;-)

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

MKH's picture

Thanks!

In response to your question regarding hard drive size when backing up, they are not the same size.

I trade with Micro Center, Frys Electronics and Tiger Direct and they have a 30 day return policy on most of their merchandise and will take motherboards, CPUs and memory back with in reason even if nothing is wrong with it. I sure if you bought something from them through their store or website they would apply that same standard to you regardless of where you live and might even get it to you free if you bought enough.

I am glad to have WinPE as an option. I agree it is superior to DOS.

Mark