Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

USB 3.0 Drive Support Under Ghost 11.5.1.2266

Created: 16 Jun 2011 • Updated: 16 Jun 2011 | 4 comments

I have an upgradable Seagate GoFlex DESK external USB 2.0 drive (F:) to which I have saved and sucessfully restored a Ghost image of the C: drive of a PC running Windows XP Pro SP 3 using Ghost 11.5.1.2266.  After upgrading the drive interface to USB 3.0 and installing the PCI card and drivers, Windows recognizes and can read from and write to this drive.  However, Ghost 11.5.1.2266 does not see/recognize this drive when I go to make a new Ghost image.  Question: Does Ghost 11.5.1.2266 support USB 3.0 drives?  If so, what do I need to do?  If not, what do I need to do?  Thanks!

Comments 4 CommentsJump to latest comment

EdT's picture

Ghost does not care about the drive interface. What you need to do is to add the USB 3.0 drivers to your WinPE boot environment (forget PCDOS, it can't do it) - you will need to do this for both the USB3.0 hardware in your PC and also any USB3.0 drivers for your storage device.  I have successfully accessed a USB3.0 external drive by loading both sets of drivers from the WinPE command line using:

DRVLOAD <full path and filename to driver INF file>

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

BarCodeGuy's picture

EdT, Thanks for this tip. I am a PC hardware and Ghost novice with the need to maintain a Ghosting procedure on a PC that I have inherited at work.  We need the increased capacity of a larger 2-3Tb drive and the increased throughput of USB 3.0.  Would you be kind enough to give me a little more detail about how to effect this procedure?  I have found the full path to the USB 3.0 PCI card driver.  I do not see that there is a driver for the Seagate drive (but again, I'm not a _PC_ guru).  We can go offline if that would be better.

EdT's picture

The bst way to check if your USB 3.0 hard disk needs a driver is to connect it to your USB 3.0 interface card while its running under Windows - you should see the new hardware wizard pop up if this is a first time connection and then it will either find a driver on the hard disk or ask for one. It might be simpler to just have a look at the software poovided by Seagate on the USB 3.0 hard disk and see if there are any drivers present.  I have a Western Digital 2Tb USB 3.0 hard disk and there are drivers supplied on the disk.

When I was testing this USB 3.0 drive with my new system which has USB 3.0 ports on the motherboard, I placed both the motherboard drivers and the hard disk drivers onto a USB stick that boots WinPE (created as per this article: Adventures with WinPE Symantec Connect

Having booted WinPE from this stick, the USB 3.0 drive plugged into the USB 3.0 port was not actually accessible via WinPE. So the first step was to load the USB 3.0 interface drivers for the mobo from the WinPE command prompt:

DRVLOAD (path and filename of motherboard INF file from mobo driver dir on USB boot key))

WinPE responded with a message to confirm that the drivers had loaded.

The next step was to load the drivers for the USB 3.0 hard disk:

DRVLOAD (path and filename of USB 3.0 driver INF from hd driver dir on usb boot key)

Again, WinPE responded with a message to confirm that the drivers had loaded.

Once these two steps were completed, I was able to find the driver letter on which the USB 3.0 drive was now to be found, and was able to read and write to the drive.  This process confirmed that I had the correct Vista 32 bit drivers required by my version of WinPE.  To avoid having to use DRVLOAD each time, the next step would be to integrate the drivers into WinPE and create a new bootable WinPE image. This is something that the Ghost software pretty much automates for you, but you need to first add the drivers, and then select them from the list of all available drivers otherwise they will not be included in the new boot image.

One other thing I would like to mention at this point - my new system includes a 3Tb hard disk internally, and I found that under Windows 7 64 bit, the largest "regular" partition I could create was 2Tb. In order to use the full capacity of the drive as a single partition, I had to use the GUID partition option.  I'm assuming that the same limitations may exist for an external USB drive that exceeds 2Tb in capacity, but what I don't know is whether a large single GUID partition can be mounted under WinPE 2.0. Perhaps not an issue today, but something to bear in mind as USB 3.0 devices grow in popularity and size.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

JoFo's picture

I am having a similar problem, Ghost 11.5.1.2266 will not detect an Iomega USB 3.0 portable hard drive when plugged into the local PC.  I am trying to do a local copy to the attached 1 TB HD. GDisk32 does not list the HD and Ghost32 will not even run, it starts, hangs and then closes.

Iomega does not require specific USB 3.0 drivers, so there are no drivers to install/load.

If I boot the PC using just a WinPE CD/Flash Drive it sees the HD fine.

It appears that Ghost has a USB 3.0 problem.