Video Screencast Help

USB Hard Drive Not Overwriting

Created: 30 Jul 2013 | 9 comments

Good Morning All,

We have a SBS Server 2011 setup with Backup Exec 2012 installed - to put the backup on we also have 5 1TB USB3 hard drives (for each work day) which are alternated on a daily basis (these are setup in a storage pool, job points to the pool)

A problem has occured now the company in question is starting to fill the hard drives - we didn't worry as we assumed the job would just overwrite the oldest data set and continue with the backup.

This isn't the case however - the job status just sits on Queued and I get alerts saying that the drive is full and for me to insert media with enough free space to fit the backup on.

I've looked around the forums and I've told the backup itself to protect the data for an hour and I've gone into Backup Exec's Settings > Storage > And set the Media overwrite protection level to "None" - still it won't overwrite the drive.

On the storage tab the Tuesday tape has a Pen/Pencil with a cross through it which I assume means it won't be overwritten...

 

What I'm wondering is - how do I get backup exec to just overwrite the drive.

 

 

 

Operating Systems:

Comments 9 CommentsJump to latest comment

sidd3009's picture

Hello Delo,

This issue has been resolved with the release of Backup Exec 2012 Service Pack 2. You may download it by using the following link: 

http://www.symantec.com/docs/TECH203155

For more details on the issue, please refer to the following link: http://www.symantec.com/business/support/index?page=content&id=TECH196201

As far as the pencil mark is concerned, you need to go to the properties of the Storage and then you need to select 'No' for the option: Limit Backup Exec to read-only operations. 

Regards,

Siddhant Saini
Advanced Technical Support Engineer, Symantec Corporation 
www.symantec.com

Delo819's picture

Hi Sidd,

Thanks for the assistance I'm installing SP2 now and will test tonight.

MusSeth's picture

What is the number of days if you have selected in job for data to be retained....

Delo819's picture

It seemed to be a combination of the read only flag and the SP2 not being installed as its working fine now.

MusSeth the retention was set to 5 days and now set to 1 hour just for testing.

Either way all seems to be working now.

sidd3009's picture
 
Backup Exec 2012 would limit Backup Exec to read-only operations in a situation where it needs to avoid any overwrite opration on the expired backup sets on any disk storage which is attached/reattached to the Backup Exec Server after a long time. 
 
Please refer to the 'Storage options in Backup Exec that affect data lifecycle management' section of the following article to get more details on it: http://www.symantec.com/business/support/index?page=content&id=TECH201826
 
If required, you may have to increase the days for the 'Limit Backup Exec to read-only operations on a storage device if it has been detached for at least x days' option available at: 
Backup Exec icon(top left) > Configuration and Settings > Backup Exec Settings > Storage. 

 

Regards,

Siddhant Saini
Advanced Technical Support Engineer, Symantec Corporation 
www.symantec.com

pkh's picture

 I've gone into Backup Exec's Settings > Storage > And set the Media overwrite protection level to "None" - still it won't overwrite the drive.

Since you have set the OPL to None, there would be no overwrite protection which means that all your backup sets can be overwritten at any time.  You should set the OPL to at either Partial or Full.

Colin Weaver's picture

Just to add to this - the "None" setting only affects media set control and therefore only applies to tapes and cartridge media (RDX etc) it does not apply to disk storage devices (fixed or USB) or Deduplication which are managed by DLM.

 

With regards the fix in 2012 Service Pack 2, as DLM is a 4 hour cycle. Then to see if SP2 is cleaning up expired media, you have to connect the USB disk up to 4 hours before you need to use it (as you have no way to tell if DLM did it's cycle 1 minute before you connected the USB diskit.)

sidd3009's picture

...To add to what Colin wrote, if you want the changes to take effect immediately, you could perform an Inventory+Catalog on the USB drive. (I dont think that it could be automated).  

Regards,

Siddhant Saini
Advanced Technical Support Engineer, Symantec Corporation 
www.symantec.com

pkh's picture

No.  The changes to the OPL takes effect immediately without the need to do any inventory or catalog.