Video Screencast Help

User can delete registy key: HKEY_CLASSES_ROOT\CLSID\.... when an SVS Layer is active

Created: 13 Oct 2009 • Updated: 29 Jul 2010 | 3 comments
MatthiasW's picture
This issue has been solved. See solution.

 Hi,

I'm having a problem with an inhouse application which I'm trying to virtualize with SVS, the problem that I seem to have is with a registry key in HKEY_CLASSES_ROOT\CLSID\....

When an SVS layer is activated on my Windows XP Desktop, I can delete registry keys in HKEY_CLASSES_ROOT\CLSID\.... as a user!

The keys in HKEY_CLASSES_ROOT\CLSID is a view of the keys in HKEY_CURRENT_USER\Software\Classes\CLSID\... and HKEY_LOCAL_MACHINE\Software\Classes\CLSID\...

When I try to delete this key in HKEY_LOCAL_MACHINE\Software\Classes\CLSID\..., it gives me an error, permission denied... this is a normal behaviour, but when I try to delete this key in HKEY_CLASSES_ROOT\CLSID, it deletes this registry key!

This only happens when an SVS layer is active, even with an empty layer.

Does anybody know why this happens?

thanks,
Matthias




Comments 3 CommentsJump to latest comment

EdT's picture

As you have noted, the HKCR\CLSID "view" is a merge of the HKLM/Software/Classes/CLSID and HKCU/Software/Classes/CLSID entries. Where there are duplicate entries in both HKLM and HKCU, then the HKCU entries are given priority, and appear in HKCR.

So if you have a key in HKCU/Software/Classes/CLSID, where a user has permissions to delete the entries, it will also appear in HKCR, and I would expect the user also to have permissions to delete this entry, as HKCR does not actually exist as a separate hive, but is a "view" of HKLM and HKCU.

However, if you are saying that you can delete ANY entry in HKCR/CLSID when you have even an empty layer loaded, then this sounds like a very serious bug.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

MatthiasW's picture

Hi EdT, 

 
Thanks for the fast reply!
 
It's a key which is located in HKLM/Software/Classes/CLSID, this key is created when installing this inhouse software.
After this key is created by installation, it will delete this key in HKCR/CLSID and recreate it when launching the application.
 
Normally, it's not possible to delete this key with a user (permissions), but when an "empty" SVS layer is active, it can delete this key.
The key can not be recreated that's why I'm having problems with this software.

 
Jordan's picture

This is a known issue and we're actively working on a fix.

If a forum post solves your problem please flag is as the solution

SOLUTION