Video Screencast Help

User defined data class. Table location in SQL?

Created: 28 Nov 2012 • Updated: 04 Jan 2013 | 12 comments
This issue has been solved. See solution.


As part of our asset management we needed to create a user defined data class to track warranties.

We had done this under altiris 6.9, and 7.0 by creating the user defined data class and assigning it to the resource types.

We were then able to easily locat e the table on the SQL server for report writing etc

We are in the process of moving to 7.1 so began the same process.

The data class was created with no difficulty at all but there is no corresponding table on the SQL server.

When the data class table is searched we can see the data class present and there is a table name but when the data table name is searched for it does not exist.

Has anyone else encountered this?

Comments 12 CommentsJump to latest comment

mclemson's picture

If you create a custom data class called 'Internet Explorer Version,' add columns (e.g. MajorVersion and FullVersion), then click Save changes, the table will be created.  The name by default is Inv_<name of your data class with all spaces replaced by underscores>, e.g. Inv_Internet_Explorer_Version.

Do you see the table, e.g. Inv_Internet_Explorer_Version, in SQL when you filter tables by a keyword (e.g. TME)?

Mike Clemson, Senior Systems Engineer, ASC
Intuitive Technology Group -- Symantec Platinum Partner

Redtidings's picture

Hi Thanks for the response. One of the custom data classes I have created shows with the naming above.

The other however does not.

I now have a call open with symantec to discuss this and will keep all posted regarding further information.

KSchroeder's picture

If you go to Settings > All Settings > Notification Server > Resource and Data Class Settings > Data Classes > User Defined, then find your data class; if you click on it, the "Data Table Name" will be displayed in the right pane; is this not there?

Symantec Trusted Advisor

For Forum threads, please click "Mark as Solution" if answered.
For all content, please give a thumbs up if you agree with or support the post.

mclemson's picture

Does the table have at least one column?  If not try creating or modifying a column.  This will recreate the custom data class and resave it, after which it may appear.

Mike Clemson, Senior Systems Engineer, ASC
Intuitive Technology Group -- Symantec Platinum Partner

Brillow32473's picture

Is this the only table that you have seen where it wont show up in hte database?  If you delete the data class are there any errors in the logs?  If you create a new data class with a slightly modified name does it create it.  If you create a new data class not releated does it create it.

This should help track down what is going on.

Redtidings's picture

Thanks for all responses will invwestigate and post results of investigation.

Redtidings's picture

I have received follow up from Symantec which pointed me at an howto article

HOWTO44064. Which details creating custom data classes forcustom inventories.

Creating them this way does create the tables immediately in SQL but I cannot link these data classes to the assets.

The data classes are populated with data from the import file which appears against the assets correctly under the edit view.

Symantec investigating further

dataclasses.doc 29.5 KB
Redtidings's picture

Symantec contacted again and told me that as this is a customisation problem their tech support cannot help.

I do not have budget to contact the consultants recomended so back to hunting for a solution myself.

Any further help would be much appreciated

Brillow32473's picture

To add the data classes to a resource you have to go to:

Settings > All Settings > Notification Server > Resource and Data Class Settings > Resource Types.

Under Resource Types you find the selected Resource Type.

Now in the Configuration Page on the right pain go to the data class section.

Click on the Add Data Classes.

A picker will come up and you know can browse and select your data class.

Once this is done the data classes that you have selected will now show on the edit page.

Redtidings's picture

Hi Brillow,

I have gone to the area you indicated in your comment but the data classes do not appear as selectable against the resource type.

Could this be because the HOWTO is on how to create custom inventory data classes?


Brillow32473's picture

Did you import it from the 7.0 or 6.x server or did you create it from scratch? Also what are the steps you are taking to create the data class and associate it?

All custom data classes should be a custom inventory data class.

Redtidings's picture

Hi All,

Thanks for all the help and advice that has been offered. smiley

I know have been able to get both custom data classes assigned correctly and linked to the asset type which then creates the table in SQL.

I have had to create them under user defined then associate them to the assets then move them to the custom folder under inventory.

It has seemed a roundabout way to get it done but it has worked.

Thanks again and I hope this helps other struggling