Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

User typed wrong recipient address and receives NDRs. Message can't be find in the queue to stop retrying

Created: 03 Jan 2013 • Updated: 07 Jan 2013 | 4 comments
This issue has been solved. See solution.

Hi,

hope someone can help me out.

A user has typed a wrong recipient address. Now Symantec Message Gateway retries to deliver the message and of course the user receives these NDRs.

I want to stop SMG to retry but I could not find the message in the delivery queue.

The error message in the NDR is:

"#< #5.4.7 smtp; 554 5.4.7 [internal] exceeded max time without delivery> #SMTP#"

and further it says:

"The server has tried to deliver this message, without success, and has stopped trying. Please try sending this message again. If the problem continues, contact your helpdesk."

I've checked the delivery queue (on both scanners) and as I said the message is not there.

So I am wondering how to stop SMG to stop retrying except to wait until the final retry timeout has been reached.

We are running SMG 10.0.0.6 with two Scanners and one CC.

Thanks in advance

Regards

 

 

Discussion Filed Under:

Comments 4 CommentsJump to latest comment

Art_P's picture

The configuration you are looking for is found at:

  1. Click Administration.
  2. Click Configuration under Hosts in the left pane.
  3. Edit the Scannner.
  4. Click the SMTP tab.
  5. Click the Advanced Settings button on the bottom.
  6. Click the Delivery tab.
  7. Edit the retry and timeout settings as you want them to be configured.
  8. Click the Continue button.
  9. Click Save (optionally checking "Apply above settings to all Scanners" if wanted).

More info in the following KB:

http://www.symantec.com/business/support/index?page=content&id=HOWTO53774

 

If you find a useful post, please use the "thumbs up" feature to mark the post as helpful. If your question has been answered, please select the "Mark as solution" for the post that best answered your question. Thank you.

Contonso's picture

Hi Art_P,

 

thanks for response. I already found these settings and know about them. But I don't want to do any change on these settings. Because these settings affect all messages. I want to delete this one (wrong addressed) message out from the queue.

I thoug it will kept in the delivery queue, but for some reason it isn't shown there and the user still gets these NDRs.

Is there any possibility to delete this one message except wait until retry-timeout has reached or modify the SMPT delivery settings?

regards

 

 

Art_P's picture

According to the information you posted, the message has already reached its max time-out and therefore it would no longer be in the delivery queue. Are you sure it is not multiple messages that were trying to be sent?

You can manually attempt to find and delete the message from the queue directly by using the mta-control command from the command line. Here is a KB that show examples:

http://www.symantec.com/business/support/index?page=content&id=TECH132980

And here is a KB that further explains the mta-control command:

http://www.symantec.com/business/support/index?page=content&id=HOWTO53708

You will need to run that command on the scanner where the message is located (or all if you are not sure which scanner has the message). However, the error you are posting indicates that the message has already timed out and should be deleted - which explains why you can't see it in the queue. I suggest contacting support if you can't find the message using the mta-control command.

 

If you find a useful post, please use the "thumbs up" feature to mark the post as helpful. If your question has been answered, please select the "Mark as solution" for the post that best answered your question. Thank you.

SOLUTION
Contonso's picture

You are right. The user just reported that he has not received any NDRs after the one I had postet above.

Nevertheless I will check the KBs

Thank you very much.