Video Screencast Help

Using change journal "unable to locate journal data"

Created: 23 May 2013 • Updated: 13 Jun 2013 | 5 comments
Carlos Javier Molina's picture
This issue has been solved. See solution.

Hello,

I have a small issue for you : 

On a Windows 2008 r2 OS platform, with an 7.5.0.5 NetBackup, a simple Windows policy, backing up several local drives, I am using the option "use change journal"

On several drives it works, but on two of them i get the error "

bpbkar change journal enabled for <Z:\>

bpbkar (pid=7240) NOT using change journal data for <Z:\>: unable to locate journal data

The backup ends successfully.

Please note that this is not a first time I run a backup with "use accelerator " option enabled, it has worked before.

I am not using accelerator.

I've checked already the http://www.symantec.com/business/support/index?pag... but this does not apply, it is not a first backup, neither a full one that would require the accelerator.

 

Thanks in advance for any tip.

Operating Systems:

Comments 5 CommentsJump to latest comment

CraigV's picture

...moved to the correct forum!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

sazz.'s picture

There is a internal TN for Symantec for the same, I had similar issue and here are the steps recommended by Symantec:

Solution

 Following are steps need to be followed to delete Change Journal.

1.  Stop the NetBackup services on client.

2.  Make sure all bpfis.exe processes are killed in Windows Task Manager. 

3.  Use the bpps command from the command-line to make sure no NetBackup processes running.

4.  Delete the NTFS change journal for each file system: 

     For each drive execute:

     Go to a command prompt and query the USN Change Journal using command: fsutil usn queryjournal <drive letter:>

     To delete Journal run below command :

     fsutil usn deletejournal /D <drive letter:>

     For example for the C: drive:

     fsutil usn deletejournal /D c:

 

5. Restart NetBackup services on client.

6. Test the backup for Full

huanglao2002's picture

bpbkar change journal enabled for <Z:\>

bpbkar (pid=7240) NOT using change journal data for <Z:\>: unable to locate journal data "

 

Can you tell use what is drive "Z" used?

can you try to exclude drive Z?

Carlos Javier Molina's picture

Hello,

 

Thank you sazz. From what I understand, after i manually deletethe change journal for a drive, launch full and then incremental backup for that drive, the change journal should be activated automatically and not manually by using fsutil in cmd.

However my NBU does not sense any change. I still get bpbkar (NOT using change journal data for <Z:\>: unable to locate journal data, after i have manually deleted the change journal and re run a full and incremental job

See below a fraction of the bpbkar log in verbosity 5:

tar_backup_tfi::setupFileDirectives: TAR - backup filename = Z:\
tar_base::keepaliveThread: INF - keepalive thread is active with an interval of 60 seconds
NBJournalDataCollection::NBJournalDataCollection: INF - volume guid:<\\?\Volume{6f91bef9-6101-11e2-818c-806e6f6e6963}\>
NBJournalDataCollection::NBJournalDataCollection: INF - mounted at:<C:\>:<\\?\Volume{6f91bef9-6101-11e2-818c-806e6f6e6963}\>
NBJournalDataCollection::NBJournalDataCollection: INF - adding to collection, volume:<\\?\Volume{6f91bef9-6101-11e2-818c-806e6f6e6963}\>:<C:\>
NBJournalData::NBJournalData: ERR - journal service is not running for volume:<\\?\Volume{6f91bef9-6101-11e2-818c-806e6f6e6963}>

 

P:S: it is a local drive. I get the same error for two of the drives , not for the rest of them, same type.

 

Thank you!

Carlos Javier Molina's picture

Had to reinstall NetBackup client on that specific machine, all went ok

 

Thanks !

SOLUTION