Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

Using Query Builder in the VMware policy!!

Created: 02 Jan 2013 • Updated: 06 Jan 2013 | 13 comments
Rami Nasser's picture
This issue has been solved. See solution.

Hi All ,

The environment contains master server 7.5.0.4 and the appliance5220 2.5 version configured as media server role and VMware backup host connected directy to the Datastores.when I'm trying to add clients manually form the (enter the vm hostname) every thing is ok ,but (browse and select virtual machine) taking too much time then time out.Also  when using the query builder tocustomise the rules the system is taking long time to discover and at the end getting time out.I increased the time period to discover machines but nothing.the steps for adding some exclude VM server list in the registry or in the appliance not helping.

I'm confused if this is related to firewalls ports or some thing else?

Regards,

Comments 13 CommentsJump to latest comment

Mark_Solutions's picture

Have you disabled the IP resolution for your query - this can speed things up and prevent the timeouts - search the VMWare Admin Guide for disableIPResolution

Hope this helps

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

SOLUTION
Rami Nasser's picture

Yes I did .I created the registry key "disableIPResolution". but no changes
Regards,

Mark_Solutions's picture

Looking at the details of the tech note this needs doing on the VMWare backup host .. which in your case is an Appliance and so running Linux

I will see what the equivalent is for Unix and get back to you.

At 7.5.0.4 it should be disabled by default as long as you are using the Display Name - is that what you use?

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

Marianne's picture

If I may ask - where did you create the registry key?
Registry key is for Windows Backup host. Your Appliance is running Linux....

Extract from NBU 7.5.0.x for VMware Admin Guide :

 

To prevent browsing delays caused by DNS problems (Linux)
 
1 On the Linux backup host, create (or open) the following file:
/usr/openv/netbackup/virtualization.conf
 
2 Add the following to the file:
[BACKUP]
"disableIPResolution"=dword:00000000

 

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Mark_Solutions's picture

Thanks Marianne - exactly what i was just digging out - saved me my search!

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

Rami Nasser's picture

Thanks Mark and Marriane,

As I thought that the master server is responsible for discovering the VM machine through the policy,for this reason I created the registry key on the master server which is windows machine.Yes you are 100% right regarding the appliance OS .So I understand here that the VMware backup host is responsible for discovering the clients not the master server .For this I need to remove the added  reg key from my master server and create .conf file inside the appliance.

Are  this settings working with all type of "primery VM identifier " or for "VM display name"??

 . On Saturday I will work on this and come back to you

Regards,

 

Mark_Solutions's picture

The tech note that i found says that it is disabled by default if you use the VM Display Name - but that setting may well have been overlooked when they translated the VMWare backup host across to the appliances.

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

Rami Nasser's picture

after adding virtualiztion.conf to the appliance and then i restareted the services on the master server and media server still having the the same issue.I can see the clients and vcenter and the esx servers and every thing inside the vcenter ,but when testing the query  it taking long time and the hang .then i tryed to browse the clients manually and got the same result .the only thing not hangs is to enter the client name directly then i can validate the policy .but when running the policy for backup it hangs through discovery clients then failed. I believe that some thing wrong with permissions and previliges to data stores or with firewall ports

 

 

 

disable ipresolution.png
Marianne's picture

Please remember that NBU is case sensitive.
I would change [backup] to [BACKUP].

Can you see VMs if you browse manually in Clients tab?

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Rami Nasser's picture

ok i wll correct the name today
it hangs when browsing

Marianne's picture

How big is this environment?

Are you connecting via vCenter server or just to one ESX server?

Have you tried to install VMware vSphere Client on your desktop and connect using the same hostname/IP and user id & password that was added in NBU? How long does it take to populate all VM hostnames in vSphere Client?

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Rami Nasser's picture

they have vcenter that contains 12 esx host .I'm connecting through vcenter only .
Today I changed the [backup] to Capital .Now I can see the vcenter and al the content .
just when running backup it fails with status 6
please support.
al the host are added to etc hosts file in the master and media server

Marianne's picture

Please start a new discussion for status 6 issue.

Post all relevant info, such as policy config and all text in Details tab.

 

**** EDIT ****

Thanks for the Solution, but Mark was first to suggest disableIPResolution - so he really deserves this one! 
I have moved the Solution.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links