Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Using VCS Resources to Mount NFSv4 Exports

Created: 19 Jan 2014 • Updated: 29 Jan 2014 | 6 comments
yairz's picture
This issue has been solved. See solution.

Hi all,

I have a two node VCS cluster running on RHEL 5 (VCS version 6).

I need the cluster to use the Mount resource to mount an NFSv4 exported FS from a NetApp filer.

I couldn't find any information in the documentation on how to perform this, as the FS type should be nfs4 for a regular mount command but the resource contains only option for "nfs" FS type.

Any advice would be much appreciated.

Thanks,

Yair

Operating Systems:

Comments 6 CommentsJump to latest comment

Gaurav Sangamnerkar's picture

Hi,

NFS v4 was very much supported from version 5.0 RU1 (Linux), refer to release notes below

http://www.symantec.com/business/support/index?pag...

For mount agent, specifying FSType would only be set to "nfs" as there is no option to put nfs4 as filesystem. However check below link on how to use NFSv4, I believe it is not the mount agent you need to take care rather you need to switch on an optional attribute in NFS agent.

Below link describes the sample setup of NFS

https://sort.symantec.com/public/documents/sfha/6....

For NFSv4 support, you might want to turn on the optional attribute of NFS resource, below link describes optional attribute

https://sort.symantec.com/public/documents/sfha/6....

NFSv4Support

Specifies whether to start the NFSv4 daemon rpc.idmapd or not and whether to monitor nfsd version 4.

Type and dimension: boolean-scalar

Default: 0

For using NFSv4

The NFS agent provides NFSv4 support to export shares using the attribute NFSv4Support. Only one of the Share resources that depends on the NFS resource needs a value of fsid=0 in its Options attribute. The shared directory that has the fsid=0 option becomes the root of all exports. The client needs to mount only this root file system instead of mounting all shares individually.

The syntax is:

    mount -t nfs4 <server>:/    <mountpoint>

Always use a slash (/) to end the path after the colon (:).

All the file systems, other than the root file system, needs to have the nohide option set in Options attribute of share resources. Set the nohide option so that authentic clients can seamlessly move through the tree of exported file systems just by mounting the root file system.

To enable NFSv4 support on your node, you must have the rpc_pipefs (pipe file system) mounted on the node. At boot time, rpc_pipefs is mounted on every Linux node. In situations where it is not mounted, mount rpc_pipefs on the cluster node.

To mount rpc_pipefs

  • At the prompt on the node, enter the following:
    # mount -t rpc_pipefs rpc_pipefs /var/lib/nfs/rpc_pipefs
    

G

PS: If you are happy with the answer provided, please mark the post as solution. You can do so by clicking link "Mark as Solution" below the answer provided.
 

yairz's picture

Hi Guarav,

Thank you for the detailed information.

However, what you've detailed is how to configure VCS to act as an NFS server sharing exported filesystems through NFSv4.

What I need is that VCS act as an NFS client which will mount the shares of a NetApp which is exporting with NFSv4.

Look at this excerpt of your thread:

 The client needs to mount only this root file system instead of mounting all shares individually.

The syntax is:

    mount -t nfs4 <server>:/    <mountpoint>

This is basically what I need VCS to perform, where the <server> is the NetApp filer in my case.

However, since I do not have nfs4 as a valid value for the FSType attribute in a Mount resource I'm not sure whether it is possible to use the Mount agent for this purpose.

I might have to switch to using custom agent with scripts to mount, unmount and veriy that the share is mounted.

Thanks,

Yair

Marianne's picture

Have you tried to use the standard Mount Agent with FS type specified as nfs?

As per Gaurav's post and http://www.symantec.com/docs/DOC2723 :

Mount agent supports NFSv4 client mounts 

The Release Notes only say:

Mount agent supports NFSv4 client mounts
This release adds support for NFSv4 client mounts on SLES 11.
 
It unfortunately does not say 'how' and neither do more recent Bundled Agent Guides.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Gaurav Sangamnerkar's picture

I agree, same thing I mentioned in previous post as "For mount agent, specifying FSType would only be set to "nfs" as there is no option to put nfs4 as filesystem"

I believe this would be an input for documentation team to correct the line which says "mount -t nfs4". a normal "nfs" mount option should work here, rest NFSv4 things would be taken care of other things which you will need to do as explained in my previous post.

G

PS: If you are happy with the answer provided, please mark the post as solution. You can do so by clicking link "Mark as Solution" below the answer provided.
 

SOLUTION
mikebounds's picture

I have had a look at my VCS 5.1 RHEL system and looked at the /opt/VRTSvcs/bin/Mount/Mount.xml file - this is the file the Java GUI uses to show you the desciption of VCS attributes and their allowable values.

In the XML, it lists nfs4 (as well as nfs) as a possible value for FSType, so it looks as though the Bundled agents guide has not been updated to reflect that you can use nfs4.

So, just specify "nfs4" in FSType and this should work.

Mike

UK Symantec Consultant in VCS, GCO, SF, VVR, VxAT on Solaris, AIX, HP-ux, Linux & Windows

If this post has answered your question then please click on "Mark as solution" link below

SOLUTION
yairz's picture

Mike,

That's fantastic!

I couldn't connect to the environment today to verify all the solutions provided in this thread, however tomorrow I'll be able to connect and will update this thread with the result.

Thank you all for you help.

Yair