Video Screencast Help

V2P Restore

Created: 05 Jan 2013 • Updated: 31 Jan 2013 | 6 comments
This issue has been solved. See solution.

I need to move a Virtual Server (SBS 2011) to the Physical Server it is running on,  (orginal needs of mutiple servers is no longer there).

I am running Hyper-V which therefore means I have *.vhd files to restore from.

I was under the impression, that I could use the VHD files to restore from.

I booted from the download Recovery CD, pointed to VHD drive and then things went downhill.

For starters; when it displayed the information on the VHD, some of the information it displayed was (sorry did not write all of them down);

    Name - Unknown

    Size - 0

- I know the files are good, I have been able to mount them in both Win7 & 8 and view all the files.

Next When selecting the destination drive, they are always grayed out.

I am trying to restore to drives on a HP Proliant DL380 G7 off a P410i RAID Controller.

I loaded the x32 drivers for this RAID controller and still they show as Grey, although I can see any partitions, created on the disks.

I tried wiping the disk so there was nothing on them, started the windows install to create a volume, both the same size and larger than the partition I was trying to restore, but always the destination was greyed out.

If I did click Next I would get EC95006 - Destination Not Vaild and EC950019 - Current Recovery Data is Invalid.


Can I restore a VHD to Physical?

Why would the VHD's show a size of 0, etc, as though they can not be read.

Why are the destination drives not useable, although the correct drivers are installed/loaded? and the drives are viewable in the console.

If it is not possiable to take a VHD drive and restore to Physical, then do I have to install the System Recovery software within the VM and backup from there to bebable to restore to the Physical.  However this still leaves the issue with not being able to select the drives. 

Any help would be appreciated - there has to be an easy way to do a V2P

Comments 6 CommentsJump to latest comment

Markus Koestler's picture

In your case I create a full volume backup of the virtual machine, and then simply starting the physical machine with the SRD restoring the created backup of the virtual machine SELECTING RESTORE ANYWHERE. This way it worked fine with me.

*** Please mark thread as solved if you consider this to have answered your question(s) ***

kaniwi's picture

I Markus,
Thanks for taking the time to reply.
When you say "Full Volume Backup of the virtual machine", I gather you installed the System Recovery software into the VM and configured it to do a full backup.
Can you also confirm where you backed up to. The VM can't backup directly to a USB drive, so I assume you destination was across the network?

In regard to the recovery - did you have any issues with the SRD seeing the destination disks?
Did the SRD create the necessary volumes during the restore, or did you have to create them before hand?

Again any help in understanding the product would be appreciated. A manual tells you what to do, but than does not always relate to reality.


Markus Koestler's picture

Yep I installed SSR into the VM. The backup destination was a NAS device attached to the network. I did not have to create the partitions because if you run a backup this way SSR "knows" the partitions to create. See also here:

*** Please mark thread as solved if you consider this to have answered your question(s) ***

Markus Koestler's picture

Anything still unlcear ?

*** Please mark thread as solved if you consider this to have answered your question(s) ***

kaniwi's picture

Thanks guys for your comments.

I still would have like to know why it did not use/see the VHD's as it says it does in the documentation.

However I did get it transfered following Markus suggestion of installing the software directly on the server I needd to to the transfer.

However, again this is were I found the instructions from Symantec fell down.  It did not indicate that on first boot after the restore, the system would go through the a "setup" procedure.  When this happened I thought I had done something wrong - first time I had done a VtoP.

In the ends it is all running but took at least twice as long as it should had.  Can't say I am particlly impressed with the product & documentation.

Again Markus thank you for your input.

Much apprciated.

Markus Koestler's picture

So may i ask you to mark this post as solved then ?

*** Please mark thread as solved if you consider this to have answered your question(s) ***