Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

VALKYRIE.DLL crashes outlook 2007 tried several fixes

Created: 13 Mar 2013 • Updated: 19 Mar 2013 | 26 comments
This issue has been solved. See solution.

outlook.exe continues to crash. machine was missing search 4.0 which I added and was on office sp2 which I upgraded to sp3.

 

ran ResetEVClient.exe several times

manually unregistered/reregistered dlls

ran fixmapi.dll before and after reboot

 

tried reinstalling the plugin

msvcr90.dll outlook.exe valkyrie.dll crash

 

any ideas without reimaging, renaming windows profile or outlook profile?

 

Operating Systems:

Comments 26 CommentsJump to latest comment

JesusWept3's picture

What version of the client?
Can you post the Event ID 1000 from the application log?

jroe's picture

were just upgrading now, I believe its v10.0.2.1112

 

Event Type:    Error
Event Source:    Microsoft Office 12
Event Category:    None
Event ID:    1000
Date:        3/13/2013
Time:        8:37:48 AM
User:        N/A
Computer:    w2
Description:
Faulting application outlook.exe, version 12.0.6661.5003, stamp 4fa2a9e1, faulting module msvcr90.dll, version 9.0.30729.6161, stamp 4dace5b9, debug? 0, fault address 0x0003523b.
Data:
0000: 41 00 70 00 70 00 6c 00   A.p.p.l.
0008: 69 00 63 00 61 00 74 00   i.c.a.t.
0010: 69 00 6f 00 6e 00 20 00   i.o.n. .
0018: 46 00 61 00 69 00 6c 00   F.a.i.l.
0020: 75 00 72 00 65 00 20 00   u.r.e. .
0028: 20 00 6f 00 75 00 74 00    .o.u.t.
0030: 6c 00 6f 00 6f 00 6b 00   l.o.o.k.
0038: 2e 00 65 00 78 00 65 00   ..e.x.e.
0040: 20 00 31 00 32 00 2e 00    .1.2...
0048: 30 00 2e 00 36 00 36 00   0...6.6.
0050: 36 00 31 00 2e 00 35 00   6.1...5.
0058: 30 00 30 00 33 00 20 00   0.0.3. .
0060: 34 00 66 00 61 00 32 00   4.f.a.2.
0068: 61 00 39 00 65 00 31 00   a.9.e.1.
0070: 20 00 69 00 6e 00 20 00    .i.n. .
0078: 6d 00 73 00 76 00 63 00   m.s.v.c.
0080: 72 00 39 00 30 00 2e 00   r.9.0...
0088: 64 00 6c 00 6c 00 20 00   d.l.l. .
0090: 39 00 2e 00 30 00 2e 00   9...0...
0098: 33 00 30 00 37 00 32 00   3.0.7.2.
00a0: 39 00 2e 00 36 00 31 00   9...6.1.
00a8: 36 00 31 00 20 00 34 00   6.1. .4.
00b0: 64 00 61 00 63 00 65 00   d.a.c.e.
00b8: 35 00 62 00 39 00 20 00   5.b.9. .
00c0: 66 00 44 00 65 00 62 00   f.D.e.b.
00c8: 75 00 67 00 20 00 30 00   u.g. .0.
00d0: 20 00 61 00 74 00 20 00    .a.t. .
00d8: 6f 00 66 00 66 00 73 00   o.f.f.s.
00e0: 65 00 74 00 20 00 30 00   e.t. .0.
00e8: 30 00 30 00 33 00 35 00   0.0.3.5.
00f0: 32 00 33 00 62 00 0d 00   2.3.b...
00f8: 0a 00                     ..      
 

jroe's picture

thank you for assisting, second pc example:

 

Event Type:    Error
Event Source:    Microsoft Office 12
Event Category:    None
Event ID:    1000
Date:        3/13/2013
Time:        1:40:46 PM
User:        N/A
Computer:   
Description:
Faulting application outlook.exe, version 12.0.6661.5003, stamp 4fa2a9e1, faulting module msvcr90.dll, version 9.0.30729.6161, stamp 4dace5b9, debug? 0, fault address 0x0003523b.
Data:
0000: 41 00 70 00 70 00 6c 00   A.p.p.l.
0008: 69 00 63 00 61 00 74 00   i.c.a.t.
0010: 69 00 6f 00 6e 00 20 00   i.o.n. .
0018: 46 00 61 00 69 00 6c 00   F.a.i.l.
0020: 75 00 72 00 65 00 20 00   u.r.e. .
0028: 20 00 6f 00 75 00 74 00    .o.u.t.
0030: 6c 00 6f 00 6f 00 6b 00   l.o.o.k.
0038: 2e 00 65 00 78 00 65 00   ..e.x.e.
0040: 20 00 31 00 32 00 2e 00    .1.2...
0048: 30 00 2e 00 36 00 36 00   0...6.6.
0050: 36 00 31 00 2e 00 35 00   6.1...5.
0058: 30 00 30 00 33 00 20 00   0.0.3. .
0060: 34 00 66 00 61 00 32 00   4.f.a.2.
0068: 61 00 39 00 65 00 31 00   a.9.e.1.
0070: 20 00 69 00 6e 00 20 00    .i.n. .
0078: 6d 00 73 00 76 00 63 00   m.s.v.c.
0080: 72 00 39 00 30 00 2e 00   r.9.0...
0088: 64 00 6c 00 6c 00 20 00   d.l.l. .
0090: 39 00 2e 00 30 00 2e 00   9...0...
0098: 33 00 30 00 37 00 32 00   3.0.7.2.
00a0: 39 00 2e 00 36 00 31 00   9...6.1.
00a8: 36 00 31 00 20 00 34 00   6.1. .4.
00b0: 64 00 61 00 63 00 65 00   d.a.c.e.
00b8: 35 00 62 00 39 00 20 00   5.b.9. .
00c0: 66 00 44 00 65 00 62 00   f.D.e.b.
00c8: 75 00 67 00 20 00 30 00   u.g. .0.
00d0: 20 00 61 00 74 00 20 00    .a.t. .
00d8: 6f 00 66 00 66 00 73 00   o.f.f.s.
00e0: 65 00 74 00 20 00 30 00   e.t. .0.
00e8: 30 00 30 00 33 00 35 00   0.0.3.5.
00f0: 32 00 33 00 62 00 0d 00   2.3.b...
00f8: 0a 00                     ..      
 

jroe's picture

I updated the missing windows updates. Same issues.

 

JesusWept3's picture

Is there anything you can tell us about how the crash occurs?
Is it random? is it as soon as Outlook starts? on close etc?
And how many users is it affecting, and is this Windows 7 or XP or all versions?
And also im guessing you disabled Enterprise Vault Outlook Add In and everything starts working, you enable it again, and then it fails?
 

JesusWept3's picture

Someone else had a very very similar issue it seems, same module, similar version, faulting address etc

"Faulting application outlook.exe, version 11.0.8326.0, faulting module msvcr90.dll, version 9.0.30729.4148, fault address 0x0003523b. "

Their solution was

Solved!
Issue was finally traced to a deployed app that has broken "Program Files" permissions!
Thanks all for advice and help.

 

jroe's picture

I saw that post, which would of been nice to know specifically what they did to fix it.

a. winxp

b. occurs right when outlook begins to load the mailbox, crashes

c. disabling plugin  > outlook then works > enable plugin > relaunch > crash

 

i'm testing a new outlook profile but since its cache exchange mode i need to test if it works after loading.

JesusWept3's picture

I'm guessing what he did was looked at the Program Files directory and then pushed down the inheritance to everything underneath, and it was probably something in the Common files directory that was being affected

you could have a look at procmon and seeing if you're getting an access denied on a certain file underneath that is causing issue

jroe's picture

yikes i'll give that a shot. if you have other ideas though please share.

JesusWept3's picture

What about those that work?
The issue is that we don't know what the previous poster found and it could be individual permissions on a particular file that have changed as opposed to the top level folder

It would also be interesting to find out whether maybe it's the same software installed too as the other user

jroe's picture

I ended up finally caving and creating a new mail profile which then after downloading the mailbox no longer crashed (cache exchange mode is enabled for our users). 

 

When switching back to the original profile it crashed again. I can swap back to the profile that doesnt crash  and its fine. 

 

However if there is a fix that doesn't require creating a new mail profile for 40+ users that would be ideal. 

jroe's picture

What did not fix it:

  1. Installed missing updates
  2. Installed sp3 (the user is back to sp2 which is our standard working for other users)
  3. Fixmapi command
  4. Resetevclient.exe C:\Program Files (x86)\Enterprise Vault\EVClient
  5. Repair of office
  6. Clearing cache files
  7. Repairing IE settings
  8. Reinstalled the plugin
  9. Ran scanost.exe
JesusWept3's picture

Your best bet is to call support and get some memory dumps and a procmon log as well

jroe's picture

i repeated the same steps for a second user and now they crash and get a second error:

"enterprise vault outlook add-in coudl not establish a connection to your exchange mailbox. restart outlook and if the same error occurs repeatedly, call your help desk. "

jroe's picture

Ok 2nd user: removed pst file and it stopped crashing.

Rob.Wilcox's picture

Odd that you have the issue so widespread, but it's got to be environmental, in my opinion.. otherwise EVERYONE would have this, and they don't.  I wouldn't suggest contacting Support and going the memory dump route, unless you've got a huge amount of time, and, it's not likely to result in a fix in the Outlook Add-in since a new profile and so on resolves the issue.

 

Antivirus?  Anything we need to  know about that?

jroe's picture

we are using SEP, and are not having AV issues with other users.

It appears to be an issue with the pst files and the plugin not playing nice together for 2 users so far in a pilot group.

I tried disabling SEP (symantec) and it didn't resolve the issue either. I didn't get a chance to run scanpst to potentially repair the pst file which could potentially stop it from crashing. My guess is its hitting an email it doesnt like and crashing. Odd part is it occurs ASAP after loading outlook.

 

Rob.Wilcox's picture

Can you post a full client log?

It is unlikely that the Outlook Addin will be touching the PST file as soon as Outlook launches.  It's normally a few minutes later, however, if the PST has been marked, and ingested in to EV, and due for deletion THESE are processed as soon as Outlook launches (I think).

But we'd be able to tell for sure from the Outlook Addin log file (if you enable maximum logging too, that'd be super)

jroe's picture

I'll have to research that, I'm back Monday thank you Rob!

jroe's picture

Rob that appears to be exactly what happens. I believe the pst is marked and is ingested into EV. An engineer took a screenshot of the server which shows the pst file in its location in a "completing" state. My plan is to run scnapst on the file to attempt and repair it which is tedious.

I will research how to enable the logging if I can get time to work with the user.

Rob.Wilcox's picture

Logging...

 

HKCU \ Software \ KVS \ Enterprise Vault \ Client

Set / Create, LoggingLevel, DWORD value 3

 

Start the client.. let it crach, post the log file.

 

And in the end you need to get a userdump of the crash and have it analysed by Symantec/Microsoft.

jroe's picture

Have another user that contiues to crash from the personal folders. Ran the scanpst utility and it did not stop the issue.

tried /cleanprofile, /resetnavpane, /cleanviews outlook switches with the same issue. I was able to generate the log, not sure waht to do with it.

jroe's picture

It was the log file itself. I turned off the errors to "errors only" and it stopped crashing.

 

Side Issue 1: if they have a sharepoint list mailbox  (same issue that causes my.domain.com to load in outlook) right click and close this box)

-this normally appears in the bottom left area of their outlook folder list of mailboxes (right click and close)

 

Main Issue 2: Change logging from minimum or maximum to “errors only”

Outlook 2007: Ctrl+shift > select the vault icon to bring up the menu > change to errors only > ok

  1. enable the plugin first in tools > trust center > addons
  1. select the disabled plugin and enable it. close outlook
  1. regedit (or go to c:\windows\system32 and right click and run with you’re a# account regedt32.exe)
  1. change the LoggingLeveL dword registry setting to 0
  2. hkey_current_user\software\kvs\enterprise vault\client
  3. relaunch outlook
  1. make sure the plugin for enterprise vault is enabled
  1. make sure their personal folders are mapped if needed. Otherwise the vault will find them and trickle them back in to the vault.

 

SOLUTION
Rob.Wilcox's picture

Glad you got it sorted.

One thing though is that the SharePoint list PST files isn't anything specific to the Enterprise Vault Outlook Addin.  SharePoint (or rather the end user) has opted to do that.

jroe's picture

Thanks!

The sharepoint lists I believe get generated if a user has a mysite. Its more of a nuance feature in outlook that can be closed. I believe it was crashing due to the debug file though.

 

Outlook 2007: setting the debug level to "errors only" stopped the crashing

Outlook 2010: needed to be set at minimum (lvl 3) or higher in order to be remotely deployed to outlook 2010 windows 7 boxes sucessfully. Otherwise it would not appear to be running even if the add-on was enabled. For instance I changed the debug level to 0 in my registry and now the vault is disabled.

changing hkey_current_user\software\kvs\enterprise vault\client\logginglevel to 3 helps "show" the enterprise vault features again in outlook.

 

I hope this helps others.