Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Vault 9.02 move archive waiting to update shortcuts

Created: 23 Oct 2013 • Updated: 24 Oct 2013 | 11 comments
This issue has been solved. See solution.

Hi

I have some problem.

I moved few days ago about 50 archives from one vault store to second vault store. 

Almost all have completed succesfull except 5 of them. 

They are still on status 2-5 waiting to updated shortcuts. All of them were moved 2 weeks ago. 

These 5 archives are with disabled mailboxes and mailboxes for them doesn't exists anymore. 

So what can I do now with these move tasks ? I'm unable to delete them or cancel. 

How can I remove them from move archive status window ? 

I also want to delete source archive for this move. 

 

 

Operating Systems:

Comments 11 CommentsJump to latest comment

EV_Ajay's picture

Hi,

If the mailbox for those move archive not exist then Shortcut update will never.

The move archive feature is using Copy & Paste method.

Hence you can export old archives data into PST and then delete the Move archive Task from EV Server and then Delete the archive if you want to delete.

Once move archive done successfully then need to delete Soure archive from source server manually, it's manual process.

 

Thanks,

Ajay

Remek's picture

thanks for replay 

but I have a problem, because I can't delete move task because I have all options grayed in move archive status, I can only select Properties or Refresh or Help. 

Any advice ?

EV_Ajay's picture
Hi,
 
During an Archive move the original Archive is marked as closed and a new Archive is created in the Destination. If for some reason the destination archive is deleted during the move then follow the steps below to remove the failed task so the task can be re-run.

1. Log into SQL Admin and expand the EnterpriseVaultDirectory database and then tables.
2. Open the Archive table and locate the entry for the failed archive
3. Update the ArchiveStatus value from 3 (closed) to 1 (open) and then close the table.
4. Open the subtask table and remove the row entry for the failed task
5.Open the Vault Admin console and confirm:

a. The Archive now shows a status of 'available' under the list of Archives
b. The task entry no longer exists in the Move Archive Status window
6. Restart the Move Archive wizard.
 
I would recommend to do not carry above steps without opening case with Symantec.
 

Thanks,

Ajay

SOLUTION
Remek's picture

it works but not to the end

I did what you wrote and now I have two archives status available, also I don't have any more task in move archive status.

But now when I want to delete this archive from Vault Console in Archives/Exchange Mailbox I get information:

"The archive cannot be deleted because it is being moved by domain\accountname. "

I've restarted vault server but I still get the same information. 

How can I delete this archive ?

 

 

EV_Ajay's picture

You can delete the archive in the following manner.

1. Right click on Archives --> Click Move Archive Status.

2. Select the archive and then click on Delete (X) button to delete the archive from the move archive status.

3. Sometimes the delete (X) button is not available to delete. In this scenario you have to access the SQL server to delete it from backend.

4. Open you SQL Server Management Studio

5. Expand EnterpriseVaultDirectory --> Tables --> Click on New Query

6.  Run the following command

user EnterprisevaultDirectory

select * from subtask.

delete from subtask  (To delete all entries from the SQL subtask table)

or

delete from subtask where column_name= 'column_vaule'  (To delete single entry from the SQL subtask table)

7. Refresh the screen from the Move Archive Status and you will see the list is empty

8. Expand the archives --> Click on Exchange Mailbox --> Right Click on Archive and then click delete

9. Click yes and the archive will be marked for deletion.

Thanks,

Ajay

Remek's picture

Ok I know how to delete archive when move status is completed

but I can't now deleted source archive which had status waiting to update shortcuts and I did what you wrote. This works perfectly, I could delete moved archive but I can't still delete source archive for this move. 

It still has an error: The archive cannot be deleted because it is being moved

I also can't see move status in move archive status because I deleted it from sql table 

EV_Ajay's picture

Deleting archives after Move Archive.
http://www.symantec.com/docs/HOWTO57342

Thanks,

Ajay

EV_Ajay's picture

Hi,

Could you let me know the Status of the Archive which you tried to delete. At the time of deletion is it generating any Event ID on EV Server , if yes please share it.

 

Thanks,

Ajay

Remek's picture

I have checked archive status in sql database do.Archive and status it's 1

also in Vault Console I see status of this archive as Available 

When I'm trying to delete this archive I get information that this archive is moving and I don't see any error or warning in event viewer (application, Symantec Enterprise Vault)

 

Remek's picture

I found solution

in database EnterpriseVaultDirectory you need to open Table SubTask, find all records which has your archive name in column parameters. 

Next open table ExchangeMailboxEntry and find archive name, go to last column MoveArchiveShortcutSubtask and change value to NULL

then go again to table SubTask and remove row with archive name in column parameters

Now you are able to delete archive from vault console. 

 

Thanks EV_Ajay you are the best

EV_Ajay's picture

Hi Remek,

Thanks for your reply.

We understand new thing.

Thanks,

Ajay