Video Screencast Help

Vault Eject

Created: 21 Feb 2013 • Updated: 21 Feb 2013 | 10 comments
This issue has been solved. See solution.

Hi Guys,

Due to some bad planning my daily vault job ran into my weekly vault job which had not completed. So before the jobs completed, I changed the settings on both of my vault profiles from Eject Mode immediately to Eject Mode Deferred. But I forgot to change the Suspend this sessions media from At time of eject to Immediatedly. I now have 2 active vault jobs at 76%. The total number of tapes written to are 26. My Mail Slots used for ejection have a capacity of 12 only. What would be the best way to get the media ejected? Attached are screen shots. Thanks

Comments 10 CommentsJump to latest comment

Nagalla's picture

Weekly job asking you to empty the map,

once you empty the map, you can get the rest of the tapes get ejected.

you can cancle the daily job.and let it run in next schedule.

snawaz3's picture

There were tapes in the map. But I had set it to defered eject. When did the tapes get ejected?

Mark_Solutions's picture

If these jobs were changed after they had already started to run then your changes will not have taken effect as the jobs were submitted with all original values passed to the jobs

They will not be valid until the next run

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

Nagalla's picture

may be vault job vault job submitted before you edit the profile.

please post the detail.log form vault seesions /usr/openv/netbackup/vault/session/<profilename>/<sid>/  to make sure what actaully happend.

snawaz3's picture

Yes. The vault jobs were actaully running when I edited the profile. Attached are the log files for both vault jobs. How do I get vault to suspend and eject the remaining media?

AttachmentSize
Detail_ daily Log.docx 236.91 KB
Detail_ weekly Log.docx 700.25 KB
Nagalla's picture

Yes. The vault jobs were actaully running when I edited the profile.

 

this answers your Previous quetions, let the current job compleate successfull and the modification that you made will take affect from next run.

to let the current job compleat you need to you need to remove the tapes from MAP,and let the rest of tapes ejected.

 

snawaz3's picture

There are no active jobs running. The map had 12 tapes in them. When I removed the tapes from the map,the vault jobs completed. There are still 18 tapes that need to be ejected. These tapes did not eject to the map.

Since the vault jobs have completed with deferred eject, have the tapes been suspended? The suspention was set to on eject but these tapes have not ejected. If the jobs have been suspended then can I through the web interface move the tapes to the map for removal? Thanks

Will Restore's picture

to check media status (i.e. SUSPENDED), run this command

bpmedialist -U -m mediaID 

Will Restore -- where there is a Will there is a way

Nagalla's picture

I am seeing from log that your Weekly job did eject 24 tapes. and later it got failed.

 

05:02:06.414 [2672.14572] <4> vltrun@VaultScsiRobot::doStartEject()^933: Executing command: "D:\Program Files\Veritas\Volmgr\bin\vmchange.exe" -res -multi_eject -sc -rn 0 -rt tld -rh ndumgt001 -vh ndumgt001 -v --- -ml DL8473:KW7015:KW7014:KW6946:KW6910:KW7006:KW6944:KW7018:KW7000:KW7011:KW6587:KW7007
 
08:28:39.681 [2672.14572] <4> vltrun@VaultScsiRobot::doStartEject()^933: Executing command: "D:\Program Files\Veritas\Volmgr\bin\vmchange.exe" -res -multi_eject -sc -rn 0 -rt tld -rh ndumgt001 -vh ndumgt001 -v --- -ml KW6540:FZQ270:KW6589:KW6599:DL8462:KW6586:KW6904:KW6578:KW6868:CT3133:BQ0125:BQ0133
 
08:28:45.110 [2672.14572] <16> vltrun@VaultScsiRobot::doEject()^933: There are problems in doing eject, returned 287
 
you does not need to worry about much, as loog as you got the tapes ejected.
the left over tapes will get eject  in next vault session.
 
just moniter next run...
SOLUTION