Video Screencast Help

VCS ERROR V-16-10001-20565

Created: 10 Jan 2013 • Updated: 22 Jan 2013 | 7 comments
Zahid.Haseeb's picture
This issue has been solved. See solution.

Environment
 
OS = SOlaris10
HA/VCS = 6.0

Cluster Nodes = Two

Error

Jan xx xx:32:27 Sec-Node AgentFramework[437]: [ID 702911 daemon.notice] VCS ERROR V-16-10001-20565 Application:ABC-APP:imf_register:Could not register process (./ABC-APP) as part of resource (ABC-APP), errno <3>

Query

While Restart the passive node I see the above error message at console. I feel that as my Application Process is not configured for AMF/IMF and I am using a tradational monitoring instead of AMF/IMF funcitionality thats why its showing the ERROR. But my question if I have not configured the AMF/IMF than why I am able to see this ERROR. Does the AMF/IMF by default ON ? or what is happening. Please share your comments

Discussion Filed Under:

Comments 7 CommentsJump to latest comment

ScottK's picture

You might want to search SORT:

https://sort.symantec.com/search?q=V-16-10001-20565

which yields a couple of hits in the documentation

Zahid.Haseeb's picture

@ ScottK as per your TechNote ""Once VCS gets into this state, IMF registration for the particular resource does not succeed, unless the AMF driver is unconfigured and reconfigured.""

1.) What are the steps for "AMF driver is unconfigured and reconfigured". please share the steps.

2.) I have configured Application Resource start, stop and monitor process only. I feel that there are more steps to configure the AMF which I did not do thats why I am facing the ERROR.

 

===========================

I read the guide and see from Page # 229 under VCS Admin Guide (http://sfdoccentral.symantec.com/Storage_Foundatio...)

Extract:

Enabling and disabling AMF on a system
 

Enable or disable AMF as follows:
To enable AMF on a system
◆ Run the following command:
haimfconfig -enable -amf
This command sets the value of AMF_START to 1 in theAMFconfiguration file.
It also configures and loads the AMF module on the system.
To disable AMF on a system
◆ Run the following command:
haimfconfig -disable -amf
This command unconfigures and unloads the AMF module on the system if
AMF is configured and loaded.
It also sets the value of AMF_START to 0 in the
AMF configuration file.

 

I think this above Extract answered of my question(s) ..So disable and re-enable can do:

""AMF driver is unconfigured and reconfigured."" as your suggested TechNote is saying (https://sort.symantec.com/search?q=V-16-10001-20565)  ..Right ?   :)

Any comment will be appreciated. Mark as Solution if your query is resolved
__________________
Thanks in Advance
Zahid Haseeb

zahidhaseeb.wordpress.com

Zahid.Haseeb's picture

Thanks ScottK

As per your LINK I saw the first four links. That link I already googled. But what does it means, this is my question please.

(My direct question is why I am having this ERROR regarding IMF/AMF if I am still not using this functionality)

Thanks :)

 

Any comment will be appreciated. Mark as Solution if your query is resolved
__________________
Thanks in Advance
Zahid Haseeb

zahidhaseeb.wordpress.com

mikebounds's picture

When AMF was introduced in 5.1SP1 it was disabled by default - see extract from SFHA 5.1SP1 Install guide:

 

AMF configuration files
/etc/sysconfig/amf 
AMF_START—Defines the startup behavior for the AMF module
after a system reboot or when AMF is attempted to start using
the init script. Valid values include:
1—Indicates that AMF is enabled to start up.
0—Indicates that AMF is disabled to start up. (default)
But in 6.0 it is enabled by default - see extract from SFHA 6.0 Install guide:
 
AMF configuration files
/etc/sysconfig/amf
This file stores the start and stop environment variables for AMF:
AMF_START—Defines the startup behavior for the AMF module
after a system reboot or when AMF is attempted to start using
the init script. Valid values include:
1—Indicates that AMF is enabled to start up. (default)
0—Indicates that AMF is disabled to start up.
To verify if AMF is enabled you could look in /etc/sysconfig/amf or use:
 

 

haimfconfig -display
 
If you want to stop this error I guess you need to disable AMF - see VCS admin guide:
To disable IMF for all IMF-aware agents
Run the following command:
haimfconfig -disable
 
Mike
 

 

UK Symantec Consultant in VCS, GCO, SF, VVR, VxAT on Solaris, AIX, HP-ux, Linux & Windows

If this post has answered your question then please click on "Mark as solution" link below

SOLUTION
Zahid.Haseeb's picture

 

Thanks for your kind words Mike

 

Node 1

 

# ./haimfconfig -display

#Agent         STATUS

Application    ENABLED

Db2udb         ENABLED

Mount          ENABLED

Netlsnr        ENABLED

Oracle         ENABLED

Process        ENABLED

Sybase         ENABLED

SybaseBk       ENABLED

Zone           ENABLED

 

Node 2

 

# ./haimfconfig -display

#Agent         STATUS

Application    ENABLED

Db2udb         ENABLED

Mount          ENABLED

Netlsnr        ENABLED

Oracle         ENABLED

Process        ENABLED

Sybase         ENABLED

SybaseBk       ENABLED

Zone           ENABLED

 

So, Running the below command will stop AMF/IMF functionality for all above Agents.

haimfconfig -disable

Any comment will be appreciated. Mark as Solution if your query is resolved
__________________
Thanks in Advance
Zahid Haseeb

zahidhaseeb.wordpress.com

mikebounds's picture

Yes.

Mike

UK Symantec Consultant in VCS, GCO, SF, VVR, VxAT on Solaris, AIX, HP-ux, Linux & Windows

If this post has answered your question then please click on "Mark as solution" link below

Zahid.Haseeb's picture

What I understand that the IMF/AMF module was not able to START due to some reason.

Any comment will be appreciated. Mark as Solution if your query is resolved
__________________
Thanks in Advance
Zahid Haseeb

zahidhaseeb.wordpress.com