Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

VCS NOTICE V-16-1-52563 VCS Login:Enter Password:VCS WARNING V-16-1-11135 Cannot get password -- error 0x6

Created: 22 May 2014 • Updated: 20 Jun 2014 | 4 comments
This issue has been solved. See solution.

Hi,

I need help to remove this error.

VCS NOTICE V-16-1-52563 VCS Login:Enter Password:VCS WARNING V-16-1-11135 Cannot get password -- error 0x6

I have performed the steps from the solution on this page (http://www.symantec.com/business/support/index?pag...) but still when I try to switch the service group the error occured.

.vcspwd content

# more .vcspwd
100 globalzone02 z_res_localzone02_zone_globalzone02.region.company.net JlmHlgKrlFmiKglSlg
# hostname
localzone02
#

Thank you.

Operating Systems:

Comments 4 CommentsJump to latest comment

sajith_cr's picture

Which version of VCS  are you using?

You need to perform the commands on each node after switching the service group to a node.

If the VCS version you are using provides hazonesetup utility, then you can use this utility on each node.

Regards,

Sajith

If this post has helped you, please vote or mark as solution.

Kimberley's picture

I've moved this to the Cluster Server forum.

Thanks for participating in the community!

mikebounds's picture

The instruction in the link do not give much details about creating the new account from the Cluster Manager Java Console - the details are:

  1. Create user with no privileges
  2. Add user as an administrator to service group that contains zone resource (modify "Administrators" attribute for service group so group has line:
    Administrators = { new_account_name }
    in main.cf

You should have a line in .vcspwd for every node in the zone can fail to, so if your zone resource is in a failover group then you should have multiple lines (you only have 1) and it should only have one line if the zone resource is in a parallel service group.

Note you can test .vcspwd is working by logging out of zone, logging back in (as root), setting and exporting VCS_HOST to name of global_zone and then test you can run a VCS command like "hagrp -list" and it should NOT prompt for a password.

Can you provide attachment or copy and paste your main.cf

Mike

UK Symantec Consultant in VCS, GCO, SF, VVR, VxAT on Solaris, AIX, HP-ux, Linux & Windows

If this post has answered your question then please click on "Mark as solution" link below

executablez's picture

Hi,

Thanks a lot for the comment. I have solved the issue by ran again the following command.

hazonesetup -g sg_listenername_zone -r res_zonename_zone -z zonename -p password -a -l -s globalzonename

I have run this on both node and it created a new entry for .vcspwd file and everything is running fine now.

Thank you.

SOLUTION