Video Screencast Help

Veritas Cluster 5.1 SP1 on RH 5.5 with Weblogic9 agent. Managed status not detected and fails to start

Created: 18 Aug 2011 • Updated: 26 Aug 2011 | 2 comments
This issue has been solved. See solution.

Hello,

I've setup Weblogic (10.3.2) Managed on VCS 5.1 SP1 which starts fine, but after some time, status is not detected and shutsdown.

I see in log, that instead of Info I get Notice, that managed1 started and its ignored:

 

9:14:28 V-16-1-50135 
User admin fired command: hares -online wls_managed1_app  luota1be  from ::ffff:127.0.0.1
 
9:15:34 V-16-55008-20186 
(something) WebLogic9:wls_managed1_app:online:<WebLogic9::DelayEntryPoint>: First Level Check , server responding at [wbl-managed-vip:7101].   

 

9:15:38 V-16-55008-20191 
(something) WebLogic9:wls_managed1_app:online:<WebLogic9::DelayEntryPoint>:Server [managed1] responding to Second Level Monitor checks.     
 
9:15:38 V-16-55008-20283
(something) WebLogic9:wls_managed1_app:online:<main::OnlineEntryPoint>:Resource [wls_managed1_app] started up successfully. 
 
9:17:40 V-16-2-13066 
(something) Agent is calling clean for resource(wls_managed1_app) because the resource is not up even after online completed.    
 
9:17:50 V-16-55008-20080 
(something) WebLogic9:wls_managed1_app:clean:<WebLogic9::Kill>:Graceful shutdown of this WebLogic Server succeeded.     

Comments 2 CommentsJump to latest comment

RastoD's picture

Problem was, that IP address was not detected by agent.

Adding IP of managed server to the service group solved it.

SOLUTION
Satish K. Pagare's picture

If you have configured the WebLogic Server to bind to a virtual IP, then its necessary that the IP is online on the system before WebLogic resource comes online. You will have to use an IP resource if this is a virtual IP and not the physical IP of the machine.