Video Screencast Help

Veritas Cluster Server 6.0 -- hauser -update

Created: 21 Aug 2012 • Updated: 22 Aug 2012 | 4 comments
This issue has been solved. See solution.

Dear All,

I  had added a new administrator user on vcs , like that, (#hauser -add clusteruser -pirv -Administrator ), but I cannot use the command (#hauser -update), because doesnt have that option, Do you know how can I get a password? I am trying using Veritas Cluster Manager Java Console to manage the cluster.

I am using VCS 6.0 on RedHat Linux 6.1.

Thanks in advance


Comments 4 CommentsJump to latest comment

Neeraj Bhatia's picture

Hi Alejandro,

The hauser man page describes the available options for hauser.

The section on Adding a User in the VCS Administrator's Guide provides the following information about adding users:

To add a user

  1. Set the configuration to read/write mode:
    # haconf -makerw
  2. Add the user:
    # hauser -add user [-priv <Administrator|Operator> [-group 
  3. Enter a password when prompted.
  4. Reset the configuration to read-only:
    # haconf -dump -makero

Here is some more information:

Please let us know if you need additional information or clarifications. 

arangari's picture

what is the error you are getting if you run 'hauser -update'?

Thanks and Warm Regards,

Amit Rangari

If this post helped you resolving the issue, please mark it as solution. _____________________________________________________________________________

alejandro-g's picture

Hi people,,

Look this issue

[root@rhvc1 vcs]# hauser -list

[root@rhvc1 vcs]# hauser -add admin-cluster -priv Administrator

[root@rhvc1 vcs]#

[root@rhvc1 vcs]# hauser -list
admin   admin-cluster

Is not the update options

[root@rhvc1 vcs]# hauser
VCS INFO V-16-1-10601 Usage:
        hauser -add <name> [-priv <Administrator|Operator|Guest> [-group <group(s)>]]
        hauser -addpriv <name> <Administrator|Operator|Guest> [-group <group(s)>]
        hauser -delpriv <name> <Administrator|Operator|Guest> [-group <group(s)>]
        hauser -addpriv <name> <AdministratorGroup|OperatorGroup> [-group <group(s)>]
        hauser -delpriv <name> <AdministratorGroup|OperatorGroup> [-group <group(s)>]
        hauser -delete <name>
        hauser -display [<name>]
        hauser -list
        hauser -help

[root@rhvc1 vcs]#

 it could be an issue between Veritas Cluster and RedHat Linux, is weird


alejandro-g's picture

Hello again,

Problem Solved

Reconfigure the cluster , in this step

"Veritas Cluster Server can be configured in secure mode

Running VCS in Secure Mode guarantees that all inter-system communication is encrypted, and users are verified with security credentials.

When running VCS in Secure Mode, NIS and system usernames and passwords are used to verify identity. VCS usernames and passwords are no longer utilized when a cluster
is running in Secure Mode.

Would you like to configure the VCS cluster in secure mode? [y,n,q,?] (n) no

It works ;)

[root@rhvc1 rhel5_x86_64]# hauser -update admin2
Enter Password:

Enter Again:

[root@rhvc1 rhel5_x86_64]#