Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

Veritas operations manager for SF Unix

Created: 04 Oct 2012 • Updated: 08 Oct 2012 | 6 comments
Umair Khalid's picture
This issue has been solved. See solution.

hi team,

 

i created a virtual Solaris 10 machine on Vmware and i have installed Storage Foundation Standard in it.

 

I need a GUI interface to manage and administer SF. I downloaded VEA and VOM (add ons) both.

 

i installed the VEA package VRTSobgui and it has been successfully installed. i actvated and started the vxsvccrtl and the status shown ONLINE. however wen i run opt/VRTsob/bin/vea nothing happens.

 

I then tried installing the VOM but the files i got for VOM were in the form of .sfa, I need to know where do i put these files so that i can run the VOM with an interface. 

 

thank you.

Comments 6 CommentsJump to latest comment

Marianne's picture

You will need an X-manager if you want to run vea on the virtual machine. 
Much easier if you download the Windows version and install it on your desktop.

As far as VOM is concerned, please download the VOM installation guide. https://sort.symantec.com/documentation

See supported Operating Systems for Management Server.
(Only Solaris SPARC is supported as Management server.)
Easiest is to use a W2003 or W2008 VM.

Solaris 10 x86 is only supported as Managed Host.

 

 

 

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

mikebounds's picture

As Marianne says, I think you need VEA client for windows which you can download from http://www.symantec.com/theme.jsp?themeid=operations_manager by clicking on Veritas Cluster Server Java Console, Veritas Cluster Server Simulator, Veritas Enterprise Administrator Console and logging on (free account) and selecting Veritas Enterprise Administrator 3.4.30 download for Windows or whatever O/S you run as your client desktop.  This will manage SF on your Solaris 10 node.

VOM is overkill to manage one node as this is a central GUI installed on a server to manage multiple servers and you access GUI by connecting to VOM server via a browser.  I think you have downloaded an add-on to the VOM server (with .sfa extension) which only VOM will understand.

As Marianne says, if you want to run VEA from your Solaris node, you will need a UNIX desktop, which would normally be a Linux client or X-Windows software on Windows

Mike 

UK Symantec Consultant in VCS, GCO, SF, VVR, VxAT on Solaris, AIX, HP-ux, Linux & Windows

If this post has answered your question then please click on "Mark as solution" link below

Jeff Foglietta's picture

Assuming your launching the gui on the Solaris virtual machine... Yes? You don't say whether your current display is a graphical destop or the system "#" prompt. If you are at s "#" prompt it is likely that the X11 packages are not installed or X11 isn't running. Verify that you have the X11 packages installed. If they are installed and you do not have the graphical "Welcome" login screen in front of you, the service needs to be started. Once started you can then log in to the system using X and the VEA gui should work. If the X service is running and your gui doesn't start you would likely get a connection refused error .. In this case cover all your bases by issuing  the command "xhost +" and verifying the DISPLAY variable is set  to 0:0 and try again.. If you are are telneting into the system you can redirect the X display back to the system your working from which must have an X server running. This is set with the "DISPLAY" variable...

Jeff Foglietta

Practice Lead - Data Protection and High Availability

Umair Khalid's picture

thank you for your help. I was able to connect to the Solaris virtual machine using the VEA installed on my wwindows desktop. I dont have a SPARC machine yet so i cannot test the VOM as yet. I'm still not sure if there is a way to get a graphical interface (VEA) inside the solaris machine instead of managing it from another windows machine.

Marianne's picture

We have tried to explain that you need  X-manager software on the machine that you are using to connect yo the VM. If you are using your Windows desktop, this is where the X- software needs to be installed. 
If you are using a text-based interface (like putty or telnet from CMD window) to connect to the Solaris VM, you cannot run a graphical interface from these windows. 
X- manager software as well as DISPLAY variable on the Solaris VM.

If you are not familiar with any of this (nothing to do with VEA specifically), it is easiest to use VEA on your Windows desktop.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

SOLUTION