Video Screencast Help

View EV domino data without EVDG or Notes?

Created: 18 Feb 2013 • Updated: 29 Aug 2013 | 3 comments
Jochen Köcher's picture
This issue has been solved. See solution.

Hi everybody,

besides official support, I am looking for a way to just display Domino journaled data without actually having an EVDG or Notes in place?

A customer migrated from Domino to Exchange. They journaled Domino data in the past and have now a journaling and mailbox archiving on Exchange in place. The customer doesn’t want to migrate/transform the Domino Journaling data, because of its size. A mere viewing within EV search (without export to NSF) would be sufficient. The domino data is save to EMC Centera.

I've tested this in moving the domino vault stores to a non EVDG server. Searches work fine, but opening the results leads to “Failed to get the document from the Storage Service” and in dtrace it corresponds to “Notes runtime was not initialized”.

  • Does anyone know if a local Lotus Notes installation is sufficient?
  • Are both EVDG and Lotus Notes required (in your opinion)?

Thanks for your insights. Best regards,


PS (Edited 29.08.2013): As this thread is closed, follow-up on:

Comments 3 CommentsJump to latest comment

Paul Honey's picture


An EVDG plays no role whatsoever for Domino journaled data, it is only relevant to servicing mailbox archiving retrievals so I do not see that as a requirement at all

Installing Lotus Notes on the EV server would be necessary for the EV services (such as Storage and others) to initialise the IBM Lotus C API that we use to access Domino data in its archived state and have any chance of retrieving it to the notes client and an original rendition

Alternatively, have you tried searching the Domino journal archives using …\enterprise vault\search.asp? Provided your AD account that you login with has access to the archive, you could use that to search the archives and view the HTML rendition of messages within the browser, rather than trying to open the original version in Notes?

Your other option is to use Discovery Accelerator to search / view the archives and the HTML rendition that we save, or additionally install Lotus Notes on the DA server also so that the data can be produced / exported in its original format

Let me know if any of those work for you



Paul Honey | Enterprise Vault Engineering | Customer Focus Team (CFT) | Symantec Corporation |

Jochen Köcher's picture

Hi Paul,

thanks for the reply. Okay, this is good to know that a EVDG is not required in your opinion. It's easier to have Lotus Notes updated with a supported version by EV/OS like 5 or 10 years down the line. I don't know what OS or Lotus Notes version would then be available. :-)

That is actually a phenomenon, that I used an AD account with permissions and searched via http://%evserver%/enterprisevault/search.asp. When I dtrace the search and especially the opening of the object, I see this in dtrace (below).

Though I was very much hoping for this result, the HTML rendition isn't accessed. To me it looks like it still requires the original object to open the rendition...

469         14:18:41.481       [9696]  (StorageOnlineOpns)    <3060>  EV:L     {CBinaryDominoSaveset::LoadEVNoteStreamFromSaveset} (Entry)
470         14:18:41.481       [9696]  (StorageOnlineOpns)    <3060>  EV:M     NotesRuntimeHelper::IsInitializedOnMainThread - could not open event [EV~NRH~MAINTHREAD~25e0] - The system cannot find the file specified.  (0x80070002)
471         14:18:41.481       [9696]  (StorageOnlineOpns)    <3060>  EV:M     CBinaryDominoSaveset::LoadEVNoteStreamFromSaveset - error: Notes runtime was not initialized
472         14:18:41.481       [9696]  (StorageOnlineOpns)    <3060>  EV:H     CBinaryDominoSaveset::LoadEVNoteStreamFromSaveset _com_error exception. hr=Catastrophic failure  (0x8000ffff)
473         14:18:41.481       [9696]  (StorageOnlineOpns)    <3060>  EV:H     {CBinaryDominoSaveset::LoadEVNoteStreamFromSaveset} (Exit) Status: [Catastrophic failure  (0x8000ffff)]
474         14:18:41.481       [9696]  (StorageOnlineOpns)    <3060>  EV:H     CBinaryDominoSaveset::GetProperty _com_error exception. hr=Catastrophic failure  (0x8000ffff)
475         14:18:41.481       [9696]  (StorageOnlineOpns)    <3060>  EV:H     {CBinaryDominoSaveset::GetProperty} (Exit) Status: [Catastrophic failure  (0x8000ffff)]
476         14:18:41.481       [9696]  (StorageOnlineOpns)    <3060>  EV:H     CDominoTraverserBase::GetMsgProperty _com_error exception. hr=Catastrophic failure  (0x8000ffff)
477         14:18:41.481       [9696]  (StorageOnlineOpns)    <3060>  EV:H     CMessageExtractor::OnMessage _com_error exception. hr=Catastrophic failure  (0x8000ffff)
478         14:18:41.481       [9696]  (StorageOnlineOpns)    <3060>  EV:H     {CMessageExtractor::OnMessage} (Exit) Status: [Catastrophic failure  (0x8000ffff)]
479         14:18:41.481       [9696]  (StorageOnlineOpns)    <3060>  EV:H     {CDominoTraverserBase::ProcessMessage} (Exit) Status: [Catastrophic failure  (0x8000ffff)]
480         14:18:41.481       [9696]  (StorageOnlineOpns)    <3060>  EV:H     CDominoTraverserBase::Traverse _com_error exception. hr=Catastrophic failure  (0x8000ffff)
481         14:18:41.481       [9696]  (StorageOnlineOpns)    <3060>  EV:H     {CDominoTraverserBase::Traverse} (Exit) Status: [Catastrophic failure  (0x8000ffff)]
482         14:18:41.481       [9696]  (StorageOnlineOpns)    <3060>  EV:L     CBinaryDominoSaveset::~CBinaryDominoSaveset - destruct
483         14:18:41.481       [9696]  (StorageOnlineOpns)    <3060>  EV:L     {AutoDeleteNote::Delete} (Entry)

I will look into just installing Lotus Notes and test...

Best regards, Jochen.

Paul Honey's picture

'Notes runtime was not initialized' is basically saying that that service cannot find the IBM Lotus C API, so it looks probably like it needs it loaded at the very least to crack open a Domino saveset, before determining whether to return the original Domino or HTML rendition. so install the Notes client and let me know your results.



Paul Honey | Enterprise Vault Engineering | Customer Focus Team (CFT) | Symantec Corporation |