Video Screencast Help

Virtual Machine Recovery Issues

Created: 21 May 2010 • Updated: 24 Aug 2010 | 5 comments
This issue has been solved. See solution.

Hi Everyone,

I'm hoping someone might be able to suggest some areas to look into with a few issues I'm running into while trying to restore a VM to an alternate location.  I have limited success depending on my restore options.
 
If I restore the VM (to an alternate location) using all the defaults, the restore is successful.  However, if I try and change some of the defaults, things don’t go so well.
 
Issues:
1.  If I try and select a different ESX host to restore to in the wizard, it doesn’t find any of my ESX hosts and I’m forced to cancel the restore:
http://www.tcpdump.com
http://www.tcpdump.com

2.  None of my network names are displayed in the wizard.  As a consequence, when I perform the restore, the VM is restored without any network adapters:
http://www.tcpdump.com

Any guidance anyone can give would be much appreciated.  I’ve enabled some debugging but haven’t found anything useful.  Hoping someone might be able to shed some light on these problems.
 
Thanks in advance!
Tom Hirt
http://www.tcpdump.com

Comments 5 CommentsJump to latest comment

Marek Kedzierski's picture

hmm maybe you should you should to add credentials for ESX server used for restore operations ? In NB7 you can add credentials for VC, ESX server and ESX restore server.

GG0001's picture

Did you find a solution for this I saw your post and checked mine and can only see 1 outta 12 ESX servers,all the ones in a cluster and invisible :).

thirt's picture

No resolution to this problem yet.

I tried adding the credentials to the individual ESX hosts as Marek suggested but this didn't help.  I'm at a loss on this one.

Richard Davies's picture

We have just done the same upgrades nb7 and esx 3.5, and are getting this issue also
credential fields are filled in, master server can see (via ping/hostfile) all 3 servers in our test environment the vc and 2 esx.
however the datacenter info does not get populated, when the vcentre server is selelcted
if None is choosen you can select the esx server but doesnt populate any datastore info(as if it cant see it)
checked san presentation and disks are there
even issued out some disk space to master to make sure.

have logged a support call
but any suggestions welcome

Richard

thirt's picture

Hi Richard - Symatec support was of no help to me; I wound up having to figure this one out on my own.

So as you probably already know, NBU is very fickle about name resolution (DNS.)  In order to resolve this issue I did the following:

  1. Use the FQDN throughout, do not use the DNS short name or IP address.  Using the short name or IP address will confuse NBU 7.0 and result in the problem I described above (hopefully Symantec will get this addressed in a future release.)  Make sure when you add the credentials for your vCenter server, you use the FQDN.
  2. Ensure the master, media (vmware backup host), vCenter and ESX hosts can all ping each other using the FQDN
  3. Ensure the display name for each ESX host in vCenter uses the FQDN (see image below)

www.tcpdump.com

Best of luck!
Tom Hirt
www.tcpdump.com

SOLUTION