Video Screencast Help

To Virtual Partiton - Failed

Created: 03 Oct 2009 • Updated: 21 May 2010 | 3 comments

I am working with Ghost Solutions Sute 2.x. Trying to image a client system automatically throught the Ghost Console using a TASK. Client is Windows XP SP3 - Server is on Win2K3 with XP2
Clients onboard NIC is a Marvell Yukon Gigabit (supports PXE)  - and the client has an additional 4 port Adaptec PCI NIC installed (Does Not Support PXE).

I am tring to execute a task to creat an image of a model client machine, however it failes to do so. I can manually boot to a Ghost Cd and creat an image, but cannot do it through the Ghost Console like i want it to.  Heres what i have done, and the results i get..

1. Using the Ghost console i have setup a task to create an image.
2. Execute the task - the task log on the bottom of the console stays task has started
3. After about 30-60 seconds the task ends with a status of "FAILED"
4. Double clicking the task brings up the Event log. The event log says step 1 "Updating PreOS Files" completed successfuly. But step 2 "To Virtual Partition" has FAILED
5. Double click "To Virtual Partition" in the event log brings up the task details. This is the information in the event details window
"Details for: To Virtual Partition

A Genreal exception occured causing the operation to fail:
A disk error occured
Win32 Error:(0x00000005)
Access is Denied

Generated at ..\DiskDriveAccessNT.cpp:150

Thread #3232 call stack
DiskDriveAccessNT::Make
DiskManagerNT::constructor

(then some memory references too long to post correctly online)"

I know the problem is ovbiously an Access is denied/permission problem. The question is WHERE.. What is the system attempting to do at this point? I suspect it is trying to reboot the system and go into the PreOS environment.

Under what user context / permission is this software trying to reboot the client computer? Is it using the "SYSTEM" account, or maybe the "SERVICE" account? Or is there a special account that i dont know about for this particular task within Ghost? 

Is it possiable the permission on the C: drive of the client machine? What access does Ghost need to have to my clients C: drive in order to perform the image create task? (It does copy files to the \Incomming directory during the 1st step of Updating PreOs files so i dont think that the client C: permissions are to blame....)

I have tried using all three Pre OS environments for my client machine (under the Machine Groups\ClientName properties tab). I have also tried using different Network Settings under the same tab)

We have just purchased this software, and ihave been working on this for a week solid - and im stuck on this step...

Can anyone shead some light on this issue? What else can i try???????

Comments 3 CommentsJump to latest comment

Eugene Manko's picture

Ghost client agent is trying to execute virtual partition dll. I presume (although you havent mentioned) that client is running Vista because XP is generally fine. Client agent runs in System context and so will VP.dll. VP will try to create virtual parttition inside your existing c: drive filesystem and then boot to it. This is what's failing. The fact that it cannot even access filesystem during make call usually means that your security permission is so tight that it cannot even open existing filesystem. Hence why I am guessing that you are running Vista out of the box, which makes system pretty much unsable. You will need to either grant Ghost client agent additional privileges to access filesystem or to loosen security restrictions. I'd suggest the first route first.

Drumgod's picture

I am running XP SP3 on my client.

I have discovered the source of my problem. We use a 3rd party software called Device Lock (v4.2) that is preventing this viritual partition from being created. Device lock is a software package that controlls permissions on removable media (hard drive are considered removable media) CD roms, floppy drives, tape driver, comm ports, ect... 

Whit that said, i need to know more about this virtural partition. I will have to assisng it permissions via device lock to allow ghost to access it. The problem i see here is that when the virtuial partition is created, the system reboots to quick to be able to observe the virtuial partition. Hence i have no idea what permissions to set, on what device. Is there a manually way to start the virtuial partition? If i can step throught that process, then i can determin what permissions/devices i need to assign in device lock.

So how can i step slowly through the virtuial partition process? please advise.

Eugene Manko's picture

Virtual partition is just a file in your filesystem that represents another filesystem. Ghost client agent needs to be able to create files on your system, defragment filesystem and shutdown OS. And no you cannot step slowly through building of the VP :)