Video Screencast Help

Virtual Vault doesn't appear until I run ResetEVClient.exe

Created: 22 Jun 2012 • Updated: 23 Oct 2012 | 5 comments
bjorn.b's picture
This issue has been solved. See solution.

Hello

I have a situation where the vault directory (virtual vault) doesn't appear in Outlook (2010) until we run ResetEVClient.exe on the client.

So - obviously the Virtual vault is configured, but the outlook add-in is bugging somehow. Any ideas folks?
BTW: this is EV 10.0.1

Appreciate your feedback :)

 

/bjorn

Comments 5 CommentsJump to latest comment

RichardG's picture

In order for it to be possible to add Virtual Vault to a user's profile, the VV store provider (EVMSP32.dll) must first be registered in the correct MapiSvc.inf file. This is normally done when the EV client is installed, but is also checked and re-done if necessary by ResetEVClient.

So it sounds like the installer may not for some reason have registered EVMSP32.dll correctly. One of the reasons that problems like this can occur is because the correct path to MapiSvc.inf is language dependent, on my English system it is in C:\Program Files (x86)\Common Files\SYSTEM\MSMAPI\1033\MAPISVC.INF.

Maybe the installation was performed by a user in a different locale to the one that is used to fix up the problem with ResetEVClient?

 

 

 

 

bjorn.b's picture

The installation was made in the same locale, and by a local admin on that computer. 

Any idea how to get around this issue?

/bjorn

/bjorn

RichardG's picture

Virtual Vault will have been tested in all language variants so it is likely that the problem is in some way environmental.

When you have the problem, do you get a client log line as below when you try to add the Virtual Vault node using the Vault Cache Properties dialog i.e. tick the archive name in the Virtual Vault tab and hit OK. You would also get an error message box displayed.

    26/06/2012 14:36:00.294: Could not create an instance of Virtual Vault. Verify that EVMSP is correctly configured in MAPISVC.INF: 0x8004010F

If so it would look like is it a MapiSvc.inf problem.

What language are you using for Windows, and what language is the Office UI set to run?

What numeric language directories exist in C:\Program Files (x86)\Common Files\SYSTEM\MSMAPI. These directories have numeric names based on the appropriate language code. Can you find one or more MapiSvc.inf files under the language code directories?

Which ones, if any, have Virtual Vault configured? - it would contain a line like "EVMSP=Virtual Vault" if it does.

bjorn.b's picture

 

We have the file MAPISVC in the folder 1044. See content below

The folder 1033 (which is the other folder in MSMAPI) hasn't got the MAPISVC file, only MSMAPI32.dll.

/bjorn

bjorn.b's picture

The solution was to run this command on all the clients: 

 
rundll32 EVMSP32.dll,MergeEVMSPWithMAPISVC
 
Probably related to the above mentioned problems/situations

/bjorn

SOLUTION