Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Virtual Vault empty, folders/mails disappearing at my users

Created: 22 Jan 2013 | 11 comments

Hello Community,

I am having many issues with Enterprise Vault at end users, all with the same problem. It started on 20th December where the first users reported his Virtual Vault in Outlook is completely empty. A reset does not help. Sometimes folder come back for a week, then disappear again. Problem exists at all plugin versions tried.

By today it seems more and more users are having this issue. As we did not change anything on our structure and the Vault server was running for 2 years now without issues, I wonder if there might be Windows Updates deployed causing that issue ?

So my queastion to the community, is anyone facing the same ? I have several tickets with Symantec Support open but until today we have not been able to solve this issue.

Thanks,

Andy

Discussion Filed Under:

Comments 11 CommentsJump to latest comment

Rob.Wilcox's picture

Pick a problem user.

Describe their environment.  Describe the server side environment.  Is this EV 10, 9 ?

What happens if they do a Vault Cache reset, and restart Outlook.  Do they get a full header synch?

Have you tried the *checks* in this article:

http://www.symantec.com/business/support/index?page=content&id=TECH52763

Then pick another problem user, and do the same (apart from the server part, as I assume that it is the same).

We need more info, really.

Andy297's picture

Hello Rob,

thanks for your reply. I am aware you need more information - I just wanted to ask in general if anyone in the community has this issue before I start describing everything in detail.

Its EV 9. After a Vault cache reset, Header and content synchronization works perfect. Also it works perfect while the issue is present.

I just had a look at that article and after doing the queries on the SQL server it looks fine to me!

That issue affects users on site or off site. Plugin version is mainly 9.04 but even with version 10 plugin its the same issue.

The behaviour of the issue is strange. It comes and goes, so it might work for a week and then folders on user side disappear again. Then its possible only the folders come back visible again, but no mails in them. Also I saw  users having only several folders in Outlook dissapear, but not all folders.

The logfiles tell nothing unusual. Symantec support by now checked several myximum tracing files, without result.

Something did change server or client side by end of last year as it worked perfectly until then and now more and more users are reporting.

Thanks for your help

Andy

Andy297's picture

More information to environment

Vault Server is 2003 Standard, 32 bit connected to a seperate SQL Server which is 2008 R2 x64

Users are working with Outlook 2007

Rob.Wilcox's picture

What version of EV is on the server?

Did you look at the article I sent?

Are you asking 'Did anyone else see this?', or do you want help in troubleshooting?

If it is the former -- then no, I've not seen it, nor has anyone reported anything similar on the forums ever (to my knowledge).

RichardG's picture

Could something odd be happening with permissions in your environment?

Are we talking about users looking at their primary archive or an archive delegated by someone else?

Andy297's picture

What version of EV is on the server?

>> 9.0.3.1164

Did you look at the article I sent?

>> Yes I did. I also tried the tree view xml file. It looks ok right now, but I just called a few users and it looks like its working for them again at the moment. I have several confirmations their Vault went back to normal state, meaning visible with all folders and mails in Outlook.

But, for some users I have to do a Vault cache reset, for some it works again without doing that.

Well, I assume the error will be back in a few days.

Are you asking 'Did anyone else see this?', or do you want help in troubleshooting?

>> I think for now I try to get it figured out with support, I will post again here if we cannot find the issue soon..

@Richard, that also came in my mind

JesusWept3's picture

I saw odd things with vv like this and it ended up being mcafee antivirus client on the end user machine messing up the mdc/DB files, an AV exclusion and a reset and issue never came back

Andy297's picture

@All

I found out something interesting. Just had a user with an Empty Vault and Empty Archive Explorer. Access rights on the primary archive looked OK for the user. All boxes checked (greyed out, as set by the synch job)

So I tested to add a manual explicit grant for the same user entry on the archive (only one users is set on all archives, and thats the owner of the mailbox)

So now access rights are set 2 times, one time by the job and one time manual. It then suddenly works in Outlook and in Archive Explorer. Now I noticed that sometimes the issue disappeared at users after synchronizing the mailbox again but re appeared few days later. So that leads to 2 things:

1. It looks like even if the boxes on the archive tell me user XY has access rights, it is not the case.

2. Why are the acces rights lost anyway, and why only sometimes ?

RichardG's picture

Re 1: Have you tried using the EV PermissionBrowser utility on the archive - it will enable you to see the folder level permissions that are set in the archive not just those set at the archive level. It might throw some more light on what is going on.

Re 2: Maybe the process of syncing the permissions from the Exchange mailbox to the archive is occasionally failing for some reason

Andy297's picture

Good hint with the utility, forgot about that...

Just went through some user lists and I see some have strange rights. Guess this are the ones where the sync is failing from time to time.

I just informed Symantec about this, lets see what we can find out about the syncing. I will definitely post the result here if we found it. Good thing is I have a workaround now ;)

Regards

Andy

Rob.Wilcox's picture

I'd have a look for 'multiple self' references in the permissions.