Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

VixDiskLib_Open() strange error

Created: 23 Sep 2013 | 8 comments

Hi all,

i am stuck with the a VixDiskLib_Open() error, but i really dont get the solution, and to be honest neither the meaning.

Scenario:

1 vm with Linux, 2 jobs on this vm as virtual machine (agent installed and so on) full and incremental, SAME storage destination. So nothing changes about permissions and so on.

The Full backup works perfectly, the Incremental one keeps telling me about VixDiskLib_Open() error.

Everything was smooth and clean until past friday, everything worked fine, we didnt do anything, no changes in configurations, no upgrades and so on.

Today not a single incremental backup can be done......and i really dont get why :-|

Any hint?

 

 

Operating Systems:

Comments 8 CommentsJump to latest comment

Jaydeep S's picture

What is the exact error message that you get. VixDiskLib_Open is very genirc to work with.

Is GRT enabled on this backup job. If yes, please perfrom a non GRT backup of linux VM (GRT is only supported for Windows VMs).

Whats is the version of ESX and Backup Exec

paolo.francolini's picture

Hi Jay

absolutely no GRT options, for granular recovery a use a second job agent based, this is just a vm backup.

This is the extended error:

V-79-57344-38277 - Unable to open a disk of the virtual machine.

VixDiskLib_Open() reported the error: You do not have access rights to this file
 

Jaydeep S's picture

Have you applied SP2 for Backup Exec 2012, if not, please do so as it does fix a lot of errors and also required to support ESX 5.1

See if this technote helps to fix the issue

http://www.symantec.com/docs/TECH129572

Rahul Kumar1's picture

ESX 5.1 is only supported from Backup exec 2012 SP2.

 

Thanks

paolo.francolini's picture

Hummm interesting question.....i am checking around but i can't find a tab or some like that where SP2 is readable.

Could you please give me a hint where i can retrieve this information?

Thx in advance!

Jaydeep S's picture

click on Backup Exec button located at the extreme top left corner -> Installation and Licensing -> Installed updates

If it is not installed you can get it from Live updates or from this link

http://www.symantec.com/docs/TECH203155

paolo.francolini's picture

Got it, there's no SP2 installed indeed, just SP1.
Thx so much for your help!