Video Screencast Help

VM Backup/Restore question (Confused)??

Created: 28 Feb 2013 • Updated: 28 Feb 2013 | 4 comments
This issue has been solved. See solution.

Hi,

I am currently using the VStorage API within 7.5.4, on certain policies I have set the VMWare option to exclude the datadisks so that only the C: is backed up for file level recovery and for VM recovery and the D drive is backed up using the traditional NBU client method.

Example of one server is a 60Gb C: and a 500Gb D: drive, the backup amount to virtual tape is 21Gb, only the C: is shown for a file level restore, when I run the VMDK restore I see two vmdk files, one is 60Gb and the other is 500Gb.

What I was wondering is when running the backup does the snapshot size equate to only the 60Gb C: drive or would it also include the 500Gb D: drive so that when a full VMDK restore is initiated it would then cover the C & D drives without the data on the D drive.

Kev

 

Operating Systems:

Comments 4 CommentsJump to latest comment

Yasuhisa Ishikawa's picture

I'm not clear about what you are wondering, but try to explain what happens while backup.

When backup starts, NetBackup ask vSphere to create snapshot of VM. This snashot include all vmdk(except independent vmdks) even if you specified 'Exclude boot disk' or 'Exclude data disks'.

Once snapshot is completed, NetBackup read vmdks regarding "Virtual disk selection" option. If set to 'Exclude data disks', netbackup read snapshot vmdk of boot disk only.

At VM recovery, NetBackup ask vShere to create all vmdks as it was regardless of 'Virtual disk selection' option, but excluded disks become empty after recovery because NetBackup has not data to restore.

Authorized Symantec Consultant(ASC) Data Protection in Tokyo, Japan

SOLUTION
Kevin Lamb's picture

Many thanks Yasuhisa, I apologise for the lack of clartity is the original question but as I was writing it it was getting confusing to me also :-)

You have answered the question and it is how I thought it worked but was unsure.

With the VM recovery are the vmdks that are shown for selection just part of a config file that are backed up on the original backup rather than the whole space as the completed backup is only 21Gb in size?

Kev

Yasuhisa Ishikawa's picture

I assume you have enabled 'Exclude deleted blocks' and 'Exclude swapping and paging files' on VMware tab(both is enabled by default). NetBackup takes only used blocks in C: drive and VM configuration in this case.

Authorized Symantec Consultant(ASC) Data Protection in Tokyo, Japan

Kevin Lamb's picture

Hi Yasuhisa,

Yes I have enabled both Exclude Deleted Blocks & Swapping and Paging Files in the VMware Tab, the issue looks to be more a reporting size than an actual size of the backup