Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

VM Restore To Alternative destination

Created: 17 Jan 2013 • Updated: 22 Jan 2013 | 9 comments
This issue has been solved. See solution.

Hi,

I am running NBU 7.5.0.4 and backing up our VM servers using the VSphere API within NBU, I am having an issue when trying to restore to an alternative location.

the recovery host is set as are all transport modes, the vCenter Server is set as default, I select an alternative ESX server from the presented lit and also select the folder.

The Display name is changed to include _new as the name already exists, Resource Pool is set to Resources

I select the appropraite datastore from the presented list, this s a VMFS filestsem with available space

Only the Original provisioning option is set in the Virtual Machine Option page

Storage Destination shows the datastore Ok

None of the LAN's are selected to connect after recovery

When I run the Pre-Recovery Check I get the following error: SAN datastore compatibility: -Failed

I have tried searching Connect and the web for any information regarding this error but so have drawn a blank, has anyone else seen something similar?

 

Kev

 

Comments 9 CommentsJump to latest comment

CrabbyShane's picture

Hey Kev,

Can you look on your NBU master server and check the restore logs?

They can be found at (install_path)\NetBackup\logs\bprd

I'd also recommed something that I always keep a copy of is the NBU troubleshooting guide: http://www.symantec.com/business/support/index?page=content&id=DOC5180

It has occasionally been somewhat helpful.

Good luck.

-CS

 

RLeon's picture

According to the Netbackup VMware admin guide, there are certain limitations when trying to specify a specific ESX host for restore, instead of pointing everything to the vCenter.
See if any of the following points apply to your case:

- To restore directly to an ESX server, the name that is specified for the restore must match the ESX server's official host name. The name must be in the same format in which it is registered in DNS and in the VMware server (whether short or fully-qualified).

- The restore fails if ESX servers are configured with short host names and the backup and restore are done through a vCenter server.

- VMware does not support the restore of virtual machines directly to an ESX 5.x server that vCenter manages. To restore the virtual machine, select the vCenter server as the destination. As an alternative, you can set up an independent ESX server to be used for restores. You must add NetBackup restore credentials for that ESX server by means of the "VMware restore ESX server" server type.

Kevin Lamb's picture

Thanks CS,

Just ahd a look through the troubleshooting documentation but nothing jumps out, I have attached the restore log file from the master but am struggling to interperet it to be honest.

This is the first time I have ran into issues with restoring a VM client.

Kev

AttachmentSize
log.011713.txt 150.89 KB

Kevin Lamb's picture

Hi Mick,

I dont have any problems selecting the datastores and they all show up in the restore GUI, it is only when I run the Pre-assessment I then get the compatibility error, my VM admin is currently looking at this as they are wondering if it is a configuration issue on their side.

Kev

captain jack sparrow's picture

Hi Kevin DO you have No.Restrictions touch file available db/altnames on master to allow alternate restore?

i believe UUID might cause conflicts being under same vCenter control. Can you try to change it and restore with new Display name

 Cheers !!!

CJS

 

Kevin Lamb's picture

Been playing around with the restore options along with my VM engineer and we have found that once we remove the SAN transport option from the restore list this now works, my original thought was that the 4 selected transport otions were used in sequence i.e. if one fails then try the other, this is obvioulsy not the way it works.

 

 

SOLUTION
RickardNell's picture

Hi Kevin,

 

This is not really a solution, what if you want only to restore over SAN for faster restores? Im currently expereincing this but the restore still completes but not at very great transfer rates. Has anyone else experience this?

daniel.hooper's picture

Yes and this is also a nightmare for environments with firewalls.

 

If anyone else has this issue then I recommend the following as it worked for me:

 

Run the restore from the recovery host that will be doing the restore.

I still get the Pre-Recovery Check error "SAN datastore compatibility: -Failed" but it still restores and powers up fine.

 

Remember if this works then thumbs up the comment.