Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

VMware Backup doesn't back up, stays in Queued State

Created: 28 Sep 2010 | 2 comments

When I run a backup for a VM by connecting to an ESX host using the ESX server credentials or the vCenter server using domain credentials, the backup starts, and then stills at the Queued state.  The domain account is a domain admin.

When the backup starts, it goes from a Running state --> preprocessing --> Snapshot Processing --> Running --> Queued state (indefinately).  The IMA*** folder and B2D*** files get created in the process, and there is network traffic, but the folder never gets larger, and the backup stays in queued state (tested for 2 hours) with this backup being the only running backup.

 

I am running Windows Server 2003 SP1, and just upgraded from BE12.0 to BE2010 R2.  I have installed the licenses for the server, the VMware agent, Exchange, SQL, and Windows.  The VMware environment is vSphere 4.0.

I am backing up the data over the LAN to a local Disk Backup folder.  I tested backing up the server using the RAWS installed locally on the VM, and it went off without a hitch.  Only the VM backup is giving me a problem.

I've messed with all kinds of options for using GRT and not using GRT, changing the available transport modes, etc.  The same result happens every time.

When I try to cancel the backup, it never cancels.  I have to kill the beremote.exe process, and then restart all of the services.

Please help!

Comments 2 CommentsJump to latest comment

ZeRoC00L's picture

How big is the virtual machine you are trying to backup ??

Does the VM already have a snapshot ? I have seen a situation where the processing step also took a few hours because there was still a snapshot on the VM!

Is this issue happening with all virtual servers you are trying to backup ?

If this response answers your concern, please mark it as a "solution"

SAllen's picture

The VM is 52GB, and there are no snapshots.  It is happening with all VMs I am backing up.  When working with support, We tried the steps indicated in this tech article that's hidden from search =P, which exactly identifies my problem.  I have not been able to reboot the server yet, because we had to run a repair from killing the processes so much.  We basically copied the contents of the VMware directories to the root of the BExec program files folder, because apparently there is a dll that gets used in the wrong order on the system.  Will update when I test this article.