Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

VMware Backup - ESX or vCenter

Created: 23 Aug 2012 • Updated: 24 Aug 2012 | 10 comments
schulti's picture
This issue has been solved. See solution.

Hello,

when I configure backups for VMware VMs over the vCenter Server - where does the BE-Server connect to? To the vCenter Server oder directly to the ESX(i)-Server on which the VM is running?

Thanks for help!

 

Comments 10 CommentsJump to latest comment

CraigV's picture

Hi,

 

You set up your selection list by connecting to the vCenter server. From there it contacts ESX to do the backups of the VMs in question.

Don't connect directly to the hosts.

Thanks!

 

EDIT: Best practices: http://www.symantec.com/business/support/index?page=content&id=HOWTO21769

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

schulti's picture

Yes, that's clear - I DO configure the backup selections by connecting to the vCenter server.

But where does the BE-Server connect to for the backup itself? Does it connect to vCenter Server and copies the vm from the ESX-Server over the vCenter server to the backup server or does it connect directly to the ESX-Server where the VM is hosted in that moment?

My problem:
When my vCenter server is virtualized i think for backup speed it would be better to connect directly to the ESX-Server instead of to the vCenter server. Am i wrong?

 

samueljn's picture

Before getting into the Backup speed, let me explain you the process:

This is the Backup process:

  1. Backup Exec backup job starts
  2. Backup Exec tells VMware to create a snapshot of VMDK through vCenter
  3. vCenter creates and mounts the snapshot to the datacenter and it now becomes the "active" snapshot (virtual machine is now running from that snaphsot)
  4. Backup Exec then gets the ESX host and guest virtual machine information from vCenter it needs to access or backup
  5. Backup Exec opens a connection with the ESX to ask for the virtual machine metadata
  6. Using vStorage APIs, Backup Exec then opens a direct data connection to the “unknown” SAN volumes and the virtual machine data is offloaded directly to the media server for backup
    1. “Extracting the Backup Data from the Target Virtual Machine” 
    2. “Deleting the Temporary Snapshot” 
  7. Once the backup completes, Backup Exec disconnects from the ESX host and vCenter
  8. Backup Exec runs a verify (by default) of the data backed up
  9. Backup job completes.

The backup performance is determined by the Transport mode in which the backup takes place. If you go the Job properties and choose Vmware, there are 4 different transport modes. (SAN, NBD, HOTADD & NBDSSL). Once the job begins, If Backup exec server has accesss to the SAN, then the job runs through SAN transport. Otherwise it runs through NBD. NBD will be relatively slow when compared to SAN. However SAN transport is not possible if BE is also installed on a VM.

This article may be helpfull to get some idea about the options available for Vmware backup: http://www.symantec.com/docs/HOWTO12794

Hope this helps.

Regards,

John

SOLUTION
schulti's picture

Thanks for that!

So it is like i mentioned before: the actual backup load doesn't have anything to do with the vCenter Server but takes the way directly from the ESX Server / Storage to the Backup Exec Server.

 

samueljn's picture

Yes it is. But we have seen version mismatches cause some issues. For e.g, Vcenter: 4.1 and ESX 5.0....However, that doesn't relate to performance issues in general. If you can make sure that Backup exec server has access to the SAN, i am sure you will get better performance using SAN transport mode to backup.

JeroenL's picture

I have a strange problem using SAN Transport mode

We are running BackupExec 2012 SP1 within a VMware virtual machine.

From our HP P4000 iSCSI SAN we present a test LUN to some of our ESXi servers and to the iSCSI initiator of the Virtual BackupExec server.

The LUN is formated as VMFS and a test VM is created with a datastore on the LUN.

When I configure a backup job to backup a VM selected through vCenter the SAN Transport mode is not possible.

When I configure a backup job to backup the same VM but now selected directly through the ESXi host the SAN Transport mode is possible.

If I examine the log files it seems the LUN name is different when using vCenter so the LUN cannot be found and no SAN Transport mode can be selected.

What can cause this problem?

 

VJware's picture

By design, SAN transport mode only works if the backup exec media server is on a physical machine & not virtual...

have a look at this - http://pubs.vmware.com/vsphere-50/index.jsp?topic=...

JeroenL's picture

What is the difference between a direct SAN connection based on iSCSI to a physical server or a virtual server?

The iSCSI SAN is presented directly to the OS, bypassing the hypervisor, by using the software iSCSI initiator build into the OS.

It is working fine for VMs backupped directly from an ESXi host, but not if that same VM is backupped when selected through vCenter. To me this is due to some error and it is not related to the media server being run virtual.

VJware's picture

What sort of error are you referring to ? Not using SAN transport mode for a backup application residing on a virtual machine is a not a BE or any backup vendor limitation...This is how VMWare has designed & SAN transport mode is disabled for such a scenario..And that's where Hot-Add transport mode comes in for such backup servers...

JeroenL's picture

Please explain why a backup of a VM selected directly from an ESXi using SAN Transport runs fine and the same VM selected from vCenter failes because the disk cannot be found?

This is stange behavior.

I will now try to get Hotadd to function properly, but there seem to be Block Size limitations.