Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Vmware duplicate job fails, Invalid Physical Volume Library Media Identifier.

Created: 28 Apr 2013 | 16 comments

Hi,

My VMware duplicate jobs suddenly fails everytime. Other dublicate jobs works fine. Error message is Media mount failed. Invalid physical volume library media identifier.

I have full backup jobs taken weekly to d2d on tuesday, thurstday and sunday. Every months last sunday duplicate to tape. Duplicate job takes most recent last full backup.

I have BE2012 with newest updates.

I have tried creating jobs again but no help. I runned inventory but no help. 

What is causing the problem?

-Matti- 

Operating Systems:

Comments 16 CommentsJump to latest comment

Jaydeep S's picture

I am assuming you are performing Full and incremental jobs for the week. Are both of those going to the disk. Before duplication?

Also in the Logon Accounts tab, confirm if the Backup Exec System Logon Account is in the format of Domain\Administrator.

Is 2012 Rev 1798 Hotfix 199866 installed?

Edit: See if the steps mentioned in http://www.symantec.com/docs/TECH137444 help you.

dfi_it's picture

I'd just like to add that I have seen this same issue this weekend and seems to be a direct result of installing the latest hotfix 201596, which I added last week.

Reason for duplicate jobs reporting as failed can be seen in the job history tab of the job log, as additional entries have appeared for each of the drive letters within the Windows system.

For example, the ones in bold appear but I would not expect to see them:

Set Detail Information - Duplicate VMVCB::\\dfvminfra\Virtual Center\DFDA6 (DFDA6.dr-foster.lan)

Set Detail Information - Duplicate VMVCB::\\dfvminfra\Virtual Center\\\DFDA6.dr-foster.lan\C:

Set Detail Information - Duplicate VMVCB::\\dfvminfra\Virtual Center\\\DFDA6.dr-foster.lan\D:

Set Detail Information - Duplicate VMVCB::\\dfvminfra\Virtual Center\\\DFDA6.dr-foster.lan\E:

Set Detail Information - Duplicate VMVCB::\\dfvminfra\Virtual Center\DFDA6 (DFDA6.dr-foster.lan)

The amount of data duplicated is correct and I have verified that a test restore of the VMDK files in full works fine.

It does seem to be a bug of some description - do I need to raise a support ticket or can this be followed up from the forums?

Thanks,

Paul.

Jaydeep S's picture

Please open a support ticket and have the issue investigated.

emmegi's picture

please keep this thread updated, thanks.

i have found that this happens ONLY with grt enabled vm backups...mhm...

dfi_it's picture

Hi emmegi -

Went through some troubleshooting steps with Symantec support yesterday and came to the same conclusion that it was only the GRT enabled backups that showed this issue.

Paul.

emmegi's picture

update here.

tested backup to (ost) with grt on : ok
tested backup to (tape) with grt on : ok
tested backup to (ost) duplicate to (tape) withOUT grt on : ok
tested backup to (ost) duplicate to (tape) with grt on : error
tested backup to (tape) duplicate to (ost) with grt on : error
tested backup to (tape) duplicate to (tape) with grt on : error

this is a BIG problem! very disappointing. Applied the hotfixes (180964 and 199866), same problem.
Tell me the ONLY solution is NOT to disable grt...

NESL Netops's picture

For what it's worth, I have the exact same issue and corrected it by uninstalling Hotfix 201596.

Kunal.Mudliyar's picture

Are you guys updated to?

Backup Exec 2012 revision 1798 Service Pack 2

It fixed a lot of issues related to Vmware and Deduplication

Technical Support

Symantec

NESL Netops's picture

No. Odd, even though it came out the other day, when I ran Live Update earlier, it told me I was up to date...

pkh's picture

It will only be available via LU in a few weeks time.  See this blog

https://www-secure.symantec.com/connect/blogs/backup-exec-servive-packs-generally-available

In the meantime, you would have to download it manually.

Kunal.Mudliyar's picture

Its not in Liveupdate still...its a manual download and install...

Technical Support

Symantec

JBSmith's picture

We've had a case open for this exact issue as well. (Case number 03976835). This problem occurred when we installed hotfix 201596, and we reliably worked around the issue by uninstalling that hotfix.

We have now upgraded to BE 2012 SP2 and the exact problem has reappeared. This was expected as the support technician could give no indication that the problem was identified and resolved in SP2.

In our case, we are doing full GRT VMware backups to tape, and then duplicating those fulls to tape. I recently came across this KB article, which seems to imply that there is a problem duplicating VMware backups to the same media type used in the initial backup:

"Backup Exec does not support the mixing of Backup-to-Disk and Backup-to-Tape between Full and Differential backups with Granular Recovery Technology (GRT) enabled.

Therefore, the methods supported for this setup are:
AVVI-Full = Backup-to-Disk > AVVI-Differential = Backup-to-Disk > Duplicate Differential to Tape
AVVI-Full = Backup-to-Tape > AVVI-Differential = Backup-to-Tape > Duplicate Differential to Disk"

http://www.symantec.com/business/support/index?pag...

In our case, however, there are no differentials in the mix, so I'm unclear on how this applies to our situation.

This has been frustrating; after installing SP2, we may have to run another full backup to the second tape library as a workaround until we can finally get this issue resolved.

Jaydeep S's picture

It certainly is frustrating to backup the same data twice. Have you tested the method where you backup to a disk first and then duplicate to the tape (Even though you don't have differential)

NESL Netops's picture

Does anyone know if this issue has been addressed yet? I would like to move to SP2 since it offers support for more recent technologies, but I don't want to put myself into a position with no opportunity for a backout plan if my virtual backups stop working again.