Video Screencast Help

Vmware restore through SAN issue

Created: 05 Jan 2013 | 4 comments


I need help on this issue.

I configured vmware backup through SAN, as below url

Master server (windows 2008) Netbackup version

Media server  (windows 2008) Netbackup version

Virtual machine (windows 2008)

Configured media server as vmware backup host,

Media server, ESX server and datastore are connected with SAN,

Media server and master server are connected with LAN.

ESX server, master server and media server are connected with  LAN

I configured policy with flash backup windows type with snapshot option with VMware backup host  (media server), in the snapshot option, I selected transfer type as Try SAN and NBD

Then I restarted test backup, backup was completed successfully with 35 MB/ sec, in backup job details, it is showing as Transport type as LAN.

While, I try to do test restore a file on virtual machine from media server (vmware backup host) , restore type as Normal restore,

It is failing with below error.

04-Jan-13 19:53 - begin Restore

04-Jan-13 19:54 - media AFO091 required

04-Jan-13 19:54 - restoring image TEST01_1357337768

04-Jan-13 19:55 - requesting resource AFO091

04-Jan-13 19:55 - granted resource AFO091

04-Jan-13 19:55 - granted resource HP.ULTRIUM3-SCSI.003

04-Jan-13 20:00 - Info bptm(pid=4140) start           

04-Jan-13 20:00 - started process bptm (4140)

04-Jan-13 20:00 - Info bpdm(pid=4140) reading backup image         

04-Jan-13 20:00 - Info bptm(pid=4140) using 128 data buffers        

04-Jan-13 20:00 - Info bptm(pid=4140) spawning a child process        

04-Jan-13 20:00 - Info bptm(pid=4140) child pid: 7352         

04-Jan-13 20:00 - Info bptm(pid=7352) start           

04-Jan-13 20:00 - started process bptm (7352)

04-Jan-13 20:00 - Info bptm(pid=4140) Waiting for mount of media id AFO091 (copy 1) on server media1stgo.

04-Jan-13 20:00 - started process bptm (4140)

04-Jan-13 20:00 - mounting AFO091

04-Jan-13 20:00 - Info bptm(pid=4140) INF - Waiting for mount of media id AFO091 on server media1stgo for reading.

04-Jan-13 20:01 - mounted; mount time: 00:00:39

04-Jan-13 20:01 - Info bptm(pid=4140) AFO091           

04-Jan-13 20:01 - Info bptm(pid=4140) INF - Waiting for positioning of media id AFO091 on server media1stgo for reading.

04-Jan-13 20:01 - positioning AFO091 to file 36

04-Jan-13 20:02 - positioned AFO091; position time: 00:01:00

04-Jan-13 20:02 - begin reading

04-Jan-13 20:02 - Info bptm(pid=4140) waited for empty buffer 9 times, delayed 24 times   

04-Jan-13 20:02 - end reading; read time: 00:00:02

04-Jan-13 20:02 - Info bptm(pid=4140) completed reading backup image        

04-Jan-13 20:03 - Error bpbrm(pid=5200) Cannot connect to TEST01        

04-Jan-13 20:03 - Info tar32(pid=0) done. status: 58: can't connect to client     

04-Jan-13 20:03 - Error bpbrm(pid=5200) client restore EXIT STATUS 58: can't connect to client 

Anyone help on this restore issue.

Comments 4 CommentsJump to latest comment

Bmitche's picture

I ran inti this same exact problem 6-8 months ago and never got it resolved.I was able to prove that even though the backup said it was using was really using SAN. I was backing up to MSDP on a particular media server and watched the network i/o and the ft i/o. It was definetly using FT as the network i/o was nearly nothing and ft was really high i/o.

As far as restore through SAN...I kept getting the same error trying to restore. It didn't like something about the SAN transport mode. I switched the restore to nbd and it worked fine. Again I reported this as an issue with no resolution.

I do all of my VM backups using hotadd now....the speed is good and I don't have to mess with all of the zoning issues with SAN transport.

Sorry I don't have an exact answer for you, but maybe you can use this as a work around.

Marianne's picture

Cannot connect to TEST01    

Is TEST01 the VM? 
Did you select the VM as destination client?

If you want to restore files back to the VM, you need to install NBU client on the VM and ensure name lookup and port connectivy as with a normal client.

Most people restore files to a folder on the Windows backup host, and then copy restored files to the VM.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

NBU_13's picture


Thanks marianne,

Now i can able to restore individual files and full virtual machine with very good speed around 67 to 99 MB/sec, but only think, the transport type is showing as LAN, not SAN.

I sure, the speed is look like SAN, but I dont now, why its showing as LAN in job detail´s transport type.

Mark_Solutions's picture

If you are restoring individual files they will always go via the LAN

A gigabit network can do up to 120 MB/s at full speed (though rarely goes above 100)

Individual file restores cannot be passed via the fibre as they connect directly to the NBU client and pass the data in the traditional way over the LAN

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.