Video Screencast Help

VmWare snapshot Backup failing

Created: 03 Jan 2013 • Updated: 06 Feb 2013 | 10 comments
This issue has been solved. See solution.


I am Running Backup Exex 2010 R3 on a windows 2003 server.

I have over 10 VmWare servers which needs to be taken backup of. A job is already set, but it was failing big time. To troubleshoot, i created another job with only 1 VmWare server in it. It failed there as well with dosens of errors. Here are the errors it comes up with:

In Vmware it start creating the snapshot but then fails after around 3 minutes, with following error:

A general system error occurred: Protocol error from VMX.

In Backup Exec 2010 R3 if show the following errors:

Job ended: 3. januar 2013 at 16:23:42
Completed status: Failed
Final error: 0xe0009574 - Unable to create a snapshot of the virtual machine. The virtual machine may be too busy to quiesce to take the snapshot.
Final error category: Resource Errors

For additional information regarding this error refer to link V-79-57344-38260

V-79-57344-33899 - The resource could not be backed up because an error occurred while connecting to the Backup Exec for Windows Servers Remote Agent.

Make sure that the correct version of the Remote Agent is installed and running on the target computer. If the server or resource no longer exists, remove it from the selection list. Edit the selection list properties, click the View Selection Details tab, and then remove the resource.

Then this error:

V-79-57344-34009 - An error was encountered creating on-disk catalog. If this is an incremental backup, cataloging of the generated media may not work correctly.

Comments 10 CommentsJump to latest comment

Gurvinder Rait's picture

Have you seen this article and has these steps been done

pkh's picture

What version of ESX are you using?  If it is ESX 5.1, it is not supported at the moment.

Also, are you using a licenced version of ESX?  BE uses the vStorage API which only comes with a paid version of ESX.  Even, if you have a paid version, check that it has not reverted to an unlicenced version.  This has happened recently to another user.

RicohNorway's picture

Hi. I have ESX 4.1 and they are payed verion, and even licenses are in place.

I followed the article given by Gurvinder, and here is what i did. I figured that i needed the correct Snapshot provider. Which snapshot provide one needs is based on that table in the article. Mine had the VmWare snapshot installed. So i uninstalled it, and installed the RAWS on vmware virtual server which needed to be taken backup of. It also installed the Backup Exec Snapshot provider. I ran the job again and it did complete the job this time, however with exceptions. Here is the message i get upon completion of the job:

V-79-57344-38727 - Backup Exec failed to snap virtual machine '*************` and was unable to collect the necessary metadata to restore individual application items. You cannot perform GRT-enabled restores of application data from this backup.

Remember that i removed the server name and inserted ****** instead.

What should i do?

RicohNorway's picture

Let me read a little bit about GRT wheter it should be enabled or not for VmWare server i am taking backup of. Only thing i know is that it has been enabled for my server, regardless of knowing propar what it is and wheter it should be enabled or not.

RicohNorway's picture

Can you explain when GRT should be enabled and/or what it is? I know briefly that it allows restore on file level. Correct me if i am wrong.

Gurvinder Rait's picture

2 kinds of GRT for VM

File Folder GRT -

- Does not require remote agent on the VM (but would require it for restore)

- You backup the VM using AVVI and in restore you can restore VM (vmdk) and you also get another view for restoring file/folders

Application GRT -

- Requires remote agent on the VM

- Backup the VM which has application like AD, Exchange/, SQL and you can view/restore the GRT for these applications also. 

You can have both selected in the job

RicohNorway's picture

I think i have both of them enabled without knowing wheter i need it or not. So if one of the servers which i wnat to take backup of has either of the following applications, Exchange, AD, SQL etc, i am unable to backup it without enabling Application GRT? I have different servers with different setup. The one i am using for test is a simple Windows 2003 Server which has a software installed for generating reports, Called Cognos. I think it uses an external server for the SQL part. I believe for a server like this, i should only have enabled the File Folder GRT. Dont think i need Application GRT.

And by the way, it says to enable restore of Application items, i need to have Application GRT enabled. But what does it mean by application items? Should it not be enough by having File GRT enabled only?

Gurvinder Rait's picture

If you backup an SQL VM you would be able to get a GRT view if the SQL Databases in the restore (just like you do for a raws backup) or if you backup exchange VM you can view the exchange database and drill down the individual exchange items and restore them as well.

RicohNorway's picture

So my understanding is, that reason why this error was appearing was that most probably the server i am backing up, does not have SQL or Exchange on it.