Video Screencast Help

Vmware snapshot backup jobs are failing with Error code 6

Created: 09 Apr 2013 • Updated: 19 Apr 2013 | 13 comments
This issue has been solved. See solution.

Hi,

Netbackup Master/Media server version 7.5.0.4

OS : windows server 2008 R2, 64-bit

I newly configured snapshot backup for vmware, it was completed successfully for 2 days, after that, it is failing continuesly with error code 6,

So, I deleted policy and again reconfigured new sanapshot backup for vmware machines, but still it is failing with same error 6

ERR-error opening the snapshot disks using given transport mode:status:23.

anyone guide me to fix this issue.

-Thank you

Operating Systems:

Comments 13 CommentsJump to latest comment

Will Restore's picture

review this older technote for possible solution:

Article URL http://www.symantec.com/docs/TECH136311
vStorage backups are failing regardless of transport method selected in policy. Attempting the backups either through vCenter or ESX result in the same errors.  This occurs due to an outstanding VMware lock file left over on the backup host.

Will Restore -- where there is a Will there is a way

Will Restore's picture

another possibility, from recent thread

https://www-secure.symantec.com/connect/forums/error-opening-snapshot-disks-using-given-transport-mode-status-23-backup-failed-back-requeste#comment-7141131

"Already solved by adding entries of my ESXi hosts into the "hosts config file" of my Master Server. It seems that NBU used hostname resolution instead of the actual IP address in accessing the ESXi servers."

Will Restore -- where there is a Will there is a way

SOLUTION
Dolly's picture

Hi, the error said it all. When netbackup for vmware take a successful snapshot, after backup the snapshot is deleted. but here, it seems there are still some stale snapshot which were not properly deleted. log on phycally to your vcenter and manually delete the snapshots from the datastore. you can also check under task & event on the vcenter for what is happening. thanks.

NBU_13's picture

Hi,

Thank you all for guide, let me try it.

Dolapo,

Iam not good in Vmware, can you please guide me, how to delete snapshot file from vcenter ?

-Raja

Dolly's picture

Select virtual machine, right click on it and select snapshot, select snapshot manager. click on the snapshot you want to delete and click delete.  Again, check all possible alerts from task and events to see what must have caused the issue.

NBU_13's picture

Hi ALL,

I tried as above all, but no luck, still backup jobs are failing with same error, but onething

I can able to ping vcenter from Netbackup master server, but not able to ping exsi server.

Dolly's picture

This might also help : http://www.symantec.com/business/support/index?page=content&id=TECH136311

For transport mode settings, use this: http://www.symantec.com/business/support/index?page=content&id=HOWTO23029. You can set all by choosing priority.

If you are using vcenter to communicate with netbackup, i guess you dont have any business with the esx. But if not using vcenter, you must make sure the backup host is able to communicate with ESX hosts.

Also check solutions to the error you are getting on page 162 of NETBACKUP FOR VMWARE ADMIN GUIDE 7.5. Thanks.

Dan@NB's picture

Remove the VM client from configured policy and configure Display name for the VM and try a test backup. If still fails, try with IP address. That should give you a clue on where the issue is.

+ Dan

vjuhola's picture

1. Install VMware tools to every virtual client, and set Primary VM identifier to VM DNS name in the backup policy. This will only select clients that have VMware tools installed (= less failing clients). More on this http://www.symantec.com/business/support/index?page=content&id=HOWTO71001

2. I reckon you are backing up over SAN. Make sure that every LUN shown to ESX is also shown to the media server, ask from your storage administrator whether there was recently added more disk. You can also do some investigating by setting up VxMS logging on the media server. If there are messages like "cannot access LUN" in the log entries, then it is a LUN mapping issue. How to set up VxMS logging http://www.symantec.com/business/support/index?page=content&id=TECH72862

Master server doesn't need to be able to ping ESX hosts, master server is only there for the credentials. Media server on the other hand needs to be able to ping ESX hosts if you are backing up over LAN (f.e. NBD transport type).

Please provide details which transport type you are using and set up VxMS logging.

-v

NBU_13's picture

Hi,

I created new policy with VM display name, with ip address and entry about vcenter, ESXI and virtual machine name in master server´s host file, but still backup jobs are failing with same error :

ERR-error opening the snapshot disks using given transport mode:status:23.

NBU_13's picture

Hi,

Thanks to all,

issue fixed,

There is some wrong entry in master server´s host file,

I deleted and re-enter vcenter, Esxi server and virtual machine ip address and fqdn and short name , then its fine and backup josb are running and completing.