Video Screencast Help

vmware snapshot failed

Created: 29 Jan 2013 • Updated: 30 Jan 2013 | 7 comments
This issue has been solved. See solution.

Hello,

I'm trying to backup several VMs and all the attemtps finish by the same general error 156. 

Looking to the 2 attached log files does not help me to locate the problem

Please, look at the log files and if you have any idea, let me know ...

Thanks

Lumir

 

-------------

NBU: 7.5.0.4

ESX: ESXi 5.0.0

VMware Tools: installed

VM VMware snapshot: success

VM: w2k8.test.local (Windows2008R2), without NBU client installation

Transport method: NBD

STU: local disk

VM events: no events in VM and ESX log

----------------------

Comments 7 CommentsJump to latest comment

Douglas_A's picture

I actually ran into this recently at a customer, the issue is with the Permissions of the vmware account you are accessing vsphere with.

 

Please ensure you have DataCenter down permissions as documented in this article.

 

http://www.symantec.com/docs/TECH130493

 

I find it much much easier to just create a user and add it to the Administrator group.

Best of Luck,

Doug

 

 

Please remember to mark the most valuable answer to your issue as the solution.

lumir.unzeitig@ts.fujitsu.com's picture

Thanks Doug.

I use built-in account "root" with "Administrator" role for connection NBU to ESX server and he has got all the permissions. I re-apply permissions to whole Inventory tree - no change.

 

Lumir

Nagalla's picture

hi,

does it ever woked , or its a new configureation?

are you able to Browse and select Virtual machiens in the policy?

did you make sure that you have entered valid  Vcenter or ESX username and passwd in Netbackup?

 

 

lumir.unzeitig@ts.fujitsu.com's picture

Thanks Nagalla.

It is new installation vmware backup has never worked here.

Yes, I'm able to browse and select VM. I tested manually and by query too.

I hope my username and password are correct, my credentials were accepted by creating "Virtual Machine Servers" in NBU Credentials. I use the same u,p for vSphere Client to ESXi connection.

 

Lumir

 

sazz.'s picture

Are you able to create manual snapshot? Does it work? If it doesn't there is no way NBU will.

Your logs are showing exactly same error message as per this TN

http://www.symantec.com/docs/TECH150487

Your log errors:

15:14:18.668 [3320.3476] <2> onlfi_vfms_logf: INF - VMware_freeze: FTL - VMware snapshot failed: SYM_VMC_SOAP_ERROR

15:14:18.668 [3320.3476] <32> onlfi_freeze: FTL - VfMS error 11; see following messages:
15:14:18.668 [3320.3476] <32> onlfi_freeze: FTL - Fatal method error was reported
15:14:18.668 [3320.3476] <32> onlfi_freeze: FTL - vfm_freeze: method: VMware_v2, type: FIM, function: VMware_v2_freeze
15:14:18.668 [3320.3476] <32> onlfi_freeze: FTL - VfMS method error 7; see following message:
15:14:18.668 [3320.3476] <32> onlfi_freeze: FTL - VMware_freeze: VIXAPI freeze failed with 6

I agree with Douglas, please check your permission again and try the manual snapshot.

Yasuhisa Ishikawa's picture

Error code 6 in VIX API represents VIX_E_NOT_SUPPORTED(The operation is not supported).

fault.RestrictedVersion.summary is also logged in bpfis log.

15:12:14.793 [3320.3476] <2> onlfi_vfms_logf: INF - vmwareLogger: SOAP 1.1 fault: "":ServerFaultCode [no subcode]
"fault.RestrictedVersion.summary"

Which edition of vSphere are you using? Does it really support VADP?

Authorized Symantec Consultant(ASC) Data Protection in Tokyo, Japan

SOLUTION
lumir.unzeitig@ts.fujitsu.com's picture

Yasuhisa, thanks.

The cause of the problem was expired evaluated license. It works great after upgrade.

 

Thanks for your help.

 

Lumir