Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

VRTRalus daemon stopping on Linux machine/backup fails

Created: 11 Mar 2010 | 10 comments

We seem to be having a problem with the "VRTRalus daemon" on one of our linux servers that is trying to get backed up by our BackupExec 12.5 Windows 2008 server.

It looks like the daeomon actually stops running either before the backup starts or when it tries to access it.

All of our other Linux servers work fine but for some reason we are getting the following message in the daily backup job when it tries to connect to this server. (The other Linux servers are basically identical to this one)

V-79-57344-3844 - The media server was unable to connect to the Remote Agent on machine hudson64.kc.local. The media server will use the local agent to try to complete the operation. Access is denied to Remote Agent. Check the login account for the specified device.

I have tested doing a backup of some files as a test backup job and it works fine. But for some reason when its part of the "daily incremental" or "full backup" jobs in the evenings it "fails".

I've tried debugging the problem by outputing the error to a log file but can't really notice anything that's causing it to stop.

Any help or tips would be appreciated.

Thanks,

Daniel

Discussion Filed Under:

Comments 10 CommentsJump to latest comment

SystemsAdminAS's picture

Daniel,

What Linux distro are you running?  Is it a supported distro for 12.5?  I'm trying to get a similar setup going on Ubuntu 9.10 - the agent installes fine (and in my case does not seem to hang or stop), but I can't get the BE server to authenticate the agent so I can browse the shares in a selection list - Be simply won't connect with root account creds.  I'm current on patches for 12.5, but have not installed updates for the agent yet (which may be part of the issue) - I wonder if there was some hotfix on the BE side that requires a patch on the Ralus agent side for proper communication.  PRevious hotfixes on the server end have broken linkages between Windows and DLO agents for me before until the agents were updated...

dfisicaro's picture

We are running Centos 5.3 on all of our servers. Which is basically Redhat Enterprise 5.

It works fine on all of the others servers.

I'll check if its in the supported though.

dfisicaro's picture

 
V-79-57344-65072 - The connection to target system has been lost. Backup set canceled.

This is the error that appears.

It seems to actually start backing up fine and then suddenly crashes at some stage.

dfisicaro's picture

I've run this command:

/opt/VRTSralus/bin/beremote --log-file-auto


Then started the backup job and get this messaged when the backup fails with the above error:

*** glibc detected *** /opt/VRTSralus/bin/beremote: double free or corruption (!prev): 0x00000000038bc900 **                                 *
======= Backtrace: =========
/lib64/libc.so.6[0x33d08722ef]
/lib64/libc.so.6(cfree+0x4b)[0x33d087273b]
/opt/VRTSralus/bin/libndmp_tpfmt.so[0x2abebcc21a42]
/opt/VRTSralus/bin/libndmp_tpfmt.so(_Z7BM_FreeP8BUF_LISTP3BUF+0x27)[0x2abebcc21b37]
/opt/VRTSralus/bin/libndmp_tpfmt.so(_Z10BM_FreeAllP8BUF_LIST+0x31)[0x2abebcc21981]
/opt/VRTSralus/bin/libndmp_tpfmt.so(_Z18TF_FreeTapeBuffersP8BUF_LIST+0x14)[0x2abebcc312c4]
/opt/VRTSralus/bin/libndmp_tpfmt.so(_Z19TF_FreeDriveContextPv+0x5b)[0x2abebcc31a6b]
/opt/VRTSralus/bin/libndmp_tpfmt.so(_Z12TF_CloseTapePv+0x3a)[0x2abebcc314ca]
/opt/VRTSralus/bin/libndmp_loops.so(_Z11LP_DoBackupP17NdmpdModuleParams+0x337)[0x2abebcd8ca97]
/opt/VRTSralus/bin/beremote[0x4220cd]
/opt/VRTSralus/bin/beremote[0x414514]
/opt/VRTSralus/bin/libndmpcomm.so[0x2abebcee28d1]
/opt/VRTSralus/bin/libndmpcomm.so(_Z19ndmpProcessRequestsPv+0x23)[0x2abebcee1af3]
/opt/VRTSralus/bin/beremote[0x410a83]
/opt/VRTSralus/bin/beremote(_Z11ndmpdSelectP12NdmpdSessioniij+0x2dc)[0x42902c]
/opt/VRTSralus/bin/beremote[0x410a0a]
/opt/VRTSralus/bin/libvxACEI.so.3(_ZN18ACE_Thread_Adapter8invoke_iEv+0x50)[0x2abeba25aee0]
/opt/VRTSralus/bin/libvxACEI.so.3(_ZN18ACE_Thread_Adapter6invokeEv+0x5a)[0x2abeba25ae4a]
/opt/VRTSralus/bin/libvxACEI.so.3(ace_thread_adapter+0x9)[0x2abeba222e69]
/lib64/libpthread.so.0[0x33d1006617]
/lib64/libc.so.6(clone+0x6d)[0x33d08d3c2d]
======= Memory map: ========
00400000-00447000 r-xp 00000000 08:03 2974037                            /opt/VRTSralus/bin/beremote
00547000-0054c000 rw-p 00047000 08:03 2974037                            /opt/VRTSralus/bin/beremote
0054c000-0059e000 rw-p 0054c000 00:00 0
037c2000-03a2c000 rw-p 037c2000 00:00 0                                  [heap]
40e90000-40e91000 ---p 40e90000 00:00 0
40e91000-41891000 rw-p 40e91000 00:00 0
41891000-41892000 ---p 41891000 00:00 0
41892000-42292000 rw-p 41892000 00:00 0
42292000-42293000 ---p 42292000 00:00 0
42293000-42c93000 rw-p 42293000 00:00 0
42c93000-42c94000 ---p 42c93000 00:00 0
42c94000-43694000 rw-p 42c94000 00:00 0
43694000-43695000 ---p 43694000 00:00 0
43695000-44095000 rw-p 43695000 00:00 0
44095000-44096000 ---p 44095000 00:00 0
44096000-44a96000 rw-p 44096000 00:00 0
33d0400000-33d041c000 r-xp 00000000 08:03 6338392                        /lib64/ld-2.5.so
33d061b000-33d061c000 r--p 0001b000 08:03 6338392                        /lib64/ld-2.5.so
33d061c000-33d061d000 rw-p 0001c000 08:03 6338392                        /lib64/ld-2.5.so
33d0800000-33d094d000 r-xp 00000000 08:03 6338393                        /lib64/libc-2.5.so
33d094d000-33d0b4d000 ---p 0014d000 08:03 6338393                        /lib64/libc-2.5.so
33d0b4d000-33d0b51000 r--p 0014d000 08:03 6338393                        /lib64/libc-2.5.so
33d0b51000-33d0b52000 rw-p 00151000 08:03 6338393                        /lib64/libc-2.5.so
33d0b52000-33d0b57000 rw-p 33d0b52000 00:00 0
33d0c00000-33d0c02000 r-xp 00000000 08:03 6338394                        /lib64/libdl-2.5.so
33d0c02000-33d0e02000 ---p 00002000 08:03 6338394                        /lib64/libdl-2.5.so
33d0e02000-33d0e03000 r--p 00002000 08:03 6338394                        /lib64/libdl-2.5.so
33d0e03000-33d0e04000 rw-p 00003000 08:03 6338394                        /lib64/libdl-2.5.so
33d1000000-33d1016000 r-xp 00000000 08:03 6338582                        /lib64/libpthread-2.5.so
33d1016000-33d1215000 ---p 00016000 08:03 6338582                        /lib64/libpthread-2.5.so
33d1215000-33d1216000 r--p 00015000 08:03 6338582                        /lib64/libpthread-2.5.so
33d1216000-33d1217000 rw-p 00016000 08:03 6338582                        /lib64/libpthread-2.5.so
33d1217000-33d121b000 rw-p 33d1217000 00:00 0
33d1400000-33d1482000 r-xp 00000000 08:03 6338599                        /lib64/libm-2.5.so
33d1482000-33d1681000 ---p 00082000 08:03 6338599                        /lib64/libm-2.5.so
33d1681000-33d1682000 r--p 00081000 08:03 6338599                        /lib64/libm-2.5.so
33d1682000-33d1683000 rw-p 00082000 08:03 6338599                        /lib64/libm-2.5.so
33d2000Aborted

Any suggestions?

SystemsAdminAS's picture

Dan,

Could it be a physical issue (networking, power-management, etc) or are you pretty sure it's software side?  Can you still connect to the Linux server and browse the folder list (I'm assuming yes as you were able to create the backup in the first place).  Are you backing up directly to tape or to a B2D setup?  If not the latter, try that out - I'm thinking some of your settings in your backup policy in the advanced tab may need looking at - I haven't gotten as far as you yet, but with Linux it's more important to make sure the 'follow mount point' and 'symbolic link' settings be correct as well...

Links that may help brainstorming:

https://www-secure.symantec.com/connect/forums/agent-stops-during-backups-sun-solaris-ralus

https://www-secure.symantec.com/connect/forums/ralus-stops-and-unloads-spontaneously-novell-oes2-suse-10

https://www-secure.symantec.com/connect/forums/backup-exec-linux-agent-version-12-ralus-connection-lost-during-backup

SystemsAdminAS's picture

Have you tried updating the RALUS agent at all to match your BE updates for 12.5?  I have done this on my Ubuntu box, though it has not helped me yet:

http://www.symantec.com/business/support/knowledge_base_results.jsp?content=all&SearchTerm=ralus+agent+updates

dfisicaro's picture

Thanks for your replys. I'll have a read of the links you sent.


The Ralus agent stops/crashes at a similar stage in the backup job.
I can browse all the files fine when I restart the agent though and run the job again. Could it be related to it trying to backup a specific folder on the Linux server?

We are backing up directly to Tape.


I've tried turning off "Verify" when running a test job on that box but can try switching off other options.

The thing is all of our other Linux servers are running pretty much the same Linux distribution and Ralus agent and not having a problem. Just this one which is weird.

dfisicaro's picture

Ok.

It looks I have had success on that linux box overnight.

What I did was install the following RALUS update:

http://seer.entsupport.symantec.com/docs/328485.htm

And then tested the backup and let it run last night and the agent hasn't crashed.

Will see how it goes.

Thanks for your help.

Daniel

victvishwa's picture

I running into the same issue.

Backup Exec 2010 - Runs on Windows Server 2008
Client - Ubuntu 9.10 32 bit

Issue: Tried to update the patch..It throws an Errror stating RALUS rpm not installed, but the agent is installed.

root@master-desktop:/usr/local/src# cat /var/VRTSralus/ralus.ver
ralus=2896.9
mdm=MDM_v0.0.4284.1
vxms=VxMS_v4.4-035
root@master-desktop:/usr/local/src#

Patch file : ralus2213HF328485-Linux.tar_345943.gz

Error:

./installraluspatch.sh
************************************************************************
*        SYMANTEC BACKUP EXEC FOR WINDOWS RALUS4.4 PATCH PROGRAM       *
************************************************************************
* Copyright (c) 2008 Symantec Corporation. All rights reserved         *
*                                                                      *
* Symantec, the Symantec Logo and all other Symantec product names     *
* and slogans are trademarks or registered trademarks of Symantec      *
* Corporation.  Symantec and the Symantec Logo Reg. U.S. Pat. &        *
* Tm. Off. Other product names and/or slogans mentioned herein may be  *
* trademarks or registered trademarks of their respective companies.   *
*                                                                      *
************************************************************************
./installraluspatch.sh: 59: rpm: not found
RALUS is not installed on this system...exiting
root@master-desktop:/usr/local/src#

Thanks
Victvishwa

victvishwa's picture

Issue: Unable to install the ralus patch for Ubuntu 9.10

Error: Posted above ,