Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

VRTSralus will not start after Debian Update from Etch (4.0) to Lenny (5.0)

Created: 17 Jun 2010 • Updated: 19 Jul 2010 | 6 comments
This issue has been solved. See solution.

Hi everyone.

We had the RALUS Backup Agent successfully running on a Debian Etch (4.0) machine for over a year now. It worked great. Now we performed an update for Etch to Lenny (5.0) and now the VRTSralus service won't start:

----------------------------------------------------------------------------------
/etc/init.d/VRTSralus.init start
Starting Symantec Backup Exec Remote Agent ./etc/init.d/VRTSralus.init: line 23:  5145 Segmentation fault      /opt/VRTSralus/bin/beremote > /var/VRTSralus/beremote.service.log 2> /var/VRTSralus/beremote.service.log.............................
Starting Symantec Backup Exec Remote Agent:                              [FAILED]
----------------------------------------------------------------------------------

The file /var/VRTSralus/beremote.service.log is empty. No logging...

Debugging mode says:

----------------------------------------------------------------------------------
/opt/VRTSralus/bin/beremote --log-console
b5c968c0 Wed Jun 16 17:45:11 2010 : Starting BE Remote Agent
b5c968c0 Wed Jun 16 17:45:11 2010 : Requested no generation of log file
b5c968c0 Wed Jun 16 17:45:11 2010 : No configuration file specified.  Using default.
b5c968c0 Wed Jun 16 17:45:11 2010 : Log to console: enabled
b5c968c0 Wed Jun 16 17:45:11 2010 : Successfully set the supplementary groups of the process
b5c968c0 Wed Jun 16 17:45:11 2010 : Initialized locks for SSL callbacks
b5c968c0 Wed Jun 16 17:45:11 2010 : Starting NDMP processor
b5c968c0 Wed Jun 16 17:45:11 2010 : NDMPDMainThreadFunc spawned: grpid=1, tid=-1245340784
b5c59b90 Wed Jun 16 17:45:11 2010 : FS_InitFileSys
b5c59b90 Wed Jun 16 17:45:11 2010 :   libbedsnt5.so could not be loaded: 0x       2 (2)
b5c59b90 Wed Jun 16 17:45:11 2010 :   libbedssql2.so could not be loaded: 0x       2 (2)
b5c59b90 Wed Jun 16 17:45:11 2010 :   libbedsxchg.so could not be loaded: 0x       2 (2)
b5c59b90 Wed Jun 16 17:45:11 2010 :   libbedsxese.so could not be loaded: 0x       2 (2)
b5c59b90 Wed Jun 16 17:45:11 2010 :   libbedsmbox.so could not be loaded: 0x       2 (2)
b5c59b90 Wed Jun 16 17:45:11 2010 :   libbedspush.so could not be loaded: 0x       2 (2)
b5c59b90 Wed Jun 16 17:45:11 2010 :   libbedsnote.so could not be loaded: 0x       2 (2)
b5c59b90 Wed Jun 16 17:45:11 2010 :   libbedsmdoc.so could not be loaded: 0x       2 (2)
b5c59b90 Wed Jun 16 17:45:11 2010 :   libbedssps2.so could not be loaded: 0x       2 (2)
b5c59b90 Wed Jun 16 17:45:11 2010 :   libbedssps3.so could not be loaded: 0x       2 (2)
b5c59b90 Wed Jun 16 17:45:11 2010 :   libbedsupfs.so could not be loaded: 0x       2 (2)
b5c59b90 Wed Jun 16 17:45:11 2010 :   libbedsshadow.so could not be loaded: 0x       2 (2)
b5c59b90 Wed Jun 16 17:45:11 2010 :   libbedsoffhost.so could not be loaded: 0x       2 (2)
b5c59b90 Wed Jun 16 17:45:11 2010 :   loaded libbedsvx.so
b5c59b90 Wed Jun 16 17:45:11 2010 :   loaded libbedsrman.so
b5c59b90 Wed Jun 16 17:45:11 2010 :   loaded libbedssms.so
b5c59b90 Wed Jun 16 17:45:11 2010 :   loaded libbedssmsp.so
b5c59b90 Wed Jun 16 17:45:11 2010 :   libbedsra.so could not be loaded: 0x       2 (2)
b5c59b90 Wed Jun 16 17:45:11 2010 :   libbedsdb2.so could not be loaded: 0x       2 (2)
b5c59b90 Wed Jun 16 17:45:11 2010 :   loaded libbedsedir.so
b5c59b90 Wed Jun 16 17:45:11 2010 :   libbedsvmesx.so could not be loaded: 0x       2 (2)
b5c59b90 Wed Jun 16 17:45:11 2010 : Initializing FSs
b5c59b90 Wed Jun 16 17:45:11 2010 : FS 1 failed to initialize: 0xE000FE46
b5c59b90 Wed Jun 16 17:45:11 2010 : Function called: RMAN_InitFileSys
b5c59b90 Wed Jun 16 17:45:11 2010 : Using 'UTF-8' Encoding.
b5c59b90 Wed Jun 16 17:45:11 2010 : Using vfm path /opt/VRTSralus/VRTSvxms from config.
b5c59b90 Wed Jun 16 17:45:11 2010 : Sucessfully set VFM_PRIVATE_ROOT env to /opt/VRTSralus/VRTSvxms.
b5c59b90 Wed Jun 16 17:45:11 2010 : VFM_PRIVATE_ROOT was set with value /opt/VRTSralus/VRTSvxms
Segmentation fault
----------------------------------------------------------------------------------

There seems to be a problem with VRTSvxms but I don't know where to start.

I thought to delete the following lines out of the ralus.cfg file could help:

Software\Symantec\Backup Exec For Windows\Backup Exec\Engine\RALUS\VfmPath=/opt/VRTSralus/VRTSvxms
Software\Symantec\Backup Exec For Windows\Backup Exec\Debug\VXBSAlevel=5

But that didn't work. After trying to start the service again the line

Software\Symantec\Backup Exec For Windows\Backup Exec\Engine\RALUS\VfmPath=/opt/VRTSralus/VRTSvxms

somehow is back in the ralus.cfg file...

Comments 6 CommentsJump to latest comment

pkh's picture

Have you tried uninstalling and installing the RALUS?

SOLUTION
RahulG's picture

Check for the following as well 
if there are any iptables configured
 if there is any firewall.
-checked ipv6 enable ---try disabling it  

Martinus-Apotheke's picture

Awesome. Uninstall/Install did the trick :-)   Didn't thought of that...

IPV6 was disabled anyway. BE is version 12.5

pkh's picture

Glad you solve your problem.  Do close out this discussion by marking my answer as the solution.