Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

VVR Migration on Redhat 4.4

Created: 21 Nov 2011 • Updated: 21 Nov 2011 | 3 comments
savas_irez's picture
This issue has been solved. See solution.

Hi,

I'm trying to test VVR migration on Redhat 4.4 with SF 5.0MP4RP1HF1 (Sort says this is the latest)

Primary site hostname is: rhas-1 (192.168.1.187)
Secondary site hostname is: rhas-2 (192.168.1.188)
As you can see, the systems are directly connected inside vmware server.

After stopping the applications, and unmounting the replicated volume, when i try to start the migration, it fails with the following error.

[root@rhas-1 ~]# vradmin -s -g rhtest migrate testrvg rhas-2
Message from Host rhas-2:
VxVM VVR vxrvg INFO V-5-1-5298 Unable to establish connection with remote host rhas-1, retrying.
VxVM VVR vxrvg INFO V-5-1-5298 Unable to establish connection with remote host rhas-1, retrying.
Message from Host rhas-2:
VxVM VVR vxrvg INFO V-5-1-5298 Unable to establish connection with remote host rhas-1, retrying.
Message from Host rhas-2:
VxVM VVR vxrvg INFO V-5-1-5298 Unable to establish connection with remote host rhas-1, retrying.
Message from Host rhas-2:
VxVM VVR vxrvg ERROR V-5-1-5579 Unable to establish connection with remote host rhas-1.
 

Both servers have + inside .rdg file (dg id's added as well).

[root@rhas-1 ~]# cat /etc/vx/vras/.rdg
1321632517.5.rhas-2.savas.lokal
+
[root@rhas-2 ~]# cat /etc/vx/vras/.rdg
1321632497.5.rhas-1.savas.lokal
+

[root@rhas-1 ~]# vxdg list rhtest
Group: rhtest
dgid: 1321632497.5.rhas-1.savas.lokal

[root@rhas-2 ~]# vxdg list drrhtest
Group: drrhtest
dgid: 1321632517.5.rhas-2.savas.lokal
 

Replication is running without problems.

[root@rhas-1 ~]# vradmin -g rhtest -l repstatus testrvg
Replicated Data Set: testrvg
Primary:
Host name: rhas-1
RVG name: testrvg
DG name: rhtest
RVG state: enabled for I/O
Data volumes: 1
VSets: 0
SRL name: rhtestSRL
SRL size: 1.00 G
Total secondaries: 1

Secondary:
Host name: rhas-2
RVG name: testrvg
DG name: drrhtest
Rlink from Primary: pri-to-sec
Rlink to Primary: sec-to-pri
Configured mode: asynchronous
Latency protection: off
SRL protection: autodcm
Data status: consistent, up-to-date
Replication status: replicating (connected)
Current mode: asynchronous
Logging to: SRL
Timestamp Information: behind by 0h 0m 0s
Bandwidth Limit: N/A

Am I missing something, there weren't too much requirements inside the guide???

Thanks,

Savas.

Comments 3 CommentsJump to latest comment

mikebounds's picture

Maybe host resolution as it looks as though rhas-2 can't communicate with rhas-1, but rhas-1 can communicate with rhas-2, so check rhas-2 can ping rhas-1.  If this is not issue, then post output of:

 vxprint -VPl

Mike

UK Symantec Consultant in VCS, GCO, SF, VVR, VxAT on Solaris, AIX, HP-ux, Linux & Windows

If this post has answered your question then please click on "Mark as solution" link below

SOLUTION
Gaurav Sangamnerkar's picture

Hi,

you would have define IP or hostnames during the configuration. I would as well suggest to verify the names/ip address resolution.

Under "vxprint -Pl" output, you can find parameters like "local_host", "remote_host" ... check if you are able to reach the names/ip address defined there.

Also, check if all VVR ports are able to connect from primary to sec & sec to pri .. ports can be listed by vrports command .. you can check by running a "telnet <sec> <port>" ..

hope this helps

G

PS: If you are happy with the answer provided, please mark the post as solution. You can do so by clicking link "Mark as Solution" below the answer provided.
 

savas_irez's picture

Hi, thanks for the replies, the hosts files on the systems were:

[root@rhas-1 ~]# cat /etc/hosts
127.0.0.1       localhost.localdomain   localhost  
192.168.1.187 rhas-1.savas.lokal      rhas-1
192.168.1.188 rhas-2.savas.lokal      rhas-2
 
[root@rhas-2 ~]# cat /etc/hosts
127.0.0.1       localhost.localdomain   localhost   rhas-2
192.168.1.188 rhas-2.savas.lokal      rhas-2
192.168.1.187 rhas-1.savas.lokal      rhas-1
 
I removed rhas-2 from the localhost line for rhas-2.
 
The migration command gave the following error:
[root@rhas-1 ~]# vradmin -s -g rhtest migrate testrvg rhas-2
Message from Primary:
VxVM VVR vradmin WARNING V-5-4-2402 Primary RLINK pri-to-sec not in CONNECT state.
 
When i checked the status:
 
[root@rhas-1 ~]# vradmin -g rhtest -l repstatus testrvg
Replicated Data Set: testrvg
Primary:
  Host name:                  rhas-2
  RVG name:                   testrvg
  DG name:                    drrhtest
  RVG state:                  enabled for I/O
  Data volumes:               1
  VSets:                      0
  SRL name:                   rhtestSRL
  SRL size:                   1.00 G
  Total secondaries:          1
 
Secondary:
  Host name:                  rhas-1
  RVG name:                   testrvg
  DG name:                    rhtest
  Rlink from Primary:         sec-to-pri
  Rlink to Primary:           pri-to-sec
  Configured mode:            asynchronous
  Latency protection:         off
  SRL protection:             autodcm
  Data status:                consistent, up-to-date
  Replication status:         paused due to network disconnection
  Current mode:               asynchronous
  Logging to:                 SRL
  Timestamp Information:      behind by 0h 0m 0s
  Bandwidth Limit:            N/A
 
 
When i checked the vxprint outputs, i saw that, (because of the localhost line for rhas-2), rhas-2 ip address was incorrectly set as 127.0.0.1.
 
[root@rhas-1 ~]# vxprint -lPV
Disk group: rhtest
 
Rlink:    pri-to-sec
info:     timeout=500 rid=0.1060
          latency_high_mark=10000 latency_low_mark=9950
          bandwidth_limit=none
state:    state=ACTIVE
          synchronous=off latencyprot=off srlprot=autodcm
assoc:    rvg=testrvg
          remote_host=rhas-2 IP_addr=192.168.1.188 port=4145
          remote_dg=drrhtest
          remote_dg_dgid=1321632517.5.rhas-2.savas.lokal
          remote_rvg_version=30
          remote_rlink=sec-to-pri
          remote_rlink_rid=0.1057
          local_host=rhas-1 IP_addr=192.168.1.187 port=4145
protocol: TCP/IP
flags:    write enabled attached consistent disconnected
 
Rvg:      testrvg
info:     rid=0.1053 version=2 rvg_version=30 last_tag=1
state:    state=ACTIVE kernel=ENABLED
assoc:    datavols=rhtestVol
          srl=rhtestSRL
          rlinks=pri-to-sec
          exports=(none)
          vsets=(none)
att:      rlinks=pri-to-sec
flags:    closed secondary enabled attached
device:   minor=65532 bdev=199/65532 cdev=199/65532 path=/dev/vx/dsk/rhtest/testrvg
perms:    user=root group=root mode=0600
 
 
[root@rhas-2 ~]# vxprint -lPV
Disk group: drrhtest
 
Rlink:    sec-to-pri
info:     timeout=500 rid=0.1057
          latency_high_mark=10000 latency_low_mark=9950
          bandwidth_limit=none
state:    state=ACTIVE
          synchronous=off latencyprot=off srlprot=autodcm
assoc:    rvg=testrvg
          remote_host=rhas-1 IP_addr=192.168.1.187 port=4145
          remote_dg=rhtest
          remote_dg_dgid=1321632497.5.rhas-1.savas.lokal
          remote_rvg_version=30
          remote_rlink=pri-to-sec
          remote_rlink_rid=0.1060
          local_host=rhas-2 IP_addr=127.0.0.1 port=4145
protocol: TCP/IP
flags:    write enabled attached consistent disconnected asynchronous
 
Rvg:      testrvg
info:     rid=0.1053 version=2 rvg_version=30 last_tag=1
state:    state=ACTIVE kernel=ENABLED
assoc:    datavols=rhtestVol
          srl=rhtestSRL
          rlinks=sec-to-pri
          exports=(none)
          vsets=(none)
att:      rlinks=sec-to-pri
flags:    closed primary enabled attached
device:   minor=65532 bdev=199/65532 cdev=199/65532 path=/dev/vx/dsk/drrhtest/testrvg
perms:    user=root group=root mode=0600
 
After re-setting the primary and secondary hosts:
[root@rhas-2 ~]# vradmin -g drrhtest changeip testrvg rhas-1 newpri=rhas-2 newsec=rhas-1
Message from Primary:
VxVM VVR vxrlink INFO V-5-1-3614 Secondary data volumes detected with rvg testrvg as parent:
VxVM VVR vxrlink INFO V-5-1-6183 rhtestVol:    len=16777216             primary_datavol=rhtestVol
 
Replication started to work!
 

This has been a good practice for me, to use new hostnames & ip addresses for replication instead of the original ones...

Thanks again!

 
Savas.