Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

VxFS fails after update to RHEL 6.3

Created: 09 Aug 2012 • Updated: 10 Aug 2012 | 4 comments
AAlmroth's picture
This issue has been solved. See solution.

Hi,

I'm seeing a problem with vxportal kernel module failing to load upon boot after upgrading RHEL 6.1 to 6.3. SFHA is on 6.0.

I found a technote (http://www.symantec.com/docs/TECH171002) but it does not seem to be this RHEL bug.

I've noticed that no vxfs related modules where transferred to /lib/modules/2.6.32-279.2.1.el6.x86_64/veritas/vxfs, they are however present in the previous kernel (131). I tried to copy the modules and rebuild the modules.dep file, but still when running /etc/init.d/vxfs start, I get;

Error in loading module "vxfs". See documentation.
Failed to create /dev/vxportal
ERROR: Module fdd does not exist in /proc/modules
ERROR: Module vxportal does not exist in /proc/modules
ERROR: Module vxfs does not exist in /proc/modules

So, either something went wrong during the RHEL upgrade (vxfs modules were not handled), or vxfs has a problem with RHEL 6.3.

All other modules, such as vxio, vxdmp loads fine;

vxspec                  3398  8
vxio                 3714530  1 vxspec
vxdmp                 404274  12 vxspec,vxio

So, I tried to apply 6.0RP1, but the vxfs patch fails, and all other patches are successfully applied.

The following patches were installed on traci:

        VRTSvxvm
        VRTSob
        VRTSfsadv
        VRTSamf
        VRTSvcs
        VRTSvbs
        VRTSsfcpi60

The following patches failed to install on traci:

        VRTSvxfs

So, my question is if anyone of you have experienced this issue? Or am I to open a support case for a new issue?

/A

Comments 4 CommentsJump to latest comment

TonyGriffiths's picture

Hi,

SFHA 6.0 is not compatible with RHEL 6.3 due to a symbol changes, please see the late breaking news technote below:

http://www.symantec.com/docs/TECH164885

This should be resolved in SFHA 6.0.1, which should release in September timeframe

cheers

tony

SOLUTION
AAlmroth's picture

Thanks for the info! We will look at alternatives to live with this until September then, as downgrade to RHEL 6.2 is not possible...

/A

278398733@qq.com's picture

so for SF6.0,you mean that REHL6.3 is enable,part of installion was failled when i try to install it .by the way,SF6.0 is ok forREHL6.2?

but see

Veritas Storage Foundation™
Release Notes
Linux
6.0
March

--------------Page 31

System requirements
The following topics describe the system requirements for this release:
Supported Linux operating systems
This section lists the supported operating systems for this release of Veritas
products.
Table 1-4 shows the supported Linux operating systems for this release.
Storage Foundation Release Notes
No longer supported
 

Operating systems Levels Kernel version Chipsets
64-bit x86,
EMT*/Opteron 4.1
64-bit only
2.6.32-131.0.15.el6
2.6.32-220.el6
Red Hat Enterprise Linux 6 Update 1, 2

i hope someone can help me solve the problem ,so communiacation is all world! haha~

TonyGriffiths's picture

Just a following up with regards to RHEL 6.3 support

Storage Foundation & High Availability Solutions 6.0.1 is now available and includes support for 6.3.

It can be downloaded from Fileconnect (you will need your FileConnect Serial number)

https://fileconnect.symantec.com/LangSelection.jsp

cheers

tony